Update to version 1.14.0; Fixes RHBZ#2061068

This commit is contained in:
Fabio Valentini 2022-08-08 18:18:32 +02:00
parent 1082abfef2
commit baeab99834
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF
6 changed files with 100 additions and 27 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/hyperfine-1.10.0.crate
/hyperfine-1.11.0.crate
/hyperfine-1.12.0.crate
/hyperfine-1.14.0.crate

63
LICENSE.dependencies Normal file
View File

@ -0,0 +1,63 @@
Apache-2.0 OR BSL-1.0: ryu v1.0.11
Apache-2.0 OR MIT: indexmap v1.9.1
MIT OR Apache-2.0: anyhow v1.0.59
MIT OR Apache-2.0: arrayvec v0.7.2
MIT OR Apache-2.0: bitflags v1.3.2
MIT OR Apache-2.0: bstr v0.2.17
MIT OR Apache-2.0: cfg-if v1.0.0
MIT OR Apache-2.0: clap v3.2.16
MIT OR Apache-2.0: clap_lex v0.2.4
MIT OR Apache-2.0: getrandom v0.2.7
MIT OR Apache-2.0: hashbrown v0.12.3
MIT OR Apache-2.0: hyperfine v1.14.0
MIT OR Apache-2.0: itoa v0.4.8
MIT OR Apache-2.0: itoa v1.0.3
MIT OR Apache-2.0: lazy_static v1.4.0
MIT OR Apache-2.0: libc v0.2.127
MIT OR Apache-2.0: num v0.3.1
MIT OR Apache-2.0: num-bigint v0.3.3
MIT OR Apache-2.0: num-complex v0.3.1
MIT OR Apache-2.0: num-integer v0.1.45
MIT OR Apache-2.0: num-iter v0.1.43
MIT OR Apache-2.0: num-rational v0.3.2
MIT OR Apache-2.0: num-traits v0.2.15
MIT OR Apache-2.0: once_cell v1.13.0
MIT OR Apache-2.0: os_str_bytes v6.2.0
MIT OR Apache-2.0: ppv-lite86 v0.2.16
MIT OR Apache-2.0: rand v0.6.5
MIT OR Apache-2.0: rand v0.8.5
MIT OR Apache-2.0: rand_chacha v0.1.1
MIT OR Apache-2.0: rand_chacha v0.3.1
MIT OR Apache-2.0: rand_core v0.3.1
MIT OR Apache-2.0: rand_core v0.4.2
MIT OR Apache-2.0: rand_core v0.6.3
MIT OR Apache-2.0: rand_hc v0.1.0
MIT OR Apache-2.0: rand_isaac v0.1.1
MIT OR Apache-2.0: rand_jitter v0.1.4
MIT OR Apache-2.0: rand_os v0.1.3
MIT OR Apache-2.0: rand_pcg v0.1.2
MIT OR Apache-2.0: rand_xorshift v0.1.1
MIT OR Apache-2.0: regex v1.6.0
MIT OR Apache-2.0: regex-syntax v0.6.27
MIT OR Apache-2.0: serde v1.0.141
MIT OR Apache-2.0: serde_json v1.0.83
MIT OR Apache-2.0: shell-words v1.1.0
MIT OR Apache-2.0: terminal_size v0.1.17
MIT OR Apache-2.0: thiserror v1.0.32
MIT: atty v0.2.14
MIT: console v0.15.1
MIT: indicatif v0.16.2
MIT: memoffset v0.6.5
MIT: nix v0.24.2
MIT: number_prefix v0.4.0
MIT: rust_decimal v1.26.1
MIT: statistical v1.0.0
MIT: strsim v0.10.0
MIT: textwrap v0.15.0
MPL-2.0: colored v2.0.0
Unlicense OR MIT: aho-corasick v0.7.18
Unlicense OR MIT: csv v1.1.6
Unlicense OR MIT: csv-core v0.1.10
Unlicense OR MIT: memchr v2.5.0
Unlicense OR MIT: regex-automata v0.1.10
Unlicense OR MIT: termcolor v1.1.3

View File

@ -0,0 +1,13 @@
--- hyperfine-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hyperfine-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -100,10 +100,3 @@
version = "0.24.1"
features = ["zerocopy"]
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = [
- "processthreadsapi",
- "minwindef",
- "winnt",
-]

View File

@ -1,9 +0,0 @@
--- hyperfine-1.12.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hyperfine-1.12.0/Cargo.toml 2022-01-12T15:09:08.188113+00:00
@@ -76,6 +76,3 @@
version = "2"
[target."cfg(not(windows))".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["processthreadsapi", "minwindef", "winnt"]

View File

@ -1,24 +1,24 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 22
%bcond_without check
%global crate hyperfine
Name: rust-%{crate}
Version: 1.12.0
Name: rust-hyperfine
Version: 1.14.0
Release: %autorelease
Summary: Command-line benchmarking tool
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/hyperfine
Source: %{crates_source}
# Initial patched metadata
# * drop windows-specific dependencies
Patch0: hyperfine-fix-metadata.diff
Source0: %{crates_source}
Source1: LICENSE.dependencies
# Automatically generated patch to strip foreign dependencies
Patch: hyperfine-fix-metadata-auto.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Command-line benchmarking tool.}
@ -27,19 +27,23 @@ Command-line benchmarking tool.}
%package -n %{crate}
Summary: %{summary}
# ASL 2.0 or Boost
# ASL 2.0 or MIT
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# MIT
# MIT or ASL 2.0
# MPLv2.0
# Unlicense or MIT
License: MIT and MPLv2.0 and (ASL 2.0 or Boost)
# MIT OR Apache-2.0
# MPL-2.0
# Unlicense OR MIT
License: MIT AND MPL-2.0 AND (Apache-2.0 OR BSL-1.0)
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md README.md
%license LICENSE-APACHE
%license LICENSE-MIT
%license LICENSE.dependencies
%doc CHANGELOG.md
%doc README.md
%{_bindir}/hyperfine
%{_mandir}/man1/hyperfine.1*
%dir %{_datadir}/bash-completion
@ -54,6 +58,7 @@ License: MIT and MPLv2.0 and (ASL 2.0 or Boost)
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
cp %{SOURCE1} .
%cargo_prep
%generate_buildrequires

View File

@ -1 +1 @@
SHA512 (hyperfine-1.12.0.crate) = 3340f47ee21457270a166a08b6dcc9d253ea481f91a401c29b59b88d3a5ae561e087447dc1b3b01e7f6f2307ea613025c9dd474d473bbd24e413b3cbe5b5dffa
SHA512 (hyperfine-1.14.0.crate) = e82a0c516663b6d78183d13606a18eed98bbb05f8145c3e93361510303991a34cfd27e1d570621ead61684bde9bc0fd7c472111c2c974f330fc06f27d83de169