Update to 1.6.0
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
8b1542c2fc
commit
6370295c77
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/hyperfine-1.5.0.crate
|
||||
/hyperfine-1.6.0.crate
|
||||
|
@ -1,24 +1,9 @@
|
||||
--- hyperfine-1.5.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ hyperfine-1.5.0/Cargo.toml 2019-02-10T16:02:01.441064+01:00
|
||||
@@ -38,7 +38,7 @@
|
||||
version = "1.0.0"
|
||||
|
||||
[dependencies.indicatif]
|
||||
-version = "0.9"
|
||||
+version = "0.11"
|
||||
|
||||
[dependencies.serde]
|
||||
version = "1.0.82"
|
||||
@@ -50,11 +50,8 @@
|
||||
version = "1.0.33"
|
||||
|
||||
[dependencies.statistical]
|
||||
-version = "0.1"
|
||||
+version = "1.0"
|
||||
[dev-dependencies.approx]
|
||||
--- hyperfine-1.6.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ hyperfine-1.6.0/Cargo.toml 2019-06-09T11:46:59.345295+00:00
|
||||
@@ -54,6 +54,3 @@
|
||||
version = "0.3"
|
||||
[target."cfg(not(windows))".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3.4"
|
||||
-version = "0.3.7"
|
||||
-features = ["processthreadsapi", "minwindef", "winnt"]
|
||||
|
@ -1,11 +1,12 @@
|
||||
# Generated by rust2rpm
|
||||
# Generated by rust2rpm 9
|
||||
%bcond_without check
|
||||
%global __cargo_skip_build 0
|
||||
|
||||
%global crate hyperfine
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.5.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.6.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Command-line benchmarking tool
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
@ -13,40 +14,38 @@ License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/hyperfine
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Bump indicatif to 0.11, https://github.com/sharkdp/hyperfine/commit/dfba8883e3cf4234bc9ae5b05d21d3c8c0c7cda3
|
||||
# * Bump statistical to 1.0, https://github.com/sharkdp/hyperfine/commit/3f6e38708e04e27ecb9f6700c2910f124b1ee497
|
||||
# * No windows
|
||||
Patch0: hyperfine-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(atty/default) >= 0.2.2 with crate(atty/default) < 0.3.0)
|
||||
BuildRequires: (crate(cfg-if/default) >= 0.1.6 with crate(cfg-if/default) < 0.2.0)
|
||||
BuildRequires: (crate(cfg-if/default) >= 0.1.9 with crate(cfg-if/default) < 0.2.0)
|
||||
BuildRequires: (crate(clap/color) >= 2.0.0 with crate(clap/color) < 3.0.0)
|
||||
BuildRequires: (crate(clap/suggestions) >= 2.0.0 with crate(clap/suggestions) < 3.0.0)
|
||||
BuildRequires: (crate(clap/wrap_help) >= 2.0.0 with crate(clap/wrap_help) < 3.0.0)
|
||||
BuildRequires: (crate(colored/default) >= 1.6.0 with crate(colored/default) < 2.0.0)
|
||||
BuildRequires: (crate(csv/default) >= 1.0.0 with crate(csv/default) < 2.0.0)
|
||||
BuildRequires: (crate(colored/default) >= 1.8.0 with crate(colored/default) < 2.0.0)
|
||||
BuildRequires: (crate(csv/default) >= 1.0.7 with crate(csv/default) < 2.0.0)
|
||||
BuildRequires: (crate(indicatif/default) >= 0.11.0 with crate(indicatif/default) < 0.12.0)
|
||||
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
|
||||
BuildRequires: (crate(serde/default) >= 1.0.82 with crate(serde/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde_derive/default) >= 1.0.82 with crate(serde_derive/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde_json/default) >= 1.0.33 with crate(serde_json/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde/default) >= 1.0.92 with crate(serde/default) < 2.0.0)
|
||||
BuildRequires: (crate(serde/derive) >= 1.0.92 with crate(serde/derive) < 2.0.0)
|
||||
BuildRequires: (crate(serde_json/default) >= 1.0.39 with crate(serde_json/default) < 2.0.0)
|
||||
BuildRequires: (crate(statistical/default) >= 1.0.0 with crate(statistical/default) < 2.0.0)
|
||||
%if %{with check}
|
||||
BuildRequires: (crate(approx/default) >= 0.3.0 with crate(approx/default) < 0.4.0)
|
||||
%endif
|
||||
|
||||
%global _description \
|
||||
A command-line benchmarking tool.
|
||||
%global _description %{expand:
|
||||
Command-line benchmarking tool.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n %{crate}
|
||||
%{summary}.
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
@ -69,6 +68,9 @@ Summary: %{summary}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jun 09 13:46:06 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.6.0-1
|
||||
- Update to 1.6.0
|
||||
|
||||
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.5.0-3
|
||||
- Bump statistical to 1.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hyperfine-1.5.0.crate) = 8428bcd65305a95ca7d48c9a7a465dbecdb07a2a08b4df3327c2df4c6cf71cc5fd3af8bfbf1730668750dd9d14885b02850c3c59a407c8395a1a2b3e8ef8c84f
|
||||
SHA512 (hyperfine-1.6.0.crate) = db300171a9a22c0d9c1bb3dddc0872acbda7ec416d65274f2542403ab5ac8cd430585d3e80e5c803b1b11a6375a0752185dc2a38ef2e491c4a72a5ce71cf0a16
|
||||
|
Loading…
Reference in New Issue
Block a user