Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2019-01-29 18:03:26 +01:00
parent 5dbe465e33
commit 4fe7b69290
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
7 changed files with 112 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/hyperfine-1.5.0.crate

View File

@ -0,0 +1,18 @@
--- hyperfine-1.5.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ hyperfine-1.5.0/Cargo.toml 2019-01-28T16:22:22.556455+01:00
@@ -38,7 +38,7 @@
version = "1.0.0"
[dependencies.indicatif]
-version = "0.9"
+version = "0.11"
[dependencies.serde]
version = "1.0.82"
@@ -55,6 +55,3 @@
version = "0.3"
[target."cfg(not(windows))".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.4"
-features = ["processthreadsapi", "minwindef", "winnt"]

73
rust-hyperfine.spec Normal file
View File

@ -0,0 +1,73 @@
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global crate hyperfine
Name: rust-%{crate}
Version: 1.5.0
Release: 1%{?dist}
Summary: Command-line benchmarking tool
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/hyperfine
Source: %{crates_source}
# Initial patched metadata
# * Bump indicatif to 0.11, https://github.com/sharkdp/hyperfine/commit/dfba8883e3cf4234bc9ae5b05d21d3c8c0c7cda3
Patch0: hyperfine-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(atty/default) >= 0.2.2 with crate(atty/default) < 0.3.0)
BuildRequires: (crate(cfg-if/default) >= 0.1.6 with crate(cfg-if/default) < 0.2.0)
BuildRequires: (crate(clap/color) >= 2.0.0 with crate(clap/color) < 3.0.0)
BuildRequires: (crate(clap/suggestions) >= 2.0.0 with crate(clap/suggestions) < 3.0.0)
BuildRequires: (crate(clap/wrap_help) >= 2.0.0 with crate(clap/wrap_help) < 3.0.0)
BuildRequires: (crate(colored/default) >= 1.6.0 with crate(colored/default) < 2.0.0)
BuildRequires: (crate(csv/default) >= 1.0.0 with crate(csv/default) < 2.0.0)
BuildRequires: (crate(indicatif/default) >= 0.11.0 with crate(indicatif/default) < 0.12.0)
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(serde/default) >= 1.0.82 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.82 with crate(serde_derive/default) < 2.0.0)
BuildRequires: (crate(serde_json/default) >= 1.0.33 with crate(serde_json/default) < 2.0.0)
BuildRequires: (crate(statistical/default) >= 0.1.0 with crate(statistical/default) < 0.2.0)
%if %{with check}
BuildRequires: (crate(approx/default) >= 0.3.0 with crate(approx/default) < 0.4.0)
%endif
%global _description \
A command-line benchmarking tool.
%description %{_description}
%package -n %{crate}
Summary: %{summary}
%description -n %{crate}
%{summary}.
%files -n %{crate}
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{_bindir}/hyperfine
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 28 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.5.0-1
- Initial package

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (hyperfine-1.5.0.crate) = 8428bcd65305a95ca7d48c9a7a465dbecdb07a2a08b4df3327c2df4c6cf71cc5fd3af8bfbf1730668750dd9d14885b02850c3c59a407c8395a1a2b3e8ef8c84f

1
tests/.fmf/version Normal file
View File

@ -0,0 +1 @@
1

5
tests/provision.fmf Normal file
View File

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

13
tests/tests.yml Normal file
View File

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-hyperfine