Update to version 1.16.1; Fixes RHBZ#2124811

This commit is contained in:
Fabio Valentini 2023-03-27 11:41:06 +02:00
parent c23aab66d5
commit 0852fce1e0
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF
6 changed files with 39 additions and 97 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/hyperfine-1.11.0.crate
/hyperfine-1.12.0.crate
/hyperfine-1.14.0.crate
/hyperfine-1.16.1.crate

View File

@ -1,63 +0,0 @@
Apache-2.0 OR BSL-1.0: ryu v1.0.11
Apache-2.0 OR MIT: indexmap v1.9.1
MIT OR Apache-2.0: anyhow v1.0.59
MIT OR Apache-2.0: arrayvec v0.7.2
MIT OR Apache-2.0: bitflags v1.3.2
MIT OR Apache-2.0: bstr v0.2.17
MIT OR Apache-2.0: cfg-if v1.0.0
MIT OR Apache-2.0: clap v3.2.16
MIT OR Apache-2.0: clap_lex v0.2.4
MIT OR Apache-2.0: getrandom v0.2.7
MIT OR Apache-2.0: hashbrown v0.12.3
MIT OR Apache-2.0: hyperfine v1.14.0
MIT OR Apache-2.0: itoa v0.4.8
MIT OR Apache-2.0: itoa v1.0.3
MIT OR Apache-2.0: lazy_static v1.4.0
MIT OR Apache-2.0: libc v0.2.127
MIT OR Apache-2.0: num v0.3.1
MIT OR Apache-2.0: num-bigint v0.3.3
MIT OR Apache-2.0: num-complex v0.3.1
MIT OR Apache-2.0: num-integer v0.1.45
MIT OR Apache-2.0: num-iter v0.1.43
MIT OR Apache-2.0: num-rational v0.3.2
MIT OR Apache-2.0: num-traits v0.2.15
MIT OR Apache-2.0: once_cell v1.13.0
MIT OR Apache-2.0: os_str_bytes v6.2.0
MIT OR Apache-2.0: ppv-lite86 v0.2.16
MIT OR Apache-2.0: rand v0.6.5
MIT OR Apache-2.0: rand v0.8.5
MIT OR Apache-2.0: rand_chacha v0.1.1
MIT OR Apache-2.0: rand_chacha v0.3.1
MIT OR Apache-2.0: rand_core v0.3.1
MIT OR Apache-2.0: rand_core v0.4.2
MIT OR Apache-2.0: rand_core v0.6.3
MIT OR Apache-2.0: rand_hc v0.1.0
MIT OR Apache-2.0: rand_isaac v0.1.1
MIT OR Apache-2.0: rand_jitter v0.1.4
MIT OR Apache-2.0: rand_os v0.1.3
MIT OR Apache-2.0: rand_pcg v0.1.2
MIT OR Apache-2.0: rand_xorshift v0.1.1
MIT OR Apache-2.0: regex v1.6.0
MIT OR Apache-2.0: regex-syntax v0.6.27
MIT OR Apache-2.0: serde v1.0.141
MIT OR Apache-2.0: serde_json v1.0.83
MIT OR Apache-2.0: shell-words v1.1.0
MIT OR Apache-2.0: terminal_size v0.1.17
MIT OR Apache-2.0: thiserror v1.0.32
MIT: atty v0.2.14
MIT: console v0.15.1
MIT: indicatif v0.16.2
MIT: memoffset v0.6.5
MIT: nix v0.24.2
MIT: number_prefix v0.4.0
MIT: rust_decimal v1.26.1
MIT: statistical v1.0.0
MIT: strsim v0.10.0
MIT: textwrap v0.15.0
MPL-2.0: colored v2.0.0
Unlicense OR MIT: aho-corasick v0.7.18
Unlicense OR MIT: csv v1.1.6
Unlicense OR MIT: csv-core v0.1.10
Unlicense OR MIT: memchr v2.5.0
Unlicense OR MIT: regex-automata v0.1.10
Unlicense OR MIT: termcolor v1.1.3

View File

@ -1,3 +0,0 @@
# rust-hyperfine
The rust-hyperfine package

View File

@ -1,7 +1,17 @@
--- hyperfine-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hyperfine-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -100,10 +100,3 @@
version = "0.24.1"
--- hyperfine-1.16.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ hyperfine-1.16.1/Cargo.toml 2023-03-27T09:24:23.791230+00:00
@@ -100,9 +100,6 @@
[features]
windows_process_extensions_main_thread_handle = []
-[target."cfg(all(windows, not(windows_process_extensions_main_thread_handle)))".dependencies.once_cell]
-version = "1.17"
-
[target."cfg(not(windows))".dependencies.libc]
version = "0.2"
@@ -110,13 +107,3 @@
version = "0.26.2"
features = ["zerocopy"]
-[target."cfg(windows)".dependencies.winapi]
@ -10,4 +20,7 @@
- "processthreadsapi",
- "minwindef",
- "winnt",
- "jobapi2",
- "tlhelp32",
- "handleapi",
-]

View File

@ -1,27 +1,24 @@
# Generated by rust2rpm 22
# Generated by rust2rpm 24
%bcond_without check
%global crate hyperfine
Name: rust-hyperfine
Version: 1.14.0
Version: 1.16.1
Release: %autorelease
Summary: Command-line benchmarking tool
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/hyperfine
Source0: %{crates_source}
Source1: LICENSE.dependencies
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: hyperfine-fix-metadata-auto.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
BuildRequires: rust-packaging >= 23
%global _description %{expand:
Command-line benchmarking tool.}
A command-line benchmarking tool.}
%description %{_description}
@ -29,6 +26,7 @@ Command-line benchmarking tool.}
Summary: %{summary}
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# MIT
# MIT OR Apache-2.0
# MPL-2.0
@ -46,19 +44,12 @@ License: MIT AND MPL-2.0 AND (Apache-2.0 OR BSL-1.0)
%doc README.md
%{_bindir}/hyperfine
%{_mandir}/man1/hyperfine.1*
%dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/hyperfine.bash
%dir %{_datadir}/fish
%dir %{_datadir}/fish/vendor_completions.d
%{_datadir}/fish/vendor_completions.d/hyperfine.fish
%dir %{_datadir}/zsh
%dir %{_datadir}/zsh/site-functions
%{_datadir}/zsh/site-functions/_hyperfine
%{bash_completions_dir}/hyperfine.bash
%{fish_completions_dir}/hyperfine.fish
%{zsh_completions_dir}/_hyperfine
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
cp %{SOURCE1} .
%cargo_prep
%generate_buildrequires
@ -66,17 +57,20 @@ cp %{SOURCE1} .
%build
%cargo_build
%cargo_license_summary
%{cargo_license} > LICENSE.dependencies
%install
%cargo_install
install -Dpm0644 -t %{buildroot}%{_mandir}/man1 \
doc/hyperfine.1
install -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
target/release/build/%{crate}-*/out/hyperfine.bash
install -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
target/release/build/%{crate}-*/out/hyperfine.fish
install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
target/release/build/%{crate}-*/out/_hyperfine
# install manpage
install -Dpm 0644 doc/hyperfine.1 -t %{buildroot}/%{_mandir}/man1
# install shell completions
install -Dpm 0644 target/release/build/%{crate}-*/out/hyperfine.bash \
-t %{buildroot}/%{bash_completions_dir}
install -Dpm 0644 target/release/build/%{crate}-*/out/hyperfine.fish \
-t %{buildroot}/%{fish_completions_dir}
install -Dpm 0644 target/release/build/%{crate}-*/out/_hyperfine \
-t %{buildroot}/%{zsh_completions_dir}
%if %{with check}
%check

View File

@ -1 +1 @@
SHA512 (hyperfine-1.14.0.crate) = e82a0c516663b6d78183d13606a18eed98bbb05f8145c3e93361510303991a34cfd27e1d570621ead61684bde9bc0fd7c472111c2c974f330fc06f27d83de169
SHA512 (hyperfine-1.16.1.crate) = 9540b4e1270132f04837cccf8d7f94da457758b9d328b254dbe963d3b5b609c1928db2331d8bc3ba728603b1e293928e2610154d13e9f4ffc8b50b874765bb88