102 lines
2.3 KiB
RPMSpec
102 lines
2.3 KiB
RPMSpec
# Generated by rust2rpm 22
|
|
%bcond_without check
|
|
|
|
%global crate hexyl
|
|
|
|
Name: rust-hexyl
|
|
Version: 0.10.0
|
|
Release: %autorelease
|
|
Summary: Command-line hex viewer
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/hexyl
|
|
Source0: %{crates_source}
|
|
Source1: LICENSE.dependencies
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * exclude binary test data from packaged files
|
|
Patch: hexyl-fix-metadata.diff
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
hexyl is a simple hex viewer for the terminal. It uses a colored output to
|
|
distinguish different categories of bytes (NUL bytes, printable ASCII
|
|
characters, ASCII whitespace characters, other ASCII characters and non-ASCII).}
|
|
|
|
%description %{_description}
|
|
|
|
%package -n %{crate}
|
|
Summary: %{summary}
|
|
# Apache-2.0 OR MIT
|
|
# MIT
|
|
# MIT OR Apache-2.0
|
|
# Unlicense OR MIT
|
|
# Zlib
|
|
License: MIT AND Zlib
|
|
# LICENSE.dependencies contains a full license breakdown
|
|
|
|
%description -n %{crate} %{_description}
|
|
|
|
%files -n %{crate}
|
|
%license LICENSE-APACHE
|
|
%license LICENSE-MIT
|
|
%license LICENSE.dependencies
|
|
%doc CHANGELOG.md
|
|
%doc CONTRIBUTING.md
|
|
%doc README.md
|
|
%{_bindir}/hexyl
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/CONTRIBUTING.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
cp %{SOURCE1} .
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|