update to version 8.2.1

This commit is contained in:
Fabio Valentini 2021-01-12 23:06:28 +01:00
parent ac4dd1a470
commit 78d394febf
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF
5 changed files with 26 additions and 19 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/fd-find-8.0.0.crate
/fd-find-8.1.0.crate
/fd-find-8.1.1.crate
/fd-find-8.2.1.crate

View File

@ -12,22 +12,24 @@ Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
1 file changed, 6 deletions(-)
diff --git a/src/main.rs b/src/main.rs
index 6ffa277..aee72ce 100644
index 5208765..ced87f0 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -32,12 +32,6 @@ use crate::filter::{SizeFilter, TimeFilter};
@@ -32,17 +32,6 @@ use crate::filter::{SizeFilter, TimeFilter};
use crate::options::Options;
use crate::regex_helper::pattern_has_uppercase_char;
use crate::regex_helper::{pattern_has_uppercase_char, pattern_matches_strings_with_leading_dot};
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
-// FIXME: re-enable jemalloc on macOS, see comment in Cargo.toml file for more infos
-#[cfg(all(not(windows), not(target_os = "macos"), not(target_env = "musl")))]
-#[cfg(all(
- not(windows),
- not(target_os = "android"),
- not(target_os = "macos"),
- not(target_env = "musl")
-))]
-#[global_allocator]
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
-
fn run() -> Result<ExitCode> {
let matches = app::build_app().get_matches_from(env::args_os());
--
2.26.2
// vivid --color-mode 8-bit generate molokai
const DEFAULT_LS_COLORS: &str = "
ow=0:or=0;38;5;16;48;5;203:no=0:ex=1;38;5;203:cd=0;38;5;203;48;5;236:mi=0;38;5;16;48;5;203:*~=0;38;5;243:st=0:pi=0;38;5;16;48;5;81:fi=0:di=0;38;5;81:so=0;38;5;16;48;5;203:bd=0;38;5;81;48;5;236:tw=0:ln=0;38;5;203:*.m=0;38;5;48:*.o=0;38;5;243:*.z=4;38;5;203:*.a=1;38;5;203:*.r=0;38;5;48:*.c=0;38;5;48:*.d=0;38;5;48:*.t=0;38;5;48:*.h=0;38;5;48:*.p=0;38;5;48:*.cc=0;38;5;48:*.ll=0;38;5;48:*.jl=0;38;5;48:*css=0;38;5;48:*.md=0;38;5;185:*.gz=4;38;5;203:*.nb=0;38;5;48:*.mn=0;38;5;48:*.go=0;38;5;48:*.xz=4;38;5;203:*.so=1;38;5;203:*.rb=0;38;5;48:*.pm=0;38;5;48:*.bc=0;38;5;243:*.py=0;38;5;48:*.as=0;38;5;48:*.pl=0;38;5;48:*.rs=0;38;5;48:*.sh=0;38;5;48:*.7z=4;38;5;203:*.ps=0;38;5;186:*.cs=0;38;5;48:*.el=0;38;5;48:*.rm=0;38;5;208:*.hs=0;38;5;48:*.td=0;38;5;48:*.ui=0;38;5;149:*.ex=0;38;5;48:*.js=0;38;5;48:*.cp=0;38;5;48:*.cr=0;38;5;48:*.la=0;38;5;243:*.kt=0;38;5;48:*.ml=0;38;5;48:*.vb=0;38;5;48:*.gv=0;38;5;48:*.lo=0;38;5;243:*.hi=0;38;5;243:*.ts=0;38;5;48:*.ko=1;38;5;203:*.hh=0;38;5;48:*.pp=0;38;5;48:*.di=0;38;5;48:*.bz=4;38;5;203:*.fs=0;38;5;48:*.png=0;38;5;208:*.zsh=0;38;5;48:*.mpg=0;38;5;208:*.pid=0;38;5;243:*.xmp=0;38;5;149:*.iso=4;38;5;203:*.m4v=0;38;5;208:*.dot=0;38;5;48:*.ods=0;38;5;186:*.inc=0;38;5;48:*.sxw=0;38;5;186:*.aif=0;38;5;208:*.git=0;38;5;243:*.gvy=0;38;5;48:*.tbz=4;38;5;203:*.log=0;38;5;243:*.txt=0;38;5;185:*.ico=0;38;5;208:*.csx=0;38;5;48:*.vob=0;38;5;208:*.pgm=0;38;5;208:*.pps=0;38;5;186:*.ics=0;38;5;186:*.img=4;38;5;203:*.fon=0;38;5;208:*.hpp=0;38;5;48:*.bsh=0;38;5;48:*.sql=0;38;5;48:*TODO=1:*.php=0;38;5;48:*.pkg=4;38;5;203:*.ps1=0;38;5;48:*.csv=0;38;5;185:*.ilg=0;38;5;243:*.ini=0;38;5;149:*.pyc=0;38;5;243:*.psd=0;38;5;208:*.htc=0;38;5;48:*.swp=0;38;5;243:*.mli=0;38;5;48:*hgrc=0;38;5;149:*.bst=0;38;5;149:*.ipp=0;38;5;48:*.fsi=0;38;5;48:*.tcl=0;38;5;48:*.exs=0;38;5;48:*.out=0;38;5;243:*.jar=4;38;5;203:*.xls=0;38;5;186:*.ppm=0;38;5;208:*.apk=4;38;5;203:*.aux=0;38;5;243:*.rpm=4;38;5;203:*.dll=1;38;5;203:*.eps=0;38;5;208:*.exe=1;38;5;203:*.doc=0;38;5;186:*.wma=0;38;5;208:*.deb=4;38;5;203:*.pod=0;38;5;48:*.ind=0;38;5;243:*.nix=0;38;5;149:*.lua=0;38;5;48:*.epp=0;38;5;48:*.dpr=0;38;5;48:*.htm=0;38;5;185:*.ogg=0;38;5;208:*.bin=4;38;5;203:*.otf=0;38;5;208:*.yml=0;38;5;149:*.pro=0;38;5;149:*.cxx=0;38;5;48:*.tex=0;38;5;48:*.fnt=0;38;5;208:*.erl=0;38;5;48:*.sty=0;38;5;243:*.bag=4;38;5;203:*.rst=0;38;5;185:*.pdf=0;38;5;186:*.pbm=0;38;5;208:*.xcf=0;38;5;208:*.clj=0;38;5;48:*.gif=0;38;5;208:*.rar=4;38;5;203:*.elm=0;38;5;48:*.bib=0;38;5;149:*.tsx=0;38;5;48:*.dmg=4;38;5;203:*.tmp=0;38;5;243:*.bcf=0;38;5;243:*.mkv=0;38;5;208:*.svg=0;38;5;208:*.cpp=0;38;5;48:*.vim=0;38;5;48:*.bmp=0;38;5;208:*.ltx=0;38;5;48:*.fls=0;38;5;243:*.flv=0;38;5;208:*.wav=0;38;5;208:*.m4a=0;38;5;208:*.mid=0;38;5;208:*.hxx=0;38;5;48:*.pas=0;38;5;48:*.wmv=0;38;5;208:*.tif=0;38;5;208:*.kex=0;38;5;186:*.mp4=0;38;5;208:*.bak=0;38;5;243:*.xlr=0;38;5;186:*.dox=0;38;5;149:*.swf=0;38;5;208:*.tar=4;38;5;203:*.tgz=4;38;5;203:*.cfg=0;38;5;149:*.xml=0;

View File

@ -1,10 +1,10 @@
--- fd-find-8.1.1/Cargo.toml 2020-05-25T14:16:36+00:00
+++ fd-find-8.1.1/Cargo.toml 2020-05-25T15:01:29.677431+00:00
--- fd-find-8.2.1/Cargo.toml 2020-12-07T18:29:12+00:00
+++ fd-find-8.2.1/Cargo.toml 2021-01-12T21:49:10.417251+00:00
@@ -86,8 +86,6 @@
[build-dependencies.version_check]
version = "0.9"
-[target."cfg(all(not(windows), not(target_os = \"macos\"), not(target_env = \"musl\")))".dependencies.jemallocator]
-[target."cfg(all(not(windows), not(target_os = \"android\"), not(target_os = \"macos\"), not(target_env = \"musl\")))".dependencies.jemallocator]
-version = "0.3.0"
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
version = "0.2"

View File

@ -1,12 +1,12 @@
# Generated by rust2rpm 15
# Generated by rust2rpm 16
%bcond_without check
%global __cargo_skip_build 0
%global crate fd-find
Name: rust-%{crate}
Version: 8.1.1
Release: 4%{?dist}
Version: 8.2.1
Release: 1%{?dist}
Summary: Simple, fast and user-friendly alternative to find
# Upstream license specification: MIT/Apache-2.0
@ -40,7 +40,7 @@ License: MIT
%files -n %{crate}
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%doc README.md CHANGELOG.md
%{_bindir}/fd
%{_mandir}/man1/fd.1*
%dir %{_datadir}/bash-completion
@ -72,7 +72,7 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
install -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
target/release/build/%{crate}-*/out/fd.fish
install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
target/release/build/%{crate}-*/out/_fd
contrib/completion/_fd
%if %{with check}
%check
@ -80,6 +80,10 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
%endif
%changelog
* Tue Jan 12 2021 Fabio Valentini <decathorpe@gmail.com> - 8.2.1-1
- Update to version 8.2.1.
- Fixes RHBZ#1904838
* Mon Dec 28 13:29:47 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.1-4
- Rebuild

View File

@ -1 +1 @@
SHA512 (fd-find-8.1.1.crate) = fd9e887940e662337b6b1ff949ed60619e8996b52ff481dcde820d680a3eb9ba6676b710a8b2be7fde6a769089efbf49d857d06d64263965f58592524fff68d5
SHA512 (fd-find-8.2.1.crate) = 3c0930b95769fab4e77794617bab833e4f58021c0e0c4ad78eb589b1b69e71af4db59e33641118ccd860c4fc29af0fcef114ecdd9dbbd43c86cb88001e63a4bc