Update to 6.1.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2017-12-13 21:23:26 +01:00
parent 97c661a98e
commit 45887791b3
2 changed files with 20 additions and 24 deletions

View File

@ -1,32 +1,25 @@
--- fd-find-6.0.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ fd-find-6.0.0/Cargo.toml 2017-11-30T23:43:28.471915+01:00
@@ -28,7 +28,7 @@
name = "fd"
path = "src/main.rs"
--- fd-find-6.1.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ fd-find-6.1.0/Cargo.toml 2017-12-13T21:22:58.398319+01:00
@@ -34,7 +34,7 @@
version = "1"
[dependencies.ansi_term]
-version = "0.9"
+version = "0.10"
[dependencies.regex]
[dependencies.atty]
version = "0.2"
@@ -37,13 +37,13 @@
version = "0.4"
[dependencies.lazy_static]
-version = "0.2.9"
+version = "1"
[dependencies.num_cpus]
version = "1.6.2"
@@ -43,7 +43,7 @@
version = "2.26.0"
[dependencies.ignore]
-version = "0.2"
+version = "0.3"
[dependencies.atty]
version = "0.2"
@@ -62,11 +62,7 @@
version = "2.26.0"
[dependencies.regex-syntax]
version = "0.4"
@@ -65,11 +65,7 @@
version = "0.1.3"
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
@ -34,6 +27,6 @@
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2"
[badges.appveyor]
[badges.travis-ci]
repository = "sharkdp/fd"

View File

@ -4,8 +4,8 @@
%global crate fd-find
Name: rust-%{crate}
Version: 6.0.0
Release: 5%{?dist}
Version: 6.1.0
Release: 1%{?dist}
Summary: Simple, fast and user-friendly alternative to find
License: MIT or ASL 2.0
@ -13,8 +13,7 @@ URL: https://crates.io/crates/fd-find
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump ansi_term to 0.10, ignore to 0.3: https://github.com/sharkdp/fd/pull/173
# * Bump lazy_static to 1, https://github.com/sharkdp/fd/pull/184
Patch0: fd-find-6.0.0-fix-metadata.diff
Patch0: fd-find-6.1.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -23,6 +22,7 @@ BuildRequires: rust-packaging
BuildRequires: (crate(ansi_term) >= 0.10.0 with crate(ansi_term) < 0.11.0)
BuildRequires: (crate(atty) >= 0.2.0 with crate(atty) < 0.3.0)
BuildRequires: (crate(clap) >= 2.26.0 with crate(clap) < 3.0.0)
BuildRequires: (crate(ctrlc) >= 3.0.0 with crate(ctrlc) < 4.0.0)
BuildRequires: (crate(ignore) >= 0.3.0 with crate(ignore) < 0.4.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
@ -85,6 +85,9 @@ Summary: %{summary}
%{_datadir}/zsh/site-functions/_fd
%changelog
* Wed Dec 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.1.0-1
- Update to 6.1.0
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 6.0.0-5
- Bump lazy_static to 1