Update to 8.0.0

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Raits 2020-04-16 11:42:48 +02:00
parent 931cfcdcea
commit 264d784f34
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
5 changed files with 21 additions and 17 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@
/fd-find-7.3.0.crate
/fd-find-7.4.0.crate
/fd-find-7.5.0.crate
/fd-find-8.0.0.crate

View File

@ -1,32 +1,32 @@
From db8cb882fb743a216687abc5cf372302405c1053 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sat, 7 Dec 2019 12:39:53 +0100
From 5425d762550be0025441cb944f8cdcc8275c6b89 Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Thu, 16 Apr 2020 11:44:31 +0200
Subject: [PATCH] Remove usage of jemallocator
It is PITA to package it in Fedora, so we will have to have fd a bit
slower for now.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
---
src/main.rs | 5 -----
1 file changed, 5 deletions(-)
diff --git a/src/main.rs b/src/main.rs
index 426eb08..c4af1ef 100644
index fb64e7a..f8e83db 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -35,11 +35,6 @@ use crate::internal::{
pattern_has_uppercase_char, transform_args_with_exec, FileTypes,
};
@@ -29,11 +29,6 @@ use crate::filter::{SizeFilter, TimeFilter};
use crate::options::Options;
use crate::regex_helper::pattern_has_uppercase_char;
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
-#[cfg(all(not(windows), not(target_env = "musl")))]
-#[global_allocator]
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
-
fn main() {
let checked_args = transform_args_with_exec(env::args_os());
let matches = app::build_app().get_matches_from(checked_args);
fn run() -> Result<ExitCode> {
let matches = app::build_app().get_matches_from(env::args_os());
--
2.24.0
2.26.0

View File

@ -1,6 +1,6 @@
--- fd-find-7.5.0/Cargo.toml 2020-03-22T16:16:10+00:00
+++ fd-find-7.5.0/Cargo.toml 2020-03-22T16:19:41.884071+00:00
@@ -80,8 +80,6 @@
--- fd-find-8.0.0/Cargo.toml 2020-04-16T08:39:41+00:00
+++ fd-find-8.0.0/Cargo.toml 2020-04-16T09:42:05.226160+00:00
@@ -83,8 +83,6 @@
[build-dependencies.version_check]
version = "0.9"

View File

@ -5,7 +5,7 @@
%global crate fd-find
Name: rust-%{crate}
Version: 7.5.0
Version: 8.0.0
Release: 1%{?dist}
Summary: Simple, fast and user-friendly alternative to find
@ -82,6 +82,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
%endif
%changelog
* Thu Apr 16 11:42:05 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.0.0-1
- Update to 8.0.0
* Sun Mar 22 17:19:42 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 7.5.0-1
- Update to 7.5.0

View File

@ -1 +1 @@
SHA512 (fd-find-7.5.0.crate) = 873ef1d4134a78833cf5f09dd7131c3083c1d2ed5330dbe9735a1d52edf9c2e014cc8d4e441333e7b8fc3c11717db4588c2434cc2f98c8ee0a10fdcdadf0080d
SHA512 (fd-find-8.0.0.crate) = 8145da321c184c1984c8b2289403e24bddb3494f9264050491248342c0eaa4fce920bfb225ad7c779a7390e2c06ccdc208d085883ce227eb1bde54349dfc8b9a