Update to 8.1.0

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Raits 2020-05-22 12:26:00 +02:00
parent 264d784f34
commit 22ef82c763
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E
5 changed files with 21 additions and 18 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@
/fd-find-7.4.0.crate /fd-find-7.4.0.crate
/fd-find-7.5.0.crate /fd-find-7.5.0.crate
/fd-find-8.0.0.crate /fd-find-8.0.0.crate
/fd-find-8.1.0.crate

View File

@ -1,6 +1,6 @@
From 5425d762550be0025441cb944f8cdcc8275c6b89 Mon Sep 17 00:00:00 2001 From 5f72a51d7eb23cd18eb07639757d4dcea2e6a2ab Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com> From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Thu, 16 Apr 2020 11:44:31 +0200 Date: Fri, 22 May 2020 12:28:05 +0200
Subject: [PATCH] Remove usage of jemallocator Subject: [PATCH] Remove usage of jemallocator
It is PITA to package it in Fedora, so we will have to have fd a bit It is PITA to package it in Fedora, so we will have to have fd a bit
@ -8,19 +8,20 @@ slower for now.
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com> Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
--- ---
src/main.rs | 5 ----- src/main.rs | 6 ------
1 file changed, 5 deletions(-) 1 file changed, 6 deletions(-)
diff --git a/src/main.rs b/src/main.rs diff --git a/src/main.rs b/src/main.rs
index fb64e7a..f8e83db 100644 index 6ffa277..aee72ce 100644
--- a/src/main.rs --- a/src/main.rs
+++ b/src/main.rs +++ b/src/main.rs
@@ -29,11 +29,6 @@ use crate::filter::{SizeFilter, TimeFilter}; @@ -32,12 +32,6 @@ use crate::filter::{SizeFilter, TimeFilter};
use crate::options::Options; use crate::options::Options;
use crate::regex_helper::pattern_has_uppercase_char; use crate::regex_helper::pattern_has_uppercase_char;
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481 -// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
-#[cfg(all(not(windows), not(target_env = "musl")))] -// FIXME: re-enable jemalloc on macOS, see comment in Cargo.toml file for more infos
-#[cfg(all(not(windows), not(target_os = "macos"), not(target_env = "musl")))]
-#[global_allocator] -#[global_allocator]
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc; -static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
- -
@ -28,5 +29,5 @@ index fb64e7a..f8e83db 100644
let matches = app::build_app().get_matches_from(env::args_os()); let matches = app::build_app().get_matches_from(env::args_os());
-- --
2.26.0 2.26.2

View File

@ -1,11 +1,11 @@
--- fd-find-8.0.0/Cargo.toml 2020-04-16T08:39:41+00:00 --- fd-find-8.1.0/Cargo.toml 2020-05-19T17:06:05+00:00
+++ fd-find-8.0.0/Cargo.toml 2020-04-16T09:42:05.226160+00:00 +++ fd-find-8.1.0/Cargo.toml 2020-05-22T10:25:14.621830+00:00
@@ -83,8 +83,6 @@ @@ -86,8 +86,6 @@
[build-dependencies.version_check] [build-dependencies.version_check]
version = "0.9" version = "0.9"
-[target."cfg(all(not(windows), not(target_env = \"musl\")))".dependencies.jemallocator] -[target."cfg(all(not(windows), not(target_os = \"macos\"), not(target_env = \"musl\")))".dependencies.jemallocator]
-version = "0.3.0" -version = "0.3.0"
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc] [target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
version = "0.2" version = "0.2"
[badges.appveyor] [target."cfg(unix)".dependencies.users]

View File

@ -5,7 +5,7 @@
%global crate fd-find %global crate fd-find
Name: rust-%{crate} Name: rust-%{crate}
Version: 8.0.0 Version: 8.1.0
Release: 1%{?dist} Release: 1%{?dist}
Summary: Simple, fast and user-friendly alternative to find Summary: Simple, fast and user-friendly alternative to find
@ -30,13 +30,11 @@ Fd is a simple, fast and user-friendly alternative to find.}
%package -n %{crate} %package -n %{crate}
Summary: %{summary} Summary: %{summary}
# Install all deps (without check), grab their licenses and make it simple
# * ASL 2.0 or MIT # * ASL 2.0 or MIT
# * MIT # * MIT
# * MIT or ASL 2.0 # * MIT or ASL 2.0
# * (MIT or ASL 2.0) and BSD
# * Unlicense or MIT # * Unlicense or MIT
License: MIT and BSD License: MIT
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -82,6 +80,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
%endif %endif
%changelog %changelog
* Fri May 22 12:25:14 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.1.0-1
- Update to 8.1.0
* Thu Apr 16 11:42:05 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.0.0-1 * Thu Apr 16 11:42:05 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 8.0.0-1
- Update to 8.0.0 - Update to 8.0.0

View File

@ -1 +1 @@
SHA512 (fd-find-8.0.0.crate) = 8145da321c184c1984c8b2289403e24bddb3494f9264050491248342c0eaa4fce920bfb225ad7c779a7390e2c06ccdc208d085883ce227eb1bde54349dfc8b9a SHA512 (fd-find-8.1.0.crate) = a643a3bb6e3b0faa4abd2ed6b800a917aef392da6a23f0a02c8d91b4f63723e943d8de485069823e23b529e630946ef64853ddbed0107f6c826152077344546a