Update to 7.4.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2019-12-07 12:10:56 +01:00
parent b226a91f47
commit 078e602df9
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
5 changed files with 61 additions and 8 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/fd-find-7.1.0.crate
/fd-find-7.2.0.crate
/fd-find-7.3.0.crate
/fd-find-7.4.0.crate

View File

@ -0,0 +1,32 @@
From db8cb882fb743a216687abc5cf372302405c1053 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sat, 7 Dec 2019 12:39:53 +0100
Subject: [PATCH] Remove usage of jemallocator
It is PITA to package it in Fedora, so we will have to have fd a bit
slower for now.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/main.rs | 5 -----
1 file changed, 5 deletions(-)
diff --git a/src/main.rs b/src/main.rs
index 426eb08..c4af1ef 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -35,11 +35,6 @@ use crate::internal::{
pattern_has_uppercase_char, transform_args_with_exec, FileTypes,
};
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
-#[cfg(all(not(windows), not(target_env = "musl")))]
-#[global_allocator]
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
-
fn main() {
let checked_args = transform_args_with_exec(env::args_os());
let matches = app::build_app().get_matches_from(checked_args);
--
2.24.0

11
fd-find-fix-metadata.diff Normal file
View File

@ -0,0 +1,11 @@
--- fd-find-7.4.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ fd-find-7.4.0/Cargo.toml 2019-12-07T11:40:50.141928+00:00
@@ -80,8 +80,6 @@
[build-dependencies.version_check]
version = "0.9"
-[target."cfg(all(not(windows), not(target_env = \"musl\")))".dependencies.jemallocator]
-version = "0.3.0"
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
version = "0.2"
[badges.appveyor]

View File

@ -1,18 +1,23 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 11
%bcond_without check
%global __cargo_skip_build 0
%global crate fd-find
Name: rust-%{crate}
Version: 7.3.0
Release: 4%{?dist}
Version: 7.4.0
Release: 1%{?dist}
Summary: Simple, fast and user-friendly alternative to find
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/fd-find
Source: %{crates_source}
# Initial patched metadata
# * Remove jemallocator from deps
Patch0: fd-find-fix-metadata.diff
# * Disable jemallocator for real
Patch0001: 0001-Remove-usage-of-jemallocator.patch
ExclusiveArch: %{rust_arches}
@ -55,12 +60,13 @@ Summary: %{summary}
%install
%cargo_install
%{__install} -Dpm0644 -t %{buildroot}%{_mandir}/man1 doc/fd.1
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
install -Dpm0644 -t %{buildroot}%{_mandir}/man1 \
doc/fd.1
install -Dpm0644 -t %{buildroot}%{_datadir}/bash-completion/completions \
target/release/build/%{crate}-*/out/fd.bash
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
install -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
target/release/build/%{crate}-*/out/fd.fish
%{__install} -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
install -Dpm0644 -t %{buildroot}%{_datadir}/zsh/site-functions \
target/release/build/%{crate}-*/out/_fd
%if %{with check}
@ -69,6 +75,9 @@ Summary: %{summary}
%endif
%changelog
* Sat Dec 07 12:09:52 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 7.4.0-1
- Update to 7.4.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.3.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (fd-find-7.3.0.crate) = 79ef919361b6aaa8f2b04d8bd5b0e3675fa163a6c0ddb10655957830af5ad3fff0c2e2c134fe45eed0709327b618d5ce2d067c00cacee8bd4c0640afa978e4f1
SHA512 (fd-find-7.4.0.crate) = 55d917e9dec018b4d2646fffec261f170000ff0654f9ba5f9625788623ec943e469cd26589f7fae8731016fa53eff4d89749a5905a4baf06c9c07e92e7efbe1b