bump lazy_static to 1

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2017-11-30 23:39:10 +01:00
parent 9db0a27993
commit d13083704a
2 changed files with 20 additions and 7 deletions

View File

@ -1,15 +1,24 @@
--- exa-0.8.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ exa-0.8.0/Cargo.toml 2017-11-27T11:50:10.756724+01:00
@@ -51,9 +51,6 @@
+++ exa-0.8.0/Cargo.toml 2017-11-30T23:37:17.982905+01:00
@@ -40,7 +40,7 @@
version = "0.4.5"
[dependencies.lazy_static]
-version = "0.2"
+version = "1"
[dependencies.term_grid]
version = "0.1.6"
@@ -50,9 +50,6 @@
[dependencies.unicode-width]
version = "0.1.4"
-
-[dependencies.getopts]
-version = "0.2.14"
-
[dependencies.glob]
version = "0.2"
@@ -64,13 +61,13 @@
version = "1.3.0"

View File

@ -5,7 +5,7 @@
Name: rust-%{crate}
Version: 0.8.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Modern replacement for ls
License: MIT
@ -15,6 +15,7 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
# * Bump ansi_term to 0.10, remove getopts, https://github.com/ogham/exa/commit/4c3fd5483d2eff2ea1e623878ede54eaa396e09e
# * Bump env_logger to 0.4, https://github.com/ogham/exa/pull/315
# * Bump users to 0.6, https://github.com/ogham/exa/pull/317
# * Bump lazy_static, https://github.com/ogham/exa/pull/322
Patch0: exa-0.8.0-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -26,7 +27,7 @@ BuildRequires: (crate(datetime) >= 0.4.5 with crate(datetime) < 0.5.0)
BuildRequires: (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires: (crate(git2) >= 0.6.4 with crate(git2) < 0.7.0)
BuildRequires: (crate(glob) >= 0.2.0 with crate(glob) < 0.3.0)
BuildRequires: (crate(lazy_static) >= 0.2.0 with crate(lazy_static) < 0.3.0)
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.9 with crate(libc) < 0.3.0)
BuildRequires: (crate(locale) >= 0.2.1 with crate(locale) < 0.3.0)
BuildRequires: (crate(log) >= 0.3.0 with crate(log) < 0.4.0)
@ -104,5 +105,8 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,Vagrantfile,contrib,devtools,screenshots.png,xtests}
%changelog
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-2
- Bump lazy_static to 1
* Tue Nov 21 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Initial package