update to version 0.10.1

This commit is contained in:
Fabio Valentini 2021-07-20 15:57:59 +02:00
parent c9eae5e024
commit 7719c18319
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF
4 changed files with 18 additions and 54 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/exa-0.8.0.crate /exa-0.8.0.crate
/exa-0.9.0.crate /exa-0.9.0.crate
/exa-0.10.1.crate

View File

@ -1,36 +1,6 @@
--- exa-0.9.0/Cargo.toml 1970-01-01T00:00:00+00:00 --- exa-0.10.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ exa-0.9.0/Cargo.toml 2020-05-22T09:33:37.117202+00:00 +++ exa-0.10.1/Cargo.toml 2021-07-20T13:09:28.108670+00:00
@@ -42,13 +42,13 @@ @@ -97,4 +97,3 @@
version = "0.12.0"
[dependencies.datetime]
-version = "0.4.7"
+version = "0.5"
[dependencies.env_logger]
-version = "0.6.1"
+version = "0.7.1"
[dependencies.git2]
-version = "0.9.1"
+version = "0.13"
optional = true
default-features = false
@@ -89,14 +89,13 @@
version = "0.1.5"
[dependencies.users]
-version = "0.9.1"
+version = "0.10"
[dependencies.zoneinfo_compiled]
-version = "0.4.8"
+version = "0.5"
[build-dependencies.datetime]
-version = "0.4.7"
+version = "0.5"
[features] [features]
default = ["git"] default = ["git"]
git = ["git2"] git = ["git2"]

View File

@ -1,14 +1,12 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
# Exa is not supposed to be used as a library
%global __cargo_skip_build 0 %global __cargo_skip_build 0
%global __cargo_is_lib() false
%global crate exa %global crate exa
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.9.0 Version: 0.10.1
Release: 15%{?dist} Release: 1%{?dist}
Summary: Modern replacement for ls Summary: Modern replacement for ls
# Upstream license specification: MIT # Upstream license specification: MIT
@ -16,21 +14,15 @@ License: MIT
URL: https://crates.io/crates/exa URL: https://crates.io/crates/exa
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Bump to env_logger 0.7.1, https://github.com/ogham/exa/pull/603 # * disable feature for vendored OpenSSL
# * Update git2 to 0.13, https://github.com/ogham/exa/pull/640
# * Update zoneinfo_compiled/datetime to 0.5, users to 0.10
# https://github.com/ogham/exa/pull/667
Patch0: exa-fix-metadata.diff Patch0: exa-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
exa is a modern replacement for the command-line program ls that ships exa is a modern replacement for the command-line program ls that ships
with Unix and Linux operating systems, with more features and better defaults. with Unix and Linux operating systems, with more features and better defaults.
It uses colours to distinguish file types and metadata. It uses colours to distinguish file types and metadata.
It knows about symlinks, extended attributes, and Git. And its small, fast, It knows about symlinks, extended attributes, and Git. And its small, fast,
@ -44,6 +36,7 @@ Summary: %{summary}
# MIT or ASL 2.0 # MIT or ASL 2.0
# MIT or ASL 2.0 or zlib # MIT or ASL 2.0 or zlib
# Unlicense or MIT # Unlicense or MIT
# zlib or ASL 2.0 or MIT
License: MIT License: MIT
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -52,7 +45,6 @@ License: MIT
%license LICENCE %license LICENCE
%doc README.md %doc README.md
%{_bindir}/exa %{_bindir}/exa
%{_mandir}/man1/exa.1*
%dir %{_datadir}/bash-completion %dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions %dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/exa.bash %{_datadir}/bash-completion/completions/exa.bash
@ -75,21 +67,22 @@ License: MIT
%install %install
%cargo_install %cargo_install
install -Dpm0644 -t %{buildroot}%{_mandir}/man1 contrib/man/exa.1 install -Dpm0644 -T completions/completions.bash \
install -Dpm0644 -T contrib/completions.bash \
%{buildroot}%{_datadir}/bash-completion/completions/exa.bash %{buildroot}%{_datadir}/bash-completion/completions/exa.bash
install -Dpm0644 -T contrib/completions.fish \ install -Dpm0644 -T completions/completions.fish \
%{buildroot}%{_datadir}/fish/vendor_completions.d/exa.fish %{buildroot}%{_datadir}/fish/vendor_completions.d/exa.fish
install -Dpm0644 -T contrib/completions.zsh \ install -Dpm0644 -T completions/completions.zsh \
%{buildroot}%{_datadir}/zsh/site-functions/_exa %{buildroot}%{_datadir}/zsh/site-functions/_exa
%if %{with check} %if %{with check}
%check %check
# https://github.com/ogham/exa/issues/318 %cargo_test
%cargo_test || :
%endif %endif
%changelog %changelog
* Tue Jul 20 2021 Fabio Valentini <decathorpe@gmail.com> - 0.10.1-1
- Update to version 0.10.1.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-15 * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (exa-0.9.0.crate) = fa798e962e4a70f98fc78ccc8eb4ae7dfd4c3c0fabca2d7f6627301ffa5042f4437c98c5698f3b4ddc77acc4162b9141e6dc2e7d2f2818ff4f03ba755a6278d6 SHA512 (exa-0.10.1.crate) = c10097e6ad8352d08893bf7d03a7eb0620dd92082aac488b08c93b5b9c15040e84c8b2c231e621e2767015050d46ba8a1c971c5c577492b1d5357a3af7e2ed41