Update glob to 0.3, number_prefix to 0.3

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2019-05-07 14:00:00 +02:00
parent 6638e649ab
commit 1f9f2a9b94
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C
3 changed files with 60 additions and 11 deletions

View File

@ -0,0 +1,37 @@
From 2d0768c8d2c4ab28f8b6bb7fb8b2fdcce2af987f Mon Sep 17 00:00:00 2001
From: Bernardo Meurer <meurerbernardo@gmail.com>
Date: Tue, 16 Apr 2019 22:54:06 -0700
Subject: [PATCH] Fix usages of number_prefix
---
src/output/render/size.rs | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/src/output/render/size.rs b/src/output/render/size.rs
index 25b2007..da9c709 100644
--- a/src/output/render/size.rs
+++ b/src/output/render/size.rs
@@ -9,8 +9,7 @@ use output::table::SizeFormat;
impl f::Size {
pub fn render<C: Colours>(&self, colours: &C, size_format: SizeFormat, numerics: &NumericLocale) -> TextCell {
- use number_prefix::{binary_prefix, decimal_prefix};
- use number_prefix::{Prefixed, Standalone, PrefixNames};
+ use number_prefix::{Prefixed, Standalone, NumberPrefix, PrefixNames};
let size = match *self {
f::Size::Some(s) => s,
@@ -19,8 +18,8 @@ impl f::Size {
};
let result = match size_format {
- SizeFormat::DecimalBytes => decimal_prefix(size as f64),
- SizeFormat::BinaryBytes => binary_prefix(size as f64),
+ SizeFormat::DecimalBytes => NumberPrefix::decimal(size as f64),
+ SizeFormat::BinaryBytes => NumberPrefix::binary(size as f64),
SizeFormat::JustBytes => {
let string = numerics.format_int(size);
return TextCell::paint(colours.size(size), string);
--
2.21.0

View File

@ -1,5 +1,5 @@
--- exa-0.8.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ exa-0.8.0/Cargo.toml 2019-02-10T11:25:06.307236+01:00
--- exa-0.8.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ exa-0.8.0/Cargo.toml 2019-05-07T11:57:04.087644+00:00
@@ -40,7 +40,7 @@
version = "0.4.5"
@ -17,7 +17,8 @@
-version = "0.2.14"
-
[dependencies.glob]
version = "0.2"
-version = "0.2"
+version = "0.3"
[dependencies.log]
-version = "0.3"
@ -39,7 +40,7 @@
[dependencies.libc]
version = "0.2.9"
@@ -79,18 +76,18 @@
@@ -79,21 +76,21 @@
version = "1.0.7"
[dependencies.git2]
@ -60,4 +61,8 @@
+version = "0.1"
[dependencies.number_prefix]
version = "0.2.3"
-version = "0.2.3"
+version = "0.3"
[features]
git = ["git2"]

View File

@ -1,4 +1,4 @@
# Generated by rust2rpm
# Generated by rust2rpm-9-1.fc31
%bcond_without check
# Exa is not supposed to be used as a library
%global __cargo_is_lib() false
@ -7,9 +7,10 @@
Name: rust-%{crate}
Version: 0.8.0
Release: 14%{?dist}
Release: 15%{?dist}
Summary: Modern replacement for ls
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/exa
Source: %{crates_source}
@ -21,6 +22,8 @@ Source: %{crates_source}
# * Bump lazy_static, https://github.com/ogham/exa/pull/322
# * Bump git2 to 0.8, https://github.com/ogham/exa/commit/f757300718b1861852d4a33459385eaf921d69e7
# https://github.com/ogham/exa/pull/461
# * Bump number_prefix to 0.3, https://github.com/ogham/exa/pull/494
# * Bump glob to 0.2, https://github.com/ogham/exa/pull/494
Patch0: exa-fix-metadata.diff
# Make it work with new git2
Patch1: 0001-Upgrade-libgit2.patch
@ -28,6 +31,8 @@ Patch1: 0001-Upgrade-libgit2.patch
Patch2: 0001-Update-log-to-0.4-and-env_logger-to-0.5.patch
# Make it work with new users
Patch3: 0001-Bump-users-crate-version.patch
# Make it work with new number_prefix
Patch4: 0001-Fix-usages-of-number_prefix.patch
ExclusiveArch: %{rust_arches}
@ -36,14 +41,14 @@ BuildRequires: (crate(ansi_term/default) >= 0.11.0 with crate(ansi_term/default
BuildRequires: (crate(datetime/default) >= 0.4.5 with crate(datetime/default) < 0.5.0)
BuildRequires: (crate(env_logger/default) >= 0.6.0 with crate(env_logger/default) < 0.7.0)
BuildRequires: (crate(git2) >= 0.8.0 with crate(git2) < 0.9.0)
BuildRequires: (crate(glob/default) >= 0.2.0 with crate(glob/default) < 0.3.0)
BuildRequires: (crate(glob/default) >= 0.3.0 with crate(glob/default) < 0.4.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(libc/default) >= 0.2.9 with crate(libc/default) < 0.3.0)
BuildRequires: (crate(locale/default) >= 0.2.1 with crate(locale/default) < 0.3.0)
BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires: (crate(natord/default) >= 1.0.7 with crate(natord/default) < 2.0.0)
BuildRequires: (crate(num_cpus/default) >= 1.3.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires: (crate(number_prefix/default) >= 0.2.3 with crate(number_prefix/default) < 0.3.0)
BuildRequires: (crate(number_prefix/default) >= 0.3.0 with crate(number_prefix/default) < 0.4.0)
BuildRequires: (crate(scoped_threadpool/default) >= 0.1.0 with crate(scoped_threadpool/default) < 0.2.0)
BuildRequires: (crate(term_grid/default) >= 0.1.6 with crate(term_grid/default) < 0.2.0)
BuildRequires: (crate(term_size/default) >= 0.3.0 with crate(term_size/default) < 0.4.0)
@ -59,8 +64,7 @@ A modern replacement for ls.
%package -n %{crate}
Summary: %{summary}
%description -n %{crate}
%{summary}.
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENCE
@ -101,6 +105,9 @@ Summary: %{summary}
%endif
%changelog
* Tue May 07 14:00:28 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-15
- Update glob to 0.3, number_prefix to 0.3
* Thu Apr 25 17:20:22 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.8.0-214
- Rebuilt for rust-users 0.9.1