rust-dua-cli/rust-dua-cli.spec

220 lines
5.7 KiB
RPMSpec

# Generated by rust2rpm 21
# * neither test files nor test code is included in published crates
%bcond_with check
%global crate dua-cli
Name: rust-%{crate}
Version: 2.17.8
Release: %autorelease
Summary: Tool to conveniently learn about the disk usage of directories
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/dua-cli
Source0: %{crates_source}
Source1: LICENSE.dependencies
# Initial patched metadata
# * drop macos-specific dependencies
Patch0: dua-cli-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Tool to conveniently learn about the disk usage of directories, fast!.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
# ASL 2.0 or MIT
# BSD
# MIT
# MIT or ASL 2.0
# MIT or ASL 2.0 or zlib
# MPLv2.0
# Unlicense or MIT
# zlib or ASL 2.0 or MIT
License: MIT and BSD and MPLv2.0
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc CHANGELOG.md
%doc README.md
%{_bindir}/dua
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crosstermion-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crosstermion-devel %{_description}
This package contains library source intended for building other packages which
use the "crosstermion" feature of the "%{crate}" crate.
%files -n %{name}+crosstermion-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+open-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+open-devel %{_description}
This package contains library source intended for building other packages which
use the "open" feature of the "%{crate}" crate.
%files -n %{name}+open-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trash-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trash-devel %{_description}
This package contains library source intended for building other packages which
use the "trash" feature of the "%{crate}" crate.
%files -n %{name}+trash-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+trash-move-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+trash-move-devel %{_description}
This package contains library source intended for building other packages which
use the "trash-move" feature of the "%{crate}" crate.
%files -n %{name}+trash-move-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tui-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tui-devel %{_description}
This package contains library source intended for building other packages which
use the "tui" feature of the "%{crate}" crate.
%files -n %{name}+tui-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tui-crossplatform-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tui-crossplatform-devel %{_description}
This package contains library source intended for building other packages which
use the "tui-crossplatform" feature of the "%{crate}" crate.
%files -n %{name}+tui-crossplatform-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tui-react-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tui-react-devel %{_description}
This package contains library source intended for building other packages which
use the "tui-react" feature of the "%{crate}" crate.
%files -n %{name}+tui-react-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tui-shared-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tui-shared-devel %{_description}
This package contains library source intended for building other packages which
use the "tui-shared" feature of the "%{crate}" crate.
%files -n %{name}+tui-shared-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tui-unix-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tui-unix-devel %{_description}
This package contains library source intended for building other packages which
use the "tui-unix" feature of the "%{crate}" crate.
%files -n %{name}+tui-unix-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-segmentation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unicode-segmentation-devel %{_description}
This package contains library source intended for building other packages which
use the "unicode-segmentation" feature of the "%{crate}" crate.
%files -n %{name}+unicode-segmentation-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
cp %{SOURCE1} .
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog