rust-difftastic/rust-difftastic.spec

65 lines
1.4 KiB
RPMSpec

# Generated by rust2rpm 23
%bcond_without check
%global crate difftastic
Name: rust-difftastic
Version: 0.45.0
Release: %autorelease
Summary: Structural diff that understands syntax
License: MIT
URL: https://crates.io/crates/difftastic
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * unpin assert_cmd and downgrade to 2.0.4 that is in EPEL 9
# * unpin libmimalloc-sys
# * unpin predicates
Patch: difftastic-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
A structural diff that understands syntax.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
License: (Apache-2.0 OR MIT) AND (Apache-2.0 OR Apache-2.0 WITH LLVM-exception OR MIT) AND MIT AND (MIT OR Unlicense) AND Zlib
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE
%if 0%{?fedora}
%license LICENSE.dependencies
%endif
%doc README.md
%{_bindir}/difft
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%if 0%{?fedora}
%{cargo_license} > LICENSE.dependencies
%endif
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog