Update to 0.14.0

This commit is contained in:
Josh Stone 2020-04-22 18:14:52 -07:00
parent d9587f2d42
commit bc441273d1
5 changed files with 163 additions and 82 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@
/bat-0.11.0.crate
/bat-0.12.1.crate
/bat-0.13.0.crate
/bat-0.14.0.crate

View File

@ -1,67 +0,0 @@
From 136a745c5de804ee9cf0ec601302e17cef6334a3 Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Sun, 22 Mar 2020 16:27:35 +0100
Subject: [PATCH] chore: Update liquid to 0.20
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
---
build.rs | 31 +++++++------------------------
1 file changed, 7 insertions(+), 24 deletions(-)
diff --git a/build.rs b/build.rs
index 1c5872e..bff88e9 100644
--- a/build.rs
+++ b/build.rs
@@ -18,34 +18,13 @@ lazy_static! {
.unwrap_or("bat");
}
-fn init_template() -> liquid::value::Object {
- let mut globals = liquid::value::Object::new();
-
- globals.insert(
- "PROJECT_NAME".into(),
- liquid::value::Value::scalar(PROJECT_NAME.to_owned()),
- );
-
- globals.insert(
- "PROJECT_EXECUTABLE".into(),
- liquid::value::Value::scalar(EXECUTABLE_NAME.to_owned()),
- );
-
- globals.insert(
- "PROJECT_VERSION".into(),
- liquid::value::Value::scalar(PROJECT_VERSION.to_owned()),
- );
-
- globals
-}
-
/// Generates a file from a liquid template.
fn template(
- variables: &liquid::value::Object,
+ variables: &liquid::Object,
in_file: &str,
out_file: impl AsRef<Path>,
) -> Result<(), Box<dyn Error>> {
- let template = liquid::ParserBuilder::with_liquid()
+ let template = liquid::ParserBuilder::with_stdlib()
.build()?
.parse(&fs::read_to_string(in_file)?)?;
@@ -54,7 +33,11 @@ fn template(
}
fn main() -> Result<(), Box<dyn Error>> {
- let variables = init_template();
+ let variables = liquid::object!({
+ "PROJECT_NAME": PROJECT_NAME.to_owned(),
+ "PROJECT_EXECUTABLE": EXECUTABLE_NAME.to_owned(),
+ "PROJECT_VERSION": PROJECT_VERSION.to_owned(),
+ });
let out_dir_env = std::env::var_os("OUT_DIR").expect("OUT_DIR to be set in build.rs");
let out_dir = Path::new(&out_dir_env);
--
2.26.0.rc2

View File

@ -1,8 +0,0 @@
--- bat-0.13.0/Cargo.toml 2020-03-22T12:44:46+00:00
+++ bat-0.13.0/Cargo.toml 2020-03-23T06:22:32.294574+00:00
@@ -92,4 +92,4 @@
version = "1.4"
[build-dependencies.liquid]
-version = "0.19"
+version = "0.20"

View File

@ -5,18 +5,14 @@
%global crate bat
Name: rust-%{crate}
Version: 0.13.0
Release: 2%{?dist}
Version: 0.14.0
Release: 1%{?dist}
Summary: cat(1) clone with wings
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/bat
Source: %{crates_source}
# Initial patched metadata
# * Update liquid to 0.20, https://github.com/sharkdp/bat/commit/136a745c5de804ee9cf0ec601302e17cef6334a3
Patch0: bat-fix-metadata.diff
Patch0001: 0001-chore-Update-liquid-to-0.20.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -85,6 +81,162 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+application-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+application-devel %{_description}
This package contains library source intended for building other packages
which use "application" feature of "%{crate}" crate.
%files -n %{name}+application-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+atty-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+atty-devel %{_description}
This package contains library source intended for building other packages
which use "atty" feature of "%{crate}" crate.
%files -n %{name}+atty-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+clap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+clap-devel %{_description}
This package contains library source intended for building other packages
which use "clap" feature of "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+dirs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dirs-devel %{_description}
This package contains library source intended for building other packages
which use "dirs" feature of "%{crate}" crate.
%files -n %{name}+dirs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+git-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+git-devel %{_description}
This package contains library source intended for building other packages
which use "git" feature of "%{crate}" crate.
%files -n %{name}+git-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+git2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+git2-devel %{_description}
This package contains library source intended for building other packages
which use "git2" feature of "%{crate}" crate.
%files -n %{name}+git2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
This package contains library source intended for building other packages
which use "lazy_static" feature of "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+liquid-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+liquid-devel %{_description}
This package contains library source intended for building other packages
which use "liquid" feature of "%{crate}" crate.
%files -n %{name}+liquid-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+paging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+paging-devel %{_description}
This package contains library source intended for building other packages
which use "paging" feature of "%{crate}" crate.
%files -n %{name}+paging-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+regex-fancy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-fancy-devel %{_description}
This package contains library source intended for building other packages
which use "regex-fancy" feature of "%{crate}" crate.
%files -n %{name}+regex-fancy-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+regex-onig-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-onig-devel %{_description}
This package contains library source intended for building other packages
which use "regex-onig" feature of "%{crate}" crate.
%files -n %{name}+regex-onig-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+shell-words-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+shell-words-devel %{_description}
This package contains library source intended for building other packages
which use "shell-words" feature of "%{crate}" crate.
%files -n %{name}+shell-words-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+wild-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wild-devel %{_description}
This package contains library source intended for building other packages
which use "wild" feature of "%{crate}" crate.
%files -n %{name}+wild-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -108,6 +260,9 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
%endif
%changelog
* Thu Apr 23 2020 Josh Stone <jistone@redhat.com> - 0.14.0-1
- Update to 0.14.0
* Wed Apr 15 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.13.0-2
- Rebuild for libgit2 1.0.0

View File

@ -1 +1 @@
SHA512 (bat-0.13.0.crate) = 950a54f8fcc8f8ef5f63e4ec4897e9dc32f39aa8965a3afba4501f1f58ad7d84d8aa34a8af3615c30112658e2fe59a3ccffbc6d1142ad2de24b650894e908c10
SHA512 (bat-0.14.0.crate) = b0da0513b82590cfa799b93fb1160373a3cdfb7b5d7189b3dce4e060a658a1dab96997646c6cd5a0631eb074512cb370b5c1db8edf95b0dd33ec61c3a13d5277