Bump assert_cmd to 2.0.0

This commit is contained in:
Robert-André Mauchin 2021-11-14 20:25:06 +01:00
parent 38dcc679df
commit 0ff52b5deb
5 changed files with 35 additions and 17 deletions

1
.gitignore vendored
View File

@ -14,3 +14,4 @@
/bat-0.15.4.crate
/bat-0.16.0.crate
/bat-0.17.1.crate
/bat-0.18.3.crate

View File

@ -18,7 +18,7 @@ index 86c3fe0..3899d7c 100644
use std::collections::BTreeMap;
use std::ffi::OsStr;
use std::fs::{self, File};
@@ -8,7 +9,7 @@ use syntect::dumps::{dump_to_file, from_binary, from_reader};
@@ -8,7 +9,7 @@ use syntect::dumps::{dump_to_file, from_
use syntect::highlighting::{Theme, ThemeSet};
use syntect::parsing::{SyntaxReference, SyntaxSet, SyntaxSetBuilder};
@ -26,8 +26,8 @@ index 86c3fe0..3899d7c 100644
+use path_absolutize::Absolutize;
use crate::assets_metadata::AssetsMetadata;
use crate::error::*;
@@ -216,10 +217,7 @@ impl HighlightingAssets {
use crate::bat_warning;
@@ -255,10 +256,7 @@ impl HighlightingAssets {
if let Some(path_str) = path_str {
// If a path was provided, we try and detect the syntax based on extension mappings.
let path = Path::new(path_str);

View File

@ -1,6 +1,6 @@
--- bat-0.17.1/Cargo.toml 2020-11-24T20:56:01+00:00
+++ bat-0.17.1/Cargo.toml 2020-12-12T23:33:02.135924+00:00
@@ -71,9 +71,8 @@
--- bat-0.18.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bat-0.18.3/Cargo.toml 2021-11-14T17:24:54.516671+00:00
@@ -79,9 +79,8 @@
version = "1.4"
optional = true
@ -12,3 +12,18 @@
[dependencies.semver]
version = "0.11"
@@ -109,7 +108,7 @@
version = "2.0"
optional = true
[dev-dependencies.assert_cmd]
-version = "1.0.5"
+version = "2.0.0"
[dev-dependencies.predicates]
version = "1.0.7"
@@ -134,4 +133,4 @@
regex-fancy = ["syntect/regex-fancy"]
regex-onig = ["syntect/regex-onig"]
[target."cfg(unix)".dev-dependencies.nix]
-version = "0.21.0"
+version = "0.22.0"

View File

@ -1,12 +1,12 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 18
%bcond_without check
%global crate bat
Name: rust-%{crate}
Version: 0.17.1
Version: 0.18.3
Release: %autorelease
Summary: cat(1) clone with wings
Summary: Cat(1) clone with wings
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
@ -14,8 +14,10 @@ URL: https://crates.io/crates/bat
Source: %{crates_source}
# Initial patched metadata
# * Switch to path-absolutize, https://github.com/sharkdp/bat/pull/1025
# * Bump assert_cmd to 2.0.0
# * Bump nix to 0.22.0
Patch0: bat-fix-metadata.diff
Patch0001: 0001-Siwtch-to-path-absolutize.patch
Patch0001: 0001-Switch-to-path-absolutize.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -48,7 +50,7 @@ License: ASL 2.0 and BSD and CC0 and LGPLv3+ and MIT
%files -n %{crate}
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%doc doc README.md CONTRIBUTING.md CHANGELOG.md
%{_bindir}/bat
%{_mandir}/man1/bat.1*
%dir %{_datadir}/fish
@ -67,7 +69,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%doc doc README.md CONTRIBUTING.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -118,16 +120,16 @@ which use "clap" feature of "%{crate}" crate.
%files -n %{name}+clap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+dirs-devel
%package -n %{name}+dirs-next-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dirs-devel %{_description}
%description -n %{name}+dirs-next-devel %{_description}
This package contains library source intended for building other packages
which use "dirs" feature of "%{crate}" crate.
which use "dirs-next" feature of "%{crate}" crate.
%files -n %{name}+dirs-devel
%files -n %{name}+dirs-next-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+git-devel

View File

@ -1 +1 @@
SHA512 (bat-0.17.1.crate) = b921603fd71af7d21899e2117d6d9275a8c1d4c019696a391fb5de84bcc09400e106268a1f91f36b1e0864056d69a9ff1c197436e53c7e0f98e4988c99745a04
SHA512 (bat-0.18.3.crate) = 078a08248b63ab602b78f05efd1721a3e1173c1b6ec9eb1f0d0e6bad954ef6c2063c6221558c102e4dac79433c2ed3bc69003d0aec4b49722b6e574bd8f7f7b3