Merge remote-tracking branch 'origin/master' into f32

This commit is contained in:
Igor Raits 2020-04-27 09:04:13 +02:00
commit 0c4eab365c
5 changed files with 12 additions and 84 deletions

2
.gitignore vendored
View File

@ -7,3 +7,5 @@
/bat-0.11.0.crate
/bat-0.12.1.crate
/bat-0.13.0.crate
/bat-0.14.0.crate
/bat-0.15.0.crate

View File

@ -1,67 +0,0 @@
From 136a745c5de804ee9cf0ec601302e17cef6334a3 Mon Sep 17 00:00:00 2001
From: Igor Raits <i.gnatenko.brain@gmail.com>
Date: Sun, 22 Mar 2020 16:27:35 +0100
Subject: [PATCH] chore: Update liquid to 0.20
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
---
build.rs | 31 +++++++------------------------
1 file changed, 7 insertions(+), 24 deletions(-)
diff --git a/build.rs b/build.rs
index 1c5872e..bff88e9 100644
--- a/build.rs
+++ b/build.rs
@@ -18,34 +18,13 @@ lazy_static! {
.unwrap_or("bat");
}
-fn init_template() -> liquid::value::Object {
- let mut globals = liquid::value::Object::new();
-
- globals.insert(
- "PROJECT_NAME".into(),
- liquid::value::Value::scalar(PROJECT_NAME.to_owned()),
- );
-
- globals.insert(
- "PROJECT_EXECUTABLE".into(),
- liquid::value::Value::scalar(EXECUTABLE_NAME.to_owned()),
- );
-
- globals.insert(
- "PROJECT_VERSION".into(),
- liquid::value::Value::scalar(PROJECT_VERSION.to_owned()),
- );
-
- globals
-}
-
/// Generates a file from a liquid template.
fn template(
- variables: &liquid::value::Object,
+ variables: &liquid::Object,
in_file: &str,
out_file: impl AsRef<Path>,
) -> Result<(), Box<dyn Error>> {
- let template = liquid::ParserBuilder::with_liquid()
+ let template = liquid::ParserBuilder::with_stdlib()
.build()?
.parse(&fs::read_to_string(in_file)?)?;
@@ -54,7 +33,11 @@ fn template(
}
fn main() -> Result<(), Box<dyn Error>> {
- let variables = init_template();
+ let variables = liquid::object!({
+ "PROJECT_NAME": PROJECT_NAME.to_owned(),
+ "PROJECT_EXECUTABLE": EXECUTABLE_NAME.to_owned(),
+ "PROJECT_VERSION": PROJECT_VERSION.to_owned(),
+ });
let out_dir_env = std::env::var_os("OUT_DIR").expect("OUT_DIR to be set in build.rs");
let out_dir = Path::new(&out_dir_env);
--
2.26.0.rc2

View File

@ -1,8 +0,0 @@
--- bat-0.13.0/Cargo.toml 2020-03-22T12:44:46+00:00
+++ bat-0.13.0/Cargo.toml 2020-03-23T06:22:32.294574+00:00
@@ -92,4 +92,4 @@
version = "1.4"
[build-dependencies.liquid]
-version = "0.19"
+version = "0.20"

View File

@ -1,24 +1,19 @@
# Generated by rust2rpm 13
# * assert_cmd is not packaged
%bcond_with check
%bcond_without check
# No devel stuff in released Fedora
%global __cargo_is_lib() false
%global crate bat
Name: rust-%{crate}
Version: 0.13.0
Release: 2%{?dist}
Version: 0.15.0
Release: 1%{?dist}
Summary: cat(1) clone with wings
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/bat
Source: %{crates_source}
# Initial patched metadata
# * Update liquid to 0.20, https://github.com/sharkdp/bat/commit/136a745c5de804ee9cf0ec601302e17cef6334a3
Patch0: bat-fix-metadata.diff
Patch0001: 0001-chore-Update-liquid-to-0.20.patch
ExclusiveArch: %{rust_arches}
@ -79,6 +74,12 @@ install -Dpm0644 -t %{buildroot}%{_datadir}/fish/vendor_completions.d \
%endif
%changelog
* Mon Apr 27 08:12:43 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.15.0-1
- Update to 0.15.0
* Thu Apr 23 2020 Josh Stone <jistone@redhat.com> - 0.14.0-1
- Update to 0.14.0
* Wed Apr 15 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.13.0-2
- Rebuild for libgit2 1.0.0

View File

@ -1 +1 @@
SHA512 (bat-0.13.0.crate) = 950a54f8fcc8f8ef5f63e4ec4897e9dc32f39aa8965a3afba4501f1f58ad7d84d8aa34a8af3615c30112658e2fe59a3ccffbc6d1142ad2de24b650894e908c10
SHA512 (bat-0.15.0.crate) = 961c26008328a70c611379d86dafa5565243e327a0898dff24e46447eb41594d106a846e638a2aae3d2d896f0cfb4ec0c60f678ea14aa534e80bfb1f2edf551f