Update to version 0.21.0; Fixes RHBZ#2038592
This commit is contained in:
parent
19104e20a1
commit
0ae1ca8f8d
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/bat-0.16.0.crate
|
||||
/bat-0.17.1.crate
|
||||
/bat-0.18.3.crate
|
||||
/bat-0.21.0.crate
|
||||
|
@ -1,3 +0,0 @@
|
||||
[DEFAULT]
|
||||
unwanted-features =
|
||||
regex-fancy
|
@ -1,44 +0,0 @@
|
||||
From d565131b04db44067f1bf07eafc863022c6b7c55 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
Date: Sun, 21 Jun 2020 10:16:03 +0200
|
||||
Subject: [PATCH] Siwtch to path-absolutize
|
||||
|
||||
This reverts commit bd17fd571f99d52b4d76a24aee719dcd89a0244d.
|
||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/assets.rs | 8 +++-----
|
||||
1 file changed, 3 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/assets.rs b/src/assets.rs
|
||||
index 86c3fe0..3899d7c 100644
|
||||
--- a/src/assets.rs
|
||||
+++ b/src/assets.rs
|
||||
@@ -1,3 +1,4 @@
|
||||
+use std::borrow::Cow;
|
||||
use std::collections::BTreeMap;
|
||||
use std::ffi::OsStr;
|
||||
use std::fs::{self, File};
|
||||
@@ -8,7 +9,7 @@ use syntect::dumps::{dump_to_file, from_
|
||||
use syntect::highlighting::{Theme, ThemeSet};
|
||||
use syntect::parsing::{SyntaxReference, SyntaxSet, SyntaxSetBuilder};
|
||||
|
||||
-use path_abs::PathAbs;
|
||||
+use path_absolutize::Absolutize;
|
||||
|
||||
use crate::assets_metadata::AssetsMetadata;
|
||||
use crate::bat_warning;
|
||||
@@ -255,10 +256,7 @@ impl HighlightingAssets {
|
||||
if let Some(path_str) = path_str {
|
||||
// If a path was provided, we try and detect the syntax based on extension mappings.
|
||||
let path = Path::new(path_str);
|
||||
- let absolute_path = PathAbs::new(path)
|
||||
- .ok()
|
||||
- .map(|p| p.as_path().to_path_buf())
|
||||
- .unwrap_or_else(|| path.to_owned());
|
||||
+ let absolute_path = path.absolutize().unwrap_or(Cow::Borrowed(path));
|
||||
|
||||
match mapping.get_syntax_for(absolute_path) {
|
||||
Some(MappingTarget::MapToUnknown) => line_syntax.ok_or_else(|| {
|
||||
--
|
||||
2.27.0
|
||||
|
39
0001-port-from-path_abs-to-path-absolutize.patch
Normal file
39
0001-port-from-path_abs-to-path-absolutize.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 6639f0061b39a21ae2e3bcfca21c7915319039db Mon Sep 17 00:00:00 2001
|
||||
From: Fabio Valentini <decathorpe@gmail.com>
|
||||
Date: Thu, 21 Jul 2022 10:45:26 +0200
|
||||
Subject: [PATCH] port from path_abs to path-absolutize
|
||||
|
||||
---
|
||||
src/assets.rs | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/assets.rs b/src/assets.rs
|
||||
index 8126843..f578d70 100644
|
||||
--- a/src/assets.rs
|
||||
+++ b/src/assets.rs
|
||||
@@ -1,3 +1,4 @@
|
||||
+use std::borrow::Cow;
|
||||
use std::ffi::OsStr;
|
||||
use std::fs;
|
||||
use std::path::Path;
|
||||
@@ -7,7 +8,7 @@ use once_cell::unsync::OnceCell;
|
||||
use syntect::highlighting::Theme;
|
||||
use syntect::parsing::{SyntaxReference, SyntaxSet};
|
||||
|
||||
-use path_abs::PathAbs;
|
||||
+use path_absolutize::Absolutize;
|
||||
|
||||
use crate::error::*;
|
||||
use crate::input::{InputReader, OpenedInput};
|
||||
@@ -224,7 +225,7 @@ impl HighlightingAssets {
|
||||
let path = input.path();
|
||||
let path_syntax = if let Some(path) = path {
|
||||
self.get_syntax_for_path(
|
||||
- PathAbs::new(path).map_or_else(|_| path.to_owned(), |p| p.as_path().to_path_buf()),
|
||||
+ path.absolutize().unwrap_or(Cow::Borrowed(path)),
|
||||
mapping,
|
||||
)
|
||||
} else {
|
||||
--
|
||||
2.37.1
|
||||
|
114
LICENSE.dependencies
Normal file
114
LICENSE.dependencies
Normal file
@ -0,0 +1,114 @@
|
||||
ASL 2.0 or Boost: rust-ryu 1.0.10
|
||||
ASL 2.0 or MIT: rust-autocfg 1.1.0
|
||||
ASL 2.0 or MIT: rust-cexpr 0.6.0
|
||||
ASL 2.0 or MIT: rust-fnv 1.0.7
|
||||
ASL 2.0 or MIT: rust-indexmap 1.9.1
|
||||
ASL 2.0 or MIT: rust-peeking_take_while 0.1.2
|
||||
ASL 2.0 or MIT: rust-rustc-hash 1.1.0
|
||||
ASL 2.0 or MIT: rust-wild 2.0.4
|
||||
ASL 2.0: rust-bytesize 1.1.0
|
||||
ASL 2.0: rust-clang-sys 1.3.3
|
||||
ASL 2.0: rust-line-wrap 0.1.1
|
||||
BSD: rust-bindgen 0.59.2
|
||||
BSD: rust-git-version 0.3.5
|
||||
BSD: rust-git-version-macro 0.3.5
|
||||
CC0: rust-encoding-index-japanese 1.20141219.5
|
||||
CC0: rust-encoding-index-korean 1.20141219.5
|
||||
CC0: rust-encoding-index-simpchinese 1.20141219.5
|
||||
CC0: rust-encoding-index-singlebyte 1.20141219.5
|
||||
CC0: rust-encoding-index-tradchinese 1.20141219.5
|
||||
LGPLv3+: rust-ansi_colours 1.1.1
|
||||
MIT and GPLv2 with exceptions and BSD: rust-libgit2-sys 0.13.4
|
||||
MIT or ASL 2.0 or zlib: rust-tinyvec_macros 0.1.0
|
||||
MIT or ASL 2.0: rust-base64 0.13.0
|
||||
MIT or ASL 2.0: rust-bitflags 1.3.2
|
||||
MIT or ASL 2.0: rust-bstr 0.2.17
|
||||
MIT or ASL 2.0: rust-bugreport 0.5.0
|
||||
MIT or ASL 2.0: rust-cc 1.0.73
|
||||
MIT or ASL 2.0: rust-cfg-if 1.0.0
|
||||
MIT or ASL 2.0: rust-clircle 0.3.0
|
||||
MIT or ASL 2.0: rust-content_inspector 0.2.4
|
||||
MIT or ASL 2.0: rust-crc32fast 1.3.2
|
||||
MIT or ASL 2.0: rust-dirs-next 2.0.0
|
||||
MIT or ASL 2.0: rust-dirs-sys-next 0.1.2
|
||||
MIT or ASL 2.0: rust-either 1.7.0
|
||||
MIT or ASL 2.0: rust-env_logger 0.9.0
|
||||
MIT or ASL 2.0: rust-flate2 1.0.22
|
||||
MIT or ASL 2.0: rust-form_urlencoded 1.0.1
|
||||
MIT or ASL 2.0: rust-git2 0.14.4
|
||||
MIT or ASL 2.0: rust-glob 0.3.0
|
||||
MIT or ASL 2.0: rust-hashbrown 0.12.3
|
||||
MIT or ASL 2.0: rust-humantime 2.1.0
|
||||
MIT or ASL 2.0: rust-idna 0.2.3
|
||||
MIT or ASL 2.0: rust-itoa 1.0.2
|
||||
MIT or ASL 2.0: rust-jobserver 0.1.24
|
||||
MIT or ASL 2.0: rust-lazy_static 1.4.0
|
||||
MIT or ASL 2.0: rust-lazycell 1.3.0
|
||||
MIT or ASL 2.0: rust-libc 0.2.126
|
||||
MIT or ASL 2.0: rust-libgit2-sys 0.13.4
|
||||
MIT or ASL 2.0: rust-libz-sys 1.1.8
|
||||
MIT or ASL 2.0: rust-linked-hash-map 0.5.6
|
||||
MIT or ASL 2.0: rust-log 0.4.17
|
||||
MIT or ASL 2.0: rust-minimal-lexical 0.2.1
|
||||
MIT or ASL 2.0: rust-num_threads 0.1.6
|
||||
MIT or ASL 2.0: rust-once_cell 1.13.0
|
||||
MIT or ASL 2.0: rust-percent-encoding 2.1.0
|
||||
MIT or ASL 2.0: rust-pkg-config 0.3.25
|
||||
MIT or ASL 2.0: rust-proc-macro-hack 0.5.19
|
||||
MIT or ASL 2.0: rust-proc-macro2 1.0.40
|
||||
MIT or ASL 2.0: rust-quote 1.0.20
|
||||
MIT or ASL 2.0: rust-regex 1.6.0
|
||||
MIT or ASL 2.0: rust-regex-syntax 0.6.27
|
||||
MIT or ASL 2.0: rust-safemem 0.3.3
|
||||
MIT or ASL 2.0: rust-semver 1.0.12
|
||||
MIT or ASL 2.0: rust-serde 1.0.139
|
||||
MIT or ASL 2.0: rust-serde_derive 1.0.139
|
||||
MIT or ASL 2.0: rust-serde_json 1.0.82
|
||||
MIT or ASL 2.0: rust-serde_yaml 0.8.25
|
||||
MIT or ASL 2.0: rust-shell-escape 0.1.5
|
||||
MIT or ASL 2.0: rust-shell-words 1.1.0
|
||||
MIT or ASL 2.0: rust-shlex 1.1.0
|
||||
MIT or ASL 2.0: rust-syn 1.0.98
|
||||
MIT or ASL 2.0: rust-term_size 0.3.2
|
||||
MIT or ASL 2.0: rust-terminal_size 0.1.17
|
||||
MIT or ASL 2.0: rust-thiserror 1.0.31
|
||||
MIT or ASL 2.0: rust-thiserror-impl 1.0.31
|
||||
MIT or ASL 2.0: rust-time 0.3.11
|
||||
MIT or ASL 2.0: rust-unicode-bidi 0.3.8
|
||||
MIT or ASL 2.0: rust-unicode-ident 1.0.1
|
||||
MIT or ASL 2.0: rust-unicode-normalization 0.1.21
|
||||
MIT or ASL 2.0: rust-unicode-width 0.1.9
|
||||
MIT or ASL 2.0: rust-url 2.2.2
|
||||
MIT or ASL 2.0: rust-vec_map 0.8.2
|
||||
MIT or ASL 2.0: rust-yaml-rust 0.4.5
|
||||
MIT or zlib or ASL 2.0: rust-miniz_oxide 0.4.4
|
||||
MIT: rust-ansi_term 0.12.1
|
||||
MIT: rust-atty 0.2.14
|
||||
MIT: rust-bincode 1.3.3
|
||||
MIT: rust-clap2 2.34.0
|
||||
MIT: rust-console 0.15.0
|
||||
MIT: rust-encoding 0.2.33
|
||||
MIT: rust-matches 0.1.9
|
||||
MIT: rust-nom 7.1.1
|
||||
MIT: rust-onig 6.1.1
|
||||
MIT: rust-onig_sys 69.7.1
|
||||
MIT: rust-path-absolutize 3.0.11
|
||||
MIT: rust-path-dedot 3.0.14
|
||||
MIT: rust-plist 1.3.1
|
||||
MIT: rust-rgb 0.8.33
|
||||
MIT: rust-strsim 0.10.0
|
||||
MIT: rust-syntect 5.0.0
|
||||
MIT: rust-sys-info 0.9.1
|
||||
MIT: rust-textwrap0.11 0.11.0
|
||||
MIT: rust-which 4.2.5
|
||||
MIT: rust-xml-rs 0.8.4
|
||||
Unlicense or MIT: rust-aho-corasick 0.7.18
|
||||
Unlicense or MIT: rust-globset 0.4.8
|
||||
Unlicense or MIT: rust-grep-cli 0.1.6
|
||||
Unlicense or MIT: rust-memchr 2.5.0
|
||||
Unlicense or MIT: rust-regex-automata 0.1.10
|
||||
Unlicense or MIT: rust-same-file 1.0.6
|
||||
Unlicense or MIT: rust-termcolor 1.1.3
|
||||
Unlicense or MIT: rust-walkdir 2.3.2
|
||||
zlib or ASL 2.0 or MIT: rust-bytemuck 1.10.0
|
||||
zlib or ASL 2.0 or MIT: rust-tinyvec 1.6.0
|
@ -1,8 +1,8 @@
|
||||
--- bat-0.18.3/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ bat-0.18.3/Cargo.toml 2021-11-14T17:24:54.516671+00:00
|
||||
@@ -79,9 +79,8 @@
|
||||
version = "1.4"
|
||||
optional = true
|
||||
--- bat-0.21.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ bat-0.21.0/Cargo.toml 2022-07-21T08:43:28.724045+00:00
|
||||
@@ -93,9 +93,8 @@
|
||||
[dependencies.once_cell]
|
||||
version = "1.10"
|
||||
|
||||
-[dependencies.path_abs]
|
||||
-version = "0.5"
|
||||
@ -10,20 +10,5 @@
|
||||
+[dependencies.path-absolutize]
|
||||
+version = "3"
|
||||
|
||||
[dependencies.semver]
|
||||
version = "0.11"
|
||||
@@ -109,7 +108,7 @@
|
||||
version = "2.0"
|
||||
optional = true
|
||||
[dev-dependencies.assert_cmd]
|
||||
-version = "1.0.5"
|
||||
+version = "2.0.0"
|
||||
|
||||
[dev-dependencies.predicates]
|
||||
version = "1.0.7"
|
||||
@@ -134,4 +133,4 @@
|
||||
regex-fancy = ["syntect/regex-fancy"]
|
||||
regex-onig = ["syntect/regex-onig"]
|
||||
[target."cfg(unix)".dev-dependencies.nix]
|
||||
-version = "0.21.0"
|
||||
+version = "0.22.0"
|
||||
[dependencies.regex]
|
||||
version = "1.5.5"
|
||||
|
202
rust-bat.spec
202
rust-bat.spec
@ -1,56 +1,62 @@
|
||||
# Generated by rust2rpm 18
|
||||
# Generated by rust2rpm 21
|
||||
%bcond_without check
|
||||
|
||||
%global crate bat
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.18.3
|
||||
Version: 0.21.0
|
||||
Release: %autorelease
|
||||
Summary: Cat(1) clone with wings
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/bat
|
||||
Source: %{crates_source}
|
||||
Source0: %{crates_source}
|
||||
Source1: LICENSE.dependencies
|
||||
# Initial patched metadata
|
||||
# * Switch to path-absolutize, https://github.com/sharkdp/bat/pull/1025
|
||||
# * Bump assert_cmd to 2.0.0
|
||||
# * Bump nix to 0.22.0
|
||||
# * Port from path_abs to path-absolutize:
|
||||
# https://github.com/sharkdp/bat/pull/1025
|
||||
Patch0: bat-fix-metadata.diff
|
||||
Patch0001: 0001-Switch-to-path-absolutize.patch
|
||||
Patch1: 0001-port-from-path_abs-to-path-absolutize.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Cat(1) clone with wings.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%if ! %{__cargo_skip_build}
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
# 0BSD or MIT or ASL 2.0
|
||||
# ASL 2.0
|
||||
# ASL 2.0 or Boost
|
||||
# ASL 2.0 or MIT
|
||||
# BSD
|
||||
# CC0
|
||||
# LGPLv3+
|
||||
# MIT
|
||||
# MIT and GPLv2 with exceptions and BSD
|
||||
# MIT or ASL 2.0
|
||||
# MIT or ASL 2.0 or zlib
|
||||
# MIT or zlib or ASL 2.0
|
||||
# Unlicense or MIT
|
||||
License: ASL 2.0 and BSD and CC0 and LGPLv3+ and MIT
|
||||
# zlib or ASL 2.0 or MIT
|
||||
License: ASL 2.0 and BSD and CC0 and GPLv2 with exceptions and LGPLv3+ and MIT
|
||||
# LICENSE.dependencies contains a full license breakdown
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc doc README.md CONTRIBUTING.md CHANGELOG.md
|
||||
%license LICENSE-APACHE
|
||||
%license LICENSE-MIT
|
||||
%license NOTICE
|
||||
%license LICENSE.dependencies
|
||||
%doc CHANGELOG.md
|
||||
%doc CONTRIBUTING.md
|
||||
%doc README.md
|
||||
%{_bindir}/bat
|
||||
%{_mandir}/man1/bat.1*
|
||||
%{_datadir}/bash-completion/completions/bat
|
||||
@ -60,7 +66,6 @@ License: ASL 2.0 and BSD and CC0 and LGPLv3+ and MIT
|
||||
%dir %{_datadir}/fish
|
||||
%dir %{_datadir}/fish/vendor_completions.d
|
||||
%{_datadir}/fish/vendor_completions.d/bat.fish
|
||||
%endif
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
@ -68,13 +73,17 @@ BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc doc README.md CONTRIBUTING.md CHANGELOG.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%license %{crate_instdir}/NOTICE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
@ -82,11 +91,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+application-devel
|
||||
Summary: %{summary}
|
||||
@ -94,11 +103,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+application-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "application" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "application" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+application-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+atty-devel
|
||||
Summary: %{summary}
|
||||
@ -106,11 +115,35 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+atty-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "atty" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "atty" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+atty-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bugreport-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bugreport-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bugreport" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bugreport-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+build-assets-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+build-assets-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "build-assets" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+build-assets-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+clap-devel
|
||||
Summary: %{summary}
|
||||
@ -118,11 +151,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+clap-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "clap" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "clap" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+clap-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dirs-next-devel
|
||||
Summary: %{summary}
|
||||
@ -130,11 +163,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dirs-next-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "dirs-next" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "dirs-next" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dirs-next-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+git-devel
|
||||
Summary: %{summary}
|
||||
@ -142,11 +175,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+git-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "git" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "git" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+git-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+git2-devel
|
||||
Summary: %{summary}
|
||||
@ -154,23 +187,35 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+git2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "git2" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "git2" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+git2-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+lazy_static-devel
|
||||
%package -n %{name}+grep-cli-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+lazy_static-devel %{_description}
|
||||
%description -n %{name}+grep-cli-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "lazy_static" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "grep-cli" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+lazy_static-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%files -n %{name}+grep-cli-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+minimal-application-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+minimal-application-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "minimal-application" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+minimal-application-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+paging-devel
|
||||
Summary: %{summary}
|
||||
@ -178,11 +223,35 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+paging-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "paging" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "paging" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+paging-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-fancy-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-fancy-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex-fancy" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-fancy-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-onig-devel
|
||||
Summary: %{summary}
|
||||
@ -190,11 +259,11 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-onig-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "regex-onig" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex-onig" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-onig-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+shell-words-devel
|
||||
Summary: %{summary}
|
||||
@ -202,11 +271,23 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+shell-words-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "shell-words" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "shell-words" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+shell-words-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+walkdir-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+walkdir-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "walkdir" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+walkdir-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+wild-devel
|
||||
Summary: %{summary}
|
||||
@ -214,14 +295,15 @@ BuildArch: noarch
|
||||
|
||||
%description -n %{name}+wild-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "wild" feature of "%{crate}" crate.
|
||||
This package contains library source intended for building other packages which
|
||||
use the "wild" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+wild-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
cp %{SOURCE1} .
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bat-0.18.3.crate) = 078a08248b63ab602b78f05efd1721a3e1173c1b6ec9eb1f0d0e6bad954ef6c2063c6221558c102e4dac79433c2ed3bc69003d0aec4b49722b6e574bd8f7f7b3
|
||||
SHA512 (bat-0.21.0.crate) = 5d3b3e00b961da9875eb0c74a82acd50c12bb5a0c76bfcd41109e5524344de67b78dca6c5bd5a801e833bff69529950d6c9cfa7e1964af4d0167664037d62aa9
|
||||
|
Loading…
Reference in New Issue
Block a user