29 lines
968 B
Diff
29 lines
968 B
Diff
From 9fedac991e717f0103d092275ac301e58c5cf010 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
|
Date: Tue, 2 Dec 2014 10:56:58 +0100
|
|
Subject: [PATCH] Generate preludes using miniruby.
|
|
|
|
---
|
|
common.mk | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/common.mk b/common.mk
|
|
index 76f1621..b0f6e28 100644
|
|
--- a/common.mk
|
|
+++ b/common.mk
|
|
@@ -782,9 +782,9 @@ $(PRELUDE_C): $(COMPILE_PRELUDE) \
|
|
$(PRELUDE_C): $(COMPILE_PRELUDE) \
|
|
{$(srcdir)}lib/rubygems/defaults.rb \
|
|
{$(srcdir)}lib/rubygems/core_ext/kernel_gem.rb \
|
|
- $(PRELUDE_SCRIPTS) $(LIB_SRCS)
|
|
+ $(PRELUDE_SCRIPTS) $(PREP) $(LIB_SRCS)
|
|
$(ECHO) generating $@
|
|
- $(Q) $(BASERUBY) $(srcdir)/tool/generic_erb.rb -I$(srcdir) -c -o $@ \
|
|
+ $(Q) $(MINIRUBY) $(srcdir)/tool/generic_erb.rb -I$(srcdir) -c -o $@ \
|
|
$(srcdir)/template/prelude.c.tmpl $(PRELUDE_SCRIPTS)
|
|
|
|
{$(VPATH)}golf_prelude.c: $(COMPILE_PRELUDE) {$(srcdir)}golf_prelude.rb
|
|
--
|
|
2.1.0
|
|
|