Upgrade to Ruby 2.5.0 (r60213).
This commit is contained in:
parent
a723452328
commit
f55c942dfb
@ -11,7 +11,7 @@ diff --git a/lib/mkmf.rb b/lib/mkmf.rb
|
||||
index 682eb46..e6b1445 100644
|
||||
--- a/lib/mkmf.rb
|
||||
+++ b/lib/mkmf.rb
|
||||
@@ -1900,7 +1900,7 @@ def configuration(srcdir)
|
||||
@@ -1899,7 +1899,7 @@ def configuration(srcdir)
|
||||
SHELL = /bin/sh
|
||||
|
||||
# V=0 quiet, V=1 verbose. other values don't work.
|
||||
|
@ -26,7 +26,7 @@ diff --git a/common.mk b/common.mk
|
||||
index 5cfbc3d..3f0a82e 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -145,7 +145,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(INITOBJS)
|
||||
@@ -147,7 +147,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(INITOBJS)
|
||||
GOLFOBJS = goruby.$(OBJEXT) golf_prelude.$(OBJEXT)
|
||||
|
||||
DEFAULT_PRELUDES = $(GEM_PRELUDE)
|
||||
@ -39,7 +39,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 028ef7ca3e..cdeff87871 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4543,6 +4543,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
@@ -4387,6 +4387,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
AC_SUBST(sitearchhdrdir)dnl
|
||||
AC_SUBST(vendorarchhdrdir)dnl
|
||||
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 11fc237552..b77e88fc37 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3780,6 +3780,11 @@ AS_IF([test ${multiarch+set}], [
|
||||
@@ -3632,6 +3632,11 @@ AS_IF([test ${multiarch+set}], [
|
||||
])
|
||||
|
||||
archlibdir='${libdir}/${arch}'
|
||||
|
@ -14,7 +14,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 999e2d6d5d..11fc237552 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4397,7 +4397,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
@@ -4242,7 +4242,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||
|
||||
if test -z "${ruby_version_dir_name}"; then
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index b77e88fc37..6bba453e3c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4461,6 +4461,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
@@ -4306,6 +4306,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||
|
||||
|
@ -15,7 +15,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 6bba453e3c..028ef7ca3e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4433,6 +4433,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
@@ -4278,6 +4278,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -26,7 +26,7 @@ index 6bba453e3c..028ef7ca3e 100644
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4457,6 +4461,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4302,6 +4306,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
@ -67,7 +67,7 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
|
||||
index b47b6e1..0b99408 100755
|
||||
--- a/tool/rbinstall.rb
|
||||
+++ b/tool/rbinstall.rb
|
||||
@@ -330,6 +330,7 @@ def CONFIG.[](name, mandatory = false)
|
||||
@@ -331,6 +331,7 @@ def CONFIG.[](name, mandatory = false)
|
||||
sitearchlibdir = CONFIG["sitearchdir"]
|
||||
vendorlibdir = CONFIG["vendorlibdir"]
|
||||
vendorarchlibdir = CONFIG["vendorarchdir"]
|
||||
@ -75,7 +75,7 @@ index b47b6e1..0b99408 100755
|
||||
mandir = CONFIG["mandir", true]
|
||||
docdir = CONFIG["docdir", true]
|
||||
configure_args = Shellwords.shellwords(CONFIG["configure_args"])
|
||||
@@ -536,7 +537,13 @@ def install(src, cmd)
|
||||
@@ -537,7 +538,13 @@ def install(src, cmd)
|
||||
install?(:local, :comm, :lib) do
|
||||
prepare "library scripts", rubylibdir
|
||||
noinst = %w[*.txt *.rdoc *.gemspec]
|
||||
|
@ -11,7 +11,7 @@ diff --git a/common.mk b/common.mk
|
||||
index 168dc52..20c218a 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -953,9 +953,9 @@ $(MINIPRELUDE_C): $(COMPILE_PRELUDE)
|
||||
@@ -956,9 +956,9 @@ $(MINIPRELUDE_C): $(COMPILE_PRELUDE)
|
||||
$(srcdir)/template/prelude.c.tmpl
|
||||
|
||||
$(PRELUDE_C): $(COMPILE_PRELUDE) \
|
||||
|
@ -20,7 +20,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 8ea969412f..a00f2b6776 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4348,9 +4348,6 @@ AS_CASE(["$target_os"],
|
||||
@@ -4193,9 +4193,6 @@ AS_CASE(["$target_os"],
|
||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||
])
|
||||
|
||||
@ -30,7 +30,7 @@ index 8ea969412f..a00f2b6776 100644
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
@@ -4373,56 +4370,62 @@ AC_ARG_WITH(ridir,
|
||||
@@ -4218,56 +4215,62 @@ AC_ARG_WITH(ridir,
|
||||
AC_SUBST(ridir)
|
||||
AC_SUBST(RI_BASE_NAME)
|
||||
|
||||
@ -120,7 +120,7 @@ index 8ea969412f..a00f2b6776 100644
|
||||
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
@@ -4439,6 +4442,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
@@ -4284,6 +4287,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
AC_SUBST(arch)dnl
|
||||
AC_SUBST(sitearch)dnl
|
||||
AC_SUBST(ruby_version)dnl
|
||||
@ -171,7 +171,7 @@ diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
|
||||
index d4c110e..d39c9a6 100755
|
||||
--- a/tool/rbinstall.rb
|
||||
+++ b/tool/rbinstall.rb
|
||||
@@ -416,7 +416,7 @@ def CONFIG.[](name, mandatory = false)
|
||||
@@ -417,7 +417,7 @@ def CONFIG.[](name, mandatory = false)
|
||||
|
||||
install?(:doc, :rdoc) do
|
||||
if $rdocdir
|
||||
@ -282,7 +282,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index a00f2b6776..999e2d6d5d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -278,7 +278,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
@@ -164,7 +164,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`
|
||||
AC_SUBST(RUBY_BASE_NAME)
|
||||
AC_SUBST(RUBYW_BASE_NAME)
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 68b8e9b42f1baf67f8ef9535d213fd0bd7ae42f4 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 25 Aug 2017 13:21:56 +0200
|
||||
Subject: [PATCH] Revert "tool/runruby.rb: test with smallest possible machine
|
||||
stack"
|
||||
|
||||
This reverts commit c4e2cf466448f4283fd3f8a17a73f5fa9b745fe1.
|
||||
---
|
||||
tool/runruby.rb | 7 +------
|
||||
1 file changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/tool/runruby.rb b/tool/runruby.rb
|
||||
index f6c46779e3..cade314748 100755
|
||||
--- a/tool/runruby.rb
|
||||
+++ b/tool/runruby.rb
|
||||
@@ -67,12 +67,7 @@ def File.realpath(*args)
|
||||
libs << File.expand_path("lib", srcdir)
|
||||
config["bindir"] = abs_archdir
|
||||
|
||||
-env = {
|
||||
- # Test with the smallest possible machine stack sizes.
|
||||
- # These values are clamped to machine-dependent minimum values in vm_core.h
|
||||
- 'RUBY_THREAD_MACHINE_STACK_SIZE' => '1',
|
||||
- 'RUBY_FIBER_MACHINE_STACK_SIZE' => '1',
|
||||
-}
|
||||
+env = {}
|
||||
|
||||
runner = File.join(abs_archdir, "exe/ruby#{config['EXEEXT']}")
|
||||
runner = nil unless File.exist?(runner)
|
||||
--
|
||||
2.14.1
|
||||
|
62
ruby.spec
62
ruby.spec
@ -10,7 +10,7 @@
|
||||
#%%global milestone rc1
|
||||
|
||||
# Keep the revision enabled for pre-releases from SVN.
|
||||
%global revision 60213
|
||||
%global revision 61169
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -29,7 +29,7 @@
|
||||
%global rubygems_dir %{_datadir}/rubygems
|
||||
|
||||
# Bundled libraries versions
|
||||
%global rubygems_version 2.6.14
|
||||
%global rubygems_version 2.7.3
|
||||
%global molinillo_version 0.5.7
|
||||
|
||||
# TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
|
||||
@ -37,18 +37,18 @@
|
||||
%global irb_version %{ruby_version}
|
||||
|
||||
%global bigdecimal_version 1.3.2
|
||||
%global bundler_version 1.15.4
|
||||
%global bundler_version 1.16.1.pre1
|
||||
%global did_you_mean_version 1.1.2
|
||||
%global io_console_version 0.4.6
|
||||
%global json_version 2.1.0
|
||||
%global minitest_version 5.10.3
|
||||
%global net_telnet_version 0.1.1
|
||||
%global openssl_version 2.1.0.beta1
|
||||
%global power_assert_version 1.1.0
|
||||
%global psych_version 3.0.0.beta3
|
||||
%global rake_version 12.1.0
|
||||
%global rdoc_version 6.0.0.beta3
|
||||
%global test_unit_version 3.2.5
|
||||
%global openssl_version 2.1.0.beta2
|
||||
%global power_assert_version 1.1.1
|
||||
%global psych_version 3.0.0
|
||||
%global rake_version 12.3.0
|
||||
%global rdoc_version 6.0.0
|
||||
%global test_unit_version 3.2.7
|
||||
%global xmlrpc_version 0.3.0
|
||||
|
||||
# Might not be needed in the future, if we are lucky enough.
|
||||
@ -133,10 +133,6 @@ Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# https://bugs.ruby-lang.org/issues/12666
|
||||
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
|
||||
|
||||
# Avoids SEGV in TestBacktrace#test_caller_lev segaults on PPC.
|
||||
# https://bugs.ruby-lang.org/issues/13757
|
||||
Patch100: ruby-2.5.0-Revert-runruby-test-with-smallest-possible-machine-stack.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Suggests: rubypick
|
||||
Recommends: ruby(rubygems) >= %{rubygems_version}
|
||||
@ -517,8 +513,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch7 -p1
|
||||
%patch9 -p1
|
||||
|
||||
%patch100 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
|
||||
@ -703,17 +697,9 @@ sed -i 's/^/%lang(ja) /' .ruby-doc.ja
|
||||
|
||||
%check
|
||||
%if 0%{?with_hardening_test}
|
||||
# Temporary change the hardening check on PPC64LE as long as the checksec is
|
||||
# is providing incorrect output.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1479302
|
||||
%ifnarch ppc64le
|
||||
# Check Ruby hardening.
|
||||
checksec -f libruby.so.%{ruby_version} | \
|
||||
grep "Full RELRO.*Canary found.*NX enabled.*DSO.*No RPATH.*No RUNPATH.*Yes.*\d*.*\d*.*libruby.so.%{ruby_version}"
|
||||
%else
|
||||
checksec -f libruby.so.%{ruby_version} | \
|
||||
grep "Full RELRO.*Canary found.*NX enabled.*DSO.*No RPATH.*No RUNPATH.*No.*\d*.*\d*.*libruby.so.%{ruby_version}"
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# Check RubyGems version correctness.
|
||||
@ -740,6 +726,10 @@ DISABLE_TESTS=""
|
||||
# Once seen: http://koji.fedoraproject.org/koji/taskinfo?taskID=12556650
|
||||
DISABLE_TESTS="$DISABLE_TESTS -x test_fork.rb"
|
||||
|
||||
# Disable failing TestProcess#test_maxgroups test.
|
||||
# https://bugs.ruby-lang.org/issues/14174
|
||||
sed -i '/def test_maxgroups$/,/^ end$/ s/^/#/' test/ruby/test_process.rb
|
||||
|
||||
make check TESTS="-v $DISABLE_TESTS"
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
@ -940,23 +930,23 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%exclude %{gem_dir}/cache/*
|
||||
|
||||
# TODO: Gemify these libraries
|
||||
%{gem_dir}/specifications/default/cmath-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/cmath-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/csv-0.1.0.gemspec
|
||||
%{gem_dir}/specifications/default/date-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/dbm-1.0.0.beta1.gemspec
|
||||
%{gem_dir}/specifications/default/date-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/dbm-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/digest-0.1.0.gemspec
|
||||
%{gem_dir}/specifications/default/etc-0.2.1.gemspec
|
||||
%{gem_dir}/specifications/default/fcntl-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/fiddle-1.0.0.beta2.gemspec
|
||||
%{gem_dir}/specifications/default/fileutils-0.7.2.gemspec
|
||||
%{gem_dir}/specifications/default/gdbm-2.0.0.beta1.gemspec
|
||||
%{gem_dir}/specifications/default/ipaddr-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/scanf-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/sdbm-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/fcntl-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/fiddle-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/fileutils-1.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/gdbm-2.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/ipaddr-1.2.0.gemspec
|
||||
%{gem_dir}/specifications/default/scanf-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/sdbm-1.0.0.gemspec
|
||||
%{gem_dir}/specifications/default/stringio-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/strscan-0.0.1.gemspec
|
||||
%{gem_dir}/specifications/default/webrick-1.4.0.beta1.gemspec
|
||||
%{gem_dir}/specifications/default/zlib-0.1.0.gemspec
|
||||
%{gem_dir}/specifications/default/zlib-1.0.0.gemspec
|
||||
|
||||
%files -n rubygems-devel
|
||||
%{_rpmconfigdir}/macros.d/macros.rubygems
|
||||
@ -1063,8 +1053,8 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||
|
||||
%changelog
|
||||
* Tue Apr 11 2017 Vít Ondruch <vondruch@redhat.com> - 2.5.0-0.1.r60213
|
||||
- Upgrade to Ruby 2.5.0 (r60213).
|
||||
* Tue Apr 11 2017 Vít Ondruch <vondruch@redhat.com> - 2.5.0-0.1.r61169
|
||||
- Upgrade to Ruby 2.5.0 (r61169).
|
||||
- Drop ruby-devel dependency on rubypick, which is pulled in transtitively.
|
||||
|
||||
* Mon Apr 03 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.1-79
|
||||
|
Loading…
x
Reference in New Issue
Block a user