Upgrade to Ruby 2.6.2.
This commit is contained in:
parent
392287d18b
commit
f4c0ae4dea
@ -245,7 +245,7 @@ diff --git a/test/rubygems/test_gem.rb b/test/rubygems/test_gem.rb
|
||||
index 0428bea..b6e090e 100644
|
||||
--- a/test/rubygems/test_gem.rb
|
||||
+++ b/test/rubygems/test_gem.rb
|
||||
@@ -1280,7 +1280,8 @@ def test_self_use_paths
|
||||
@@ -1288,7 +1288,8 @@ def test_self_use_paths
|
||||
|
||||
def test_self_user_dir
|
||||
parts = [@userhome, '.gem', Gem.ruby_engine]
|
||||
@ -255,7 +255,7 @@ index 0428bea..b6e090e 100644
|
||||
|
||||
assert_equal File.join(parts), Gem.user_dir
|
||||
end
|
||||
@@ -1357,7 +1358,7 @@ def test_self_gzip
|
||||
@@ -1365,7 +1366,7 @@ def test_self_gzip
|
||||
def test_self_vendor_dir
|
||||
expected =
|
||||
File.join RbConfig::CONFIG['vendordir'], 'gems',
|
||||
|
@ -1,43 +0,0 @@
|
||||
From b228a084aa200c82deaf02ee3cfa91943171f166 Mon Sep 17 00:00:00 2001
|
||||
From: naruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
||||
Date: Wed, 30 Jan 2019 13:09:26 +0000
|
||||
Subject: [PATCH] merge revision(s) 66888: [Backport #15460]
|
||||
|
||||
* Fix rubyspec to follow IO#ungetbyte's fix
|
||||
Merge CRuby r66824
|
||||
With fixing actual spec and the version the change applied.
|
||||
|
||||
|
||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_6@66952 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
||||
---
|
||||
spec/ruby/core/io/ungetbyte_spec.rb | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/spec/ruby/core/io/ungetbyte_spec.rb b/spec/ruby/core/io/ungetbyte_spec.rb
|
||||
index 2e51fb02987c..f5f9a11be154 100644
|
||||
--- a/spec/ruby/core/io/ungetbyte_spec.rb
|
||||
+++ b/spec/ruby/core/io/ungetbyte_spec.rb
|
||||
@@ -49,7 +49,7 @@
|
||||
end
|
||||
end
|
||||
|
||||
- ruby_version_is '2.6'...'2.7' do
|
||||
+ ruby_version_is '2.6'...'2.6.1' do
|
||||
it "is an RangeError if the integer is not in 8bit" do
|
||||
for i in [4095, 0x4f7574206f6620636861722072616e6765] do
|
||||
lambda { @io.ungetbyte(i) }.should raise_error(RangeError)
|
||||
@@ -57,10 +57,11 @@
|
||||
end
|
||||
end
|
||||
|
||||
- ruby_version_is '2.7' do
|
||||
+ ruby_version_is '2.6.1' do
|
||||
it "never raises RangeError" do
|
||||
- for i in [4095, 0x4f7574206f6620636861722072616e6765] do
|
||||
- lambda { @io.ungetbyte(i) }.should_not raise_error
|
||||
+ for i in [4095, 0x4f7574206f6620636861722072616e67ff] do
|
||||
+ @io.ungetbyte(i).should be_nil
|
||||
+ @io.getbyte.should == 255
|
||||
end
|
||||
end
|
||||
end
|
14
ruby.spec
14
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 2
|
||||
%global minor_version 6
|
||||
%global teeny_version 1
|
||||
%global teeny_version 2
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 115
|
||||
%global release 116
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
# The RubyGems library has to stay out of Ruby directory tree, since the
|
||||
@ -29,7 +29,7 @@
|
||||
%global rubygems_dir %{_datadir}/rubygems
|
||||
|
||||
# Bundled libraries versions
|
||||
%global rubygems_version 3.0.1
|
||||
%global rubygems_version 3.0.3
|
||||
%global rubygems_molinillo_version 0.5.7
|
||||
|
||||
%global bundler_version 1.17.2
|
||||
@ -146,10 +146,6 @@ Patch11: rubygems-3.0.3-Restore-gem-build-behavior-and-introdcue-the-C-flag-to-g
|
||||
# This allows to loosen the RDoc dependency again.
|
||||
# https://github.com/rubygems/rubygems/pull/2604
|
||||
Patch12: rubygems-3.0.3-Avoid-rdoc-hook-when-its-failed-to-load-rdoc-library.patch
|
||||
# Fix "IO#ungetbyte is an RangeError if the integer is not in 8bit FAILED"
|
||||
# test failure.
|
||||
# https://bugs.ruby-lang.org/issues/15460
|
||||
Patch13: ruby-2.6.1-Fix-rubyspec-to-follow-IO-ungetbyte-fix.patch
|
||||
|
||||
# Add support for .include directive used by OpenSSL config files.
|
||||
# https://github.com/ruby/openssl/pull/216
|
||||
@ -547,7 +543,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch9 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch22 -p1
|
||||
%patch23 -p1
|
||||
|
||||
@ -1170,6 +1165,9 @@ make check TESTS="-v $DISABLE_TESTS" MSPECOPT="-fs $MSPECOPTS"
|
||||
%{_mandir}/man5/gemfile.5*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 14 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.2-116
|
||||
- Upgrade to Ruby 2.6.2.
|
||||
|
||||
* Tue Mar 05 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.1-115
|
||||
- Fix ".include =" support in openssl.cnf (rhbz#1668916).
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ruby-2.6.1.tar.xz) = fb36289a955f0596c683cdadf1e4a9a9fd35222b1e1c6160c2e7cd82e5befd40a7aa4361e55f7a8f83c06ee899ec493821c7db34a60c4ac3bca0e874d33ef1a9
|
||||
SHA512 (ruby-2.6.2.tar.xz) = 13f7d7b483a037378eac4bf4bebddc21d69f4e19e6bbb397dd53e7518037ae9a3aa5b41fc20bf1fe410803c6efc3a6a65a65af47648d3a93713f75cfe885326a
|
||||
|
Loading…
Reference in New Issue
Block a user