Update to Ruby 2.0.0-p0.
This commit is contained in:
parent
405ae9bea2
commit
eba90976c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ ruby-rev415a3ef9ab82c65a7abc-ext_tk.tar.gz
|
|||||||
/ruby-1.9.3-p374.tar.gz
|
/ruby-1.9.3-p374.tar.gz
|
||||||
/ruby-1.9.3-p385.tar.gz
|
/ruby-1.9.3-p385.tar.gz
|
||||||
/ruby-2.0.0-r39387.tar.gz
|
/ruby-2.0.0-r39387.tar.gz
|
||||||
|
/ruby-2.0.0-p0.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From c42cf83f26309b0cba46917f79d20d680e667054 Mon Sep 17 00:00:00 2001
|
|
||||||
From: mrkn <mrkn@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
|
|
||||||
Date: Tue, 19 Feb 2013 11:50:48 +0000
|
|
||||||
Subject: [PATCH] * ext/bigdecimal/bigdecimal.gemspec: bump to 1.2.0.
|
|
||||||
[ruby-core:51777] [Bug #7761]
|
|
||||||
|
|
||||||
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39321 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
|
|
||||||
---
|
|
||||||
ext/bigdecimal/bigdecimal.gemspec | 4 ++--
|
|
||||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/ext/bigdecimal/bigdecimal.gemspec b/ext/bigdecimal/bigdecimal.gemspec
|
|
||||||
index 362808c..4240f82 100644
|
|
||||||
--- a/ext/bigdecimal/bigdecimal.gemspec
|
|
||||||
+++ b/ext/bigdecimal/bigdecimal.gemspec
|
|
||||||
@@ -1,10 +1,10 @@
|
|
||||||
# -*- ruby -*-
|
|
||||||
-_VERSION = "1.1.0"
|
|
||||||
+_VERSION = "1.2.0"
|
|
||||||
|
|
||||||
Gem::Specification.new do |s|
|
|
||||||
s.name = "bigdecimal"
|
|
||||||
s.version = _VERSION
|
|
||||||
- s.date = "2011-07-30"
|
|
||||||
+ s.date = "2012-02-19"
|
|
||||||
s.summary = "Arbitrary-precision decimal floating-point number library."
|
|
||||||
s.homepage = "http://www.ruby-lang.org"
|
|
||||||
s.email = "mrkn@mrkn.jp"
|
|
||||||
--
|
|
||||||
1.8.1.2
|
|
||||||
|
|
13
ruby.spec
13
ruby.spec
@ -13,7 +13,7 @@
|
|||||||
#%%global milestone preview2
|
#%%global milestone preview2
|
||||||
|
|
||||||
# Keep the revision enabled for pre-releases from SVN.
|
# Keep the revision enabled for pre-releases from SVN.
|
||||||
%global revision 39387
|
#%%global revision 39387
|
||||||
|
|
||||||
%global ruby_archive %{name}-%{ruby_version}
|
%global ruby_archive %{name}-%{ruby_version}
|
||||||
|
|
||||||
@ -26,7 +26,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%global release 3
|
%global release 1
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||||
|
|
||||||
%global ruby_libdir %{_datadir}/%{name}
|
%global ruby_libdir %{_datadir}/%{name}
|
||||||
@ -62,7 +62,7 @@
|
|||||||
%global irb_version %{ruby_version_patch_level}
|
%global irb_version %{ruby_version_patch_level}
|
||||||
%global rdoc_version 4.0.0
|
%global rdoc_version 4.0.0
|
||||||
%global bigdecimal_version 1.2.0
|
%global bigdecimal_version 1.2.0
|
||||||
%global io_console_version 0.4.1
|
%global io_console_version 0.4.2
|
||||||
%global json_version 1.7.7
|
%global json_version 1.7.7
|
||||||
%global minitest_version 4.3.2
|
%global minitest_version 4.3.2
|
||||||
%global psych_version 2.0.0
|
%global psych_version 2.0.0
|
||||||
@ -93,9 +93,6 @@ Source3: ruby-exercise.stp
|
|||||||
Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
|
Patch0: ruby-2.0.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
|
||||||
# http://bugs.ruby-lang.org/issues/7808
|
# http://bugs.ruby-lang.org/issues/7808
|
||||||
Patch1: ruby-1.9.3-arch-specific-dir.patch
|
Patch1: ruby-1.9.3-arch-specific-dir.patch
|
||||||
# Fixes rubygem-bigdecimla version.
|
|
||||||
# https://bugs.ruby-lang.org/issues/7761
|
|
||||||
Patch2: ruby-2.0.0-ext-bigdecimal-bigdecimal.gemspec-bump-to-1.2.0.patch
|
|
||||||
# Force multiarch directories for i.86 to be always named i386. This solves
|
# Force multiarch directories for i.86 to be always named i386. This solves
|
||||||
# some differencies in build between Fedora and RHEL.
|
# some differencies in build between Fedora and RHEL.
|
||||||
Patch3: ruby-1.9.3-always-use-i386.patch
|
Patch3: ruby-1.9.3-always-use-i386.patch
|
||||||
@ -380,7 +377,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
|||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
@ -866,6 +862,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
|||||||
%{ruby_libdir}/tkextlib
|
%{ruby_libdir}/tkextlib
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 25 2013 Vít Ondruch <vondruch@redhat.com> - 2.0.0.0-1
|
||||||
|
- Update to Ruby 2.0.0-p0.
|
||||||
|
|
||||||
* Mon Feb 25 2013 Mamoru TASAKA <mtasaka@fedoraprojec.org> - 2.0.0.0-0.3.r39387
|
* Mon Feb 25 2013 Mamoru TASAKA <mtasaka@fedoraprojec.org> - 2.0.0.0-0.3.r39387
|
||||||
- Move test-unit.gemspec to -libs subpackage for now because rubygems
|
- Move test-unit.gemspec to -libs subpackage for now because rubygems
|
||||||
2.0.0 does not create this
|
2.0.0 does not create this
|
||||||
|
Loading…
Reference in New Issue
Block a user