Update to Ruby 2.2.4.
This commit is contained in:
parent
b3ffc2fef6
commit
e467536081
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/ruby-2.2.1.tar.xz
|
||||
/ruby-2.2.2.tar.xz
|
||||
/ruby-2.2.3.tar.xz
|
||||
/ruby-2.2.4.tar.xz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From b9fa5fc9a14e6c889c9a0fa9c9386b2018f2314c Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Evans <code@jeremyevans.net>
|
||||
Date: Fri, 17 Jul 2015 11:25:09 -0600
|
||||
Subject: [PATCH 4/8] Don't force SSLv3 in test, as it is insecure and may not
|
||||
be supported
|
||||
|
||||
LibreSSL disables SSLv3 by default, and there's no reason this code
|
||||
should require SSLv3.
|
||||
|
||||
diff --git test/openssl/test_ssl_session.rb test/openssl/test_ssl_session.rb
|
||||
index 0c384c7..d4713d9 100644
|
||||
--- test/openssl/test_ssl_session.rb
|
||||
+++ test/openssl/test_ssl_session.rb
|
||||
@@ -355,7 +355,7 @@ __EOS__
|
||||
3.times do
|
||||
sock = TCPSocket.new("127.0.0.1", port)
|
||||
begin
|
||||
- ssl = OpenSSL::SSL::SSLSocket.new(sock, OpenSSL::SSL::SSLContext.new("SSLv3"))
|
||||
+ ssl = OpenSSL::SSL::SSLSocket.new(sock, OpenSSL::SSL::SSLContext.new)
|
||||
ssl.sync_close = true
|
||||
ssl.session = last_client_session if last_client_session
|
||||
ssl.connect
|
||||
--
|
||||
2.4.5
|
||||
|
@ -1,23 +0,0 @@
|
||||
From fb08c34eee2c883a01ab0dda2a2e34a290516a2a Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Evans <code@jeremyevans.net>
|
||||
Date: Fri, 17 Jul 2015 11:31:45 -0600
|
||||
Subject: [PATCH 5/8] Use OP_NO_TICKET when testing SSL session cache callbacks
|
||||
|
||||
This fixes the test when using LibreSSL and possibly some
|
||||
configurations of OpenSSL.
|
||||
|
||||
diff --git test/openssl/test_ssl_session.rb test/openssl/test_ssl_session.rb
|
||||
index d4713d9..58fa20b 100644
|
||||
--- test/openssl/test_ssl_session.rb
|
||||
+++ test/openssl/test_ssl_session.rb
|
||||
@@ -316,6 +316,7 @@ __EOS__
|
||||
|
||||
ctx_proc = Proc.new { |ctx, ssl|
|
||||
ctx.session_cache_mode = OpenSSL::SSL::SSLContext::SESSION_CACHE_SERVER
|
||||
+ ctx.options = OpenSSL::SSL::OP_NO_TICKET
|
||||
last_server_session = nil
|
||||
|
||||
# get_cb is called whenever a client proposed to resume a session but
|
||||
--
|
||||
2.4.5
|
||||
|
@ -1,13 +0,0 @@
|
||||
Index: test/openssl/test_ssl_session.rb
|
||||
===================================================================
|
||||
--- test/openssl/test_ssl_session.rb (revision 49098)
|
||||
+++ test/openssl/test_ssl_session.rb (revision 49099)
|
||||
@@ -278,7 +278,7 @@
|
||||
|
||||
def test_ctx_client_session_cb
|
||||
called = {}
|
||||
- ctx = OpenSSL::SSL::SSLContext.new("SSLv3")
|
||||
+ ctx = OpenSSL::SSL::SSLContext.new
|
||||
ctx.session_cache_mode = OpenSSL::SSL::SSLContext::SESSION_CACHE_CLIENT
|
||||
|
||||
ctx.session_new_cb = lambda { |ary|
|
15
ruby.spec
15
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 2
|
||||
%global minor_version 2
|
||||
%global teeny_version 3
|
||||
%global teeny_version 4
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 46
|
||||
%global release 47
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
%global rubygems_version 2.4.5.1
|
||||
@ -115,11 +115,6 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# Use miniruby to regenerate prelude.c.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# Don't use SSLv3 for tests.
|
||||
# https://bugs.ruby-lang.org/issues/10046
|
||||
Patch9: ruby-2.3.0-fix-test-ctx-client-session-cb.patch
|
||||
Patch10: ruby-2.3.0-Don-t-force-SSLv3-in-test-as-it-is-insecure-and-may-.patch
|
||||
Patch11: ruby-2.3.0-Use-OP_NO_TICKET-when-testing-SSL-session-cache-call.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||
@ -421,9 +416,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch9
|
||||
%patch10
|
||||
%patch11
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -898,6 +890,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Mon Dec 21 2015 Vít Ondruch <vondruch@redhat.com> - 2.2.4-47
|
||||
- Update to Ruby 2.2.4.
|
||||
|
||||
* Thu Dec 10 2015 Vít Ondruch <vondruch@redhat.com> - 2.2.3-46
|
||||
- Fix ABRT hook autoloading.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user