Disbable sse2 on i668 (bug #1101811)
This commit is contained in:
parent
1610d07dcd
commit
de383e7548
41
ruby-nosse2.patch
Normal file
41
ruby-nosse2.patch
Normal file
@ -0,0 +1,41 @@
|
||||
diff -up ruby-2.1.5/configure.in.nosse2 ruby-2.1.5/configure.in
|
||||
--- ruby-2.1.5/configure.in.nosse2 2014-12-26 16:31:57.696889054 -0700
|
||||
+++ ruby-2.1.5/configure.in 2014-12-26 16:32:25.187718930 -0700
|
||||
@@ -860,22 +860,6 @@ if test "$GCC" = yes; then
|
||||
for oflag in -fno-fast-math; do
|
||||
RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
|
||||
done
|
||||
- AS_CASE(["$target"],
|
||||
- [*-darwin*], [
|
||||
- # doesn't seem necessary on Mac OS X
|
||||
- ],
|
||||
- [[i[4-6]86*|i386*mingw*]], [
|
||||
- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
|
||||
- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
|
||||
- ])
|
||||
- AS_CASE(["$XCFLAGS"],
|
||||
- [[*-msse2*]], [
|
||||
- RUBY_TRY_CFLAGS(-mstackrealign, [
|
||||
- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
|
||||
- ])
|
||||
- ])
|
||||
- ]
|
||||
- )
|
||||
fi
|
||||
|
||||
AC_ARG_WITH(opt-dir,
|
||||
diff -up ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 ruby-2.1.5/test/ruby/test_sprintf.rb
|
||||
--- ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 2014-09-03 09:25:51.000000000 -0600
|
||||
+++ ruby-2.1.5/test/ruby/test_sprintf.rb 2014-12-26 16:31:57.699889035 -0700
|
||||
@@ -194,8 +194,9 @@ class TestSprintf < Test::Unit::TestCase
|
||||
sprintf("%20.0f", 36893488147419107329.0))
|
||||
assert_equal(" Inf", sprintf("% 0e", 1.0/0.0), "moved from btest/knownbug")
|
||||
assert_equal(" -0.", sprintf("%#10.0f", -0.5), "[ruby-dev:42552]")
|
||||
- assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
|
||||
- assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
|
||||
+ # out of spec
|
||||
+ #assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
|
||||
+ #assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
|
||||
end
|
||||
|
||||
def test_float_hex
|
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 25
|
||||
%global release 26
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
%global rubygems_version 2.2.2
|
||||
@ -109,6 +109,9 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# Test are broken due to SSLv3 disabled in Fedora.
|
||||
# https://bugs.ruby-lang.org/issues/10046
|
||||
Patch7: ruby-2.2.0-Don-t-use-obsolete-SSLv3-for-tests.patch
|
||||
# Disable sse2, already applied upstream
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1101811
|
||||
Patch8: ruby-nosse2.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||
@ -370,6 +373,7 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -870,6 +874,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Fri Dec 26 2014 Orion Poplwski <orion@cora.nwra.com> - 2.1.5-26
|
||||
- Disbable sse2 on i668 (bug #1101811)
|
||||
|
||||
* Thu Nov 20 2014 Vít Ondruch <vondruch@redhat.com> - 2.1.5-25
|
||||
- Update to Ruby 2.1.5.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user