Upgrade to Ruby 2.4.0 (r56948).
This commit is contained in:
parent
4fe83e0951
commit
cf0491b278
@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 0e371e2..d4f1dcb 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4526,6 +4526,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
@@ -4534,6 +4534,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
AC_SUBST(sitearchhdrdir)dnl
|
||||
AC_SUBST(vendorarchhdrdir)dnl
|
||||
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 37d9a62..553d4d0 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3778,6 +3778,11 @@ if test ${multiarch+set}; then
|
||||
@@ -3786,6 +3786,11 @@ if test ${multiarch+set}; then
|
||||
fi
|
||||
|
||||
archlibdir='${libdir}/${arch}'
|
||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
||||
index db37cd6..ce8d149 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4380,7 +4380,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
@@ -4388,7 +4388,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||
|
||||
if test -z "${ruby_version_dir_name}"; then
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 553d4d0..03a4152 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4444,6 +4444,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
@@ -4452,6 +4452,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||
|
||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 03a4152..0e371e2 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4416,6 +4416,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
@@ -4424,6 +4424,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4440,6 +4444,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4448,6 +4452,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
|
@ -20,7 +20,7 @@ diff --git a/configure.in b/configure.in
|
||||
index db37cd6..6e73fae 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4331,9 +4331,6 @@ AS_CASE(["$target_os"],
|
||||
@@ -4339,9 +4339,6 @@ AS_CASE(["$target_os"],
|
||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||
])
|
||||
|
||||
@ -30,7 +30,7 @@ index db37cd6..6e73fae 100644
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
@@ -4356,56 +4353,62 @@ AC_ARG_WITH(ridir,
|
||||
@@ -4364,56 +4361,62 @@ AC_ARG_WITH(ridir,
|
||||
AC_SUBST(ridir)
|
||||
AC_SUBST(RI_BASE_NAME)
|
||||
|
||||
@ -120,7 +120,7 @@ index db37cd6..6e73fae 100644
|
||||
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
@@ -4422,6 +4425,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
@@ -4430,6 +4433,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
AC_SUBST(arch)dnl
|
||||
AC_SUBST(sitearch)dnl
|
||||
AC_SUBST(ruby_version)dnl
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 43934fbbf16c7f19e07ae1de17fce6697fb137cc Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Tue, 8 Nov 2016 16:25:24 +0100
|
||||
Subject: [PATCH] Use primary group as well as supplementary groups.
|
||||
|
||||
I might happen in certain environments (systemd-nspawn) that process has
|
||||
no supplementary groups, but primary groups should be enough to pass most
|
||||
of the tests.
|
||||
---
|
||||
test/fileutils/test_fileutils.rb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/fileutils/test_fileutils.rb b/test/fileutils/test_fileutils.rb
|
||||
index 0ff0aad..fa5b24d 100644
|
||||
--- a/test/fileutils/test_fileutils.rb
|
||||
+++ b/test/fileutils/test_fileutils.rb
|
||||
@@ -142,7 +142,7 @@ def mymkdir(path)
|
||||
|
||||
def setup
|
||||
@prevdir = Dir.pwd
|
||||
- @groups = Process.groups if have_file_perm?
|
||||
+ @groups = [Process.gid, Process.groups].flatten if have_file_perm?
|
||||
tmproot = @tmproot = Dir.mktmpdir "fileutils"
|
||||
Dir.chdir tmproot
|
||||
my_rm_rf 'data'; mymkdir 'data'
|
||||
--
|
||||
2.10.1
|
||||
|
22
ruby.spec
22
ruby.spec
@ -10,7 +10,7 @@
|
||||
#%%global milestone preview2
|
||||
|
||||
# Keep the revision enabled for pre-releases from SVN.
|
||||
%global revision 56693
|
||||
%global revision 56948
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -42,9 +42,9 @@
|
||||
%global json_version 2.0.2
|
||||
%global minitest_version 5.9.1
|
||||
%global net_telnet_version 0.1.1
|
||||
%global openssl_version 2.0.0.beta.2
|
||||
%global power_assert_version 0.3.1
|
||||
%global psych_version 2.1.1
|
||||
%global openssl_version 2.0.0
|
||||
%global power_assert_version 0.4.1
|
||||
%global psych_version 2.2.1
|
||||
%global rake_version 11.3.0
|
||||
%global rdoc_version 5.0.0
|
||||
%global test_unit_version 3.2.1
|
||||
@ -128,10 +128,6 @@ Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# hardening features of glibc (rhbz#1361037).
|
||||
# https://bugs.ruby-lang.org/issues/12666
|
||||
Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
|
||||
# Make https://bugs.ruby-lang.org/issues/12910 pass in Mock with --new-chroot.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1393404
|
||||
# https://bugs.ruby-lang.org/issues/12910
|
||||
Patch10: ruby-2.4.0-Use-primary-group-as-well-as-supplementary-groups.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Suggests: rubypick
|
||||
@ -509,7 +505,6 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -536,6 +531,7 @@ autoconf
|
||||
--with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
|
||||
--with-rubygemsdir='%{rubygems_dir}' \
|
||||
--with-ruby-pc='%{name}.pc' \
|
||||
--with-compress-debug-sections=no \
|
||||
--disable-rpath \
|
||||
--enable-shared \
|
||||
--with-ruby-version='' \
|
||||
@ -728,9 +724,6 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{_mandir}/man1/erb*
|
||||
%{_mandir}/man1/ruby*
|
||||
|
||||
# http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries
|
||||
%exclude %{_libdir}/libruby-static.a
|
||||
|
||||
%files devel
|
||||
%doc BSDL
|
||||
%doc COPYING
|
||||
@ -768,6 +761,7 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/digest
|
||||
%{ruby_libdir}/drb
|
||||
%{ruby_libdir}/fiddle
|
||||
%{ruby_libdir}/forwardable
|
||||
%exclude %{ruby_libdir}/irb
|
||||
%{ruby_libdir}/matrix
|
||||
%{ruby_libdir}/net
|
||||
@ -1015,8 +1009,8 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||
|
||||
%changelog
|
||||
* Fri May 27 2016 Vít Ondruch <vondruch@redhat.com> - 2.4.0-0.1.r56693
|
||||
- Upgrade to Ruby 2.4.0 (r56693).
|
||||
* Fri May 27 2016 Vít Ondruch <vondruch@redhat.com> - 2.4.0-0.1.r56948
|
||||
- Upgrade to Ruby 2.4.0 (r56948).
|
||||
- Workaround "an invalid stdio handle" error on PPC (rhbz#1361037).
|
||||
- Add gemspec_add_dep and gemspec_remove_dep macros.
|
||||
- Move gemified xmlrpc into subpackage.
|
||||
|
Loading…
x
Reference in New Issue
Block a user