Fix ABRT hook autoloading.
This commit is contained in:
parent
bd75b0a7fe
commit
c0513dfb8c
28
ruby-2.2.3-Generate-preludes-using-miniruby.patch
Normal file
28
ruby-2.2.3-Generate-preludes-using-miniruby.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From 9fedac991e717f0103d092275ac301e58c5cf010 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Tue, 2 Dec 2014 10:56:58 +0100
|
||||
Subject: [PATCH] Generate preludes using miniruby.
|
||||
|
||||
---
|
||||
common.mk | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/common.mk b/common.mk
|
||||
index 76f1621..b0f6e28 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -782,9 +782,9 @@ $(PRELUDE_C): $(COMPILE_PRELUDE) \
|
||||
$(PRELUDE_C): $(COMPILE_PRELUDE) \
|
||||
{$(srcdir)}lib/rubygems/defaults.rb \
|
||||
{$(srcdir)}lib/rubygems/core_ext/kernel_gem.rb \
|
||||
- $(PRELUDE_SCRIPTS) $(LIB_SRCS)
|
||||
+ $(PRELUDE_SCRIPTS) $(PREP) $(LIB_SRCS)
|
||||
$(ECHO) generating $@
|
||||
- $(Q) $(BASERUBY) $(srcdir)/tool/generic_erb.rb -I$(srcdir) -c -o $@ \
|
||||
+ $(Q) $(MINIRUBY) $(srcdir)/tool/generic_erb.rb -I$(srcdir) -c -o $@ \
|
||||
$(srcdir)/template/prelude.c.tmpl $(PRELUDE_SCRIPTS)
|
||||
|
||||
{$(VPATH)}golf_prelude.c: $(COMPILE_PRELUDE) {$(srcdir)}golf_prelude.rb
|
||||
--
|
||||
2.1.0
|
||||
|
13
ruby.spec
13
ruby.spec
@ -21,7 +21,7 @@
|
||||
%endif
|
||||
|
||||
|
||||
%global release 45
|
||||
%global release 46
|
||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
||||
|
||||
%global rubygems_version 2.4.5.1
|
||||
@ -110,6 +110,9 @@ Patch5: ruby-1.9.3-mkmf-verbose.patch
|
||||
# in support for ABRT.
|
||||
# http://bugs.ruby-lang.org/issues/8566
|
||||
Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
|
||||
# Use miniruby to regenerate prelude.c.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
|
||||
# Don't use SSLv3 for tests.
|
||||
# https://bugs.ruby-lang.org/issues/10046
|
||||
Patch9: ruby-2.3.0-fix-test-ctx-client-session-cb.patch
|
||||
@ -415,6 +418,7 @@ rm -rf ext/fiddle/libffi*
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch9
|
||||
%patch10
|
||||
%patch11
|
||||
@ -450,10 +454,6 @@ autoconf
|
||||
--enable-multiarch \
|
||||
--with-prelude=./abrt_prelude.rb \
|
||||
|
||||
# Avoid regeneration of prelude.c due to patch6 applied to common.mk.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
touch prelude.c
|
||||
|
||||
# Q= makes the build output more verbose and allows to check Fedora
|
||||
# compiler options.
|
||||
make %{?_smp_mflags} COPY="cp -p" Q=
|
||||
@ -893,6 +893,9 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Thu Dec 10 2015 Vít Ondruch <vondruch@redhat.com> - 2.2.3-46
|
||||
- Fix ABRT hook autoloading.
|
||||
|
||||
* Fri Sep 04 2015 Michal Toman <mtoman@fedoraproject.org> - 2.2.3-45
|
||||
- Add support for MIPS architecture to config.h
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user