Upgrade to Ruby 2.2.0-preview2.
This commit is contained in:
parent
2cd1c80dbf
commit
b651e4837e
@ -13,7 +13,7 @@ diff --git a/Makefile.in b/Makefile.in
|
||||
index 7e8ed82..7916993 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -113,6 +113,8 @@ XRUBY_LIBDIR = @XRUBY_LIBDIR@
|
||||
@@ -114,6 +114,8 @@ XRUBY_LIBDIR = @XRUBY_LIBDIR@
|
||||
XRUBY_RUBYLIBDIR = @XRUBY_RUBYLIBDIR@
|
||||
XRUBY_RUBYHDRDIR = @XRUBY_RUBYHDRDIR@
|
||||
|
||||
@ -26,7 +26,7 @@ diff --git a/common.mk b/common.mk
|
||||
index 5cfbc3d..3f0a82e 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -115,7 +115,7 @@
|
||||
@@ -115,7 +115,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(INITOBJS)
|
||||
GOLFOBJS = goruby.$(OBJEXT) golf_prelude.$(OBJEXT)
|
||||
|
||||
DEFAULT_PRELUDES = $(GEM_PRELUDE)
|
||||
@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 0e371e2..d4f1dcb 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4103,6 +4103,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
@@ -4145,6 +4145,13 @@ AC_SUBST(rubyarchhdrdir)dnl
|
||||
AC_SUBST(sitearchhdrdir)dnl
|
||||
AC_SUBST(vendorarchhdrdir)dnl
|
||||
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 37d9a62..553d4d0 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3325,6 +3325,11 @@ if test ${multiarch+set}; then
|
||||
@@ -3367,6 +3367,11 @@ if test ${multiarch+set}; then
|
||||
fi
|
||||
|
||||
archlibdir='${libdir}/${arch}'
|
||||
|
@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 17ed3ed..5843651 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3909,8 +3909,6 @@ AS_CASE(["$target_os"],
|
||||
@@ -3951,8 +3951,6 @@ AS_CASE(["$target_os"],
|
||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||
])
|
||||
|
||||
@ -23,7 +23,7 @@ index 17ed3ed..5843651 100644
|
||||
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
@@ -3940,6 +3938,7 @@ AC_ARG_WITH(ruby-version,
|
||||
@@ -3982,6 +3980,7 @@ AC_ARG_WITH(ruby-version,
|
||||
[ruby_version=full])
|
||||
unset RUBY_LIB_VERSION
|
||||
unset RUBY_LIB_VERSION_STYLE
|
||||
@ -31,7 +31,7 @@ index 17ed3ed..5843651 100644
|
||||
AS_CASE(["$ruby_version"],
|
||||
[full], [RUBY_LIB_VERSION_STYLE='3 /* full */'],
|
||||
[minor], [RUBY_LIB_VERSION_STYLE='2 /* minor */'])
|
||||
@@ -3956,30 +3955,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
||||
@@ -3998,30 +3997,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
||||
ruby_version="`$CPP -I. -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
|
||||
eval $ruby_version
|
||||
elif test -z "${ruby_version}"; then
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 553d4d0..03a4152 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4021,6 +4021,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
@@ -4063,6 +4063,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
|
||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||
|
||||
|
@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
|
||||
index 03a4152..0e371e2 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3995,6 +3995,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
@@ -4037,6 +4037,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4018,6 +4022,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4060,6 +4064,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
|
26
ruby.spec
26
ruby.spec
@ -7,10 +7,10 @@
|
||||
%global ruby_release %{ruby_version}
|
||||
|
||||
# Specify the named version. It has precedense to revision.
|
||||
#%%global milestone preview2
|
||||
%global milestone preview2
|
||||
|
||||
# Keep the revision enabled for pre-releases from SVN.
|
||||
%global revision 48476
|
||||
#%%global revision 48629
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -38,11 +38,11 @@
|
||||
%global io_console_version 0.4.2
|
||||
%global json_version 1.8.1
|
||||
%global minitest_version 5.4.3
|
||||
%global power_assert_version 0.2.0
|
||||
%global power_assert_version 0.2.2
|
||||
%global psych_version 2.0.6
|
||||
%global rake_version 10.3.2
|
||||
%global rake_version 10.4.0
|
||||
%global rdoc_version 4.2.0.alpha
|
||||
%global test_unit_version 3.0.6
|
||||
%global test_unit_version 3.0.7
|
||||
|
||||
# Might not be needed in the future, if we are lucky enough.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=888262
|
||||
@ -430,6 +430,13 @@ autoconf
|
||||
--enable-multiarch \
|
||||
--with-prelude=./abrt_prelude.rb \
|
||||
|
||||
# Avoid regeneration of prelude.c due to patch6 applied to common.mk.
|
||||
# https://bugs.ruby-lang.org/issues/10554
|
||||
# TODO: Alternative solution might be to remove the path6 entirely and go
|
||||
# ahead with the following proposal:
|
||||
# https://bugs.ruby-lang.org/issues/8566#note-3
|
||||
touch prelude.c
|
||||
|
||||
# Q= makes the build output more verbose and allows to check Fedora
|
||||
# compiler options.
|
||||
make %{?_smp_mflags} COPY="cp -p" Q=
|
||||
@ -582,6 +589,11 @@ touch abrt.rb
|
||||
sed -i '/assert(OpenSSL::Cipher::Cipher.new(name).is_a?(OpenSSL::Cipher::Cipher))/i \
|
||||
next if /wrap/ =~ name' test/openssl/test_cipher.rb
|
||||
|
||||
# Test is broken due to SSLv3 disabled in Fedora.
|
||||
# https://bugs.ruby-lang.org/issues/10046
|
||||
sed -i '/def test_ctx_client_session_cb$/,/^ end$/ s/^/#/' test/openssl/test_ssl_session.rb
|
||||
sed -i '/def test_ctx_server_session_cb$/,/^ end$/ s/^/#/' test/openssl/test_ssl_session.rb
|
||||
|
||||
make check TESTS="-v $DISABLE_TESTS"
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
@ -872,8 +884,8 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{ruby_libdir}/tkextlib
|
||||
|
||||
%changelog
|
||||
* Mon Nov 10 2014 Vít Ondruch <vondruch@redhat.com> - 2.2.0-0.24.r48476
|
||||
- Upgrade to Ruby 2.2.0 (r48476).
|
||||
* Mon Nov 10 2014 Vít Ondruch <vondruch@redhat.com> - 2.2.0-0.24.preview2
|
||||
- Upgrade to Ruby 2.2.0-preview2.
|
||||
- Explicitly list RubyGems directories to avoid accidentaly packaged content.
|
||||
- Split test-unit and power_assert gems into separate sub-packages.
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user