Convert to git formated patch.
This commit is contained in:
parent
6193662f24
commit
b3f2794361
@ -1,6 +1,17 @@
|
||||
--- a/configure.in.orig 2011-10-18 08:56:21.587594685 +0200
|
||||
+++ b/configure.in 2011-10-18 08:56:59.751593321 +0200
|
||||
@@ -3153,6 +3153,8 @@
|
||||
From 1f061d350d01fc55272872d6f7932986dba4011d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 14:37:28 +0100
|
||||
Subject: [PATCH] Always use i386.
|
||||
|
||||
---
|
||||
configure.in | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index c65e0c7..748edc9 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3293,6 +3293,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
configure_args=$ac_configure_args
|
||||
AC_SUBST(configure_args)dnl
|
||||
|
||||
@ -9,3 +20,6 @@
|
||||
if test "${universal_binary-no}" = yes ; then
|
||||
arch="universal-${target_os}"
|
||||
AC_CACHE_CHECK(whether __ARCHITECTURE__ is available, rb_cv_architecture_available,
|
||||
--
|
||||
1.8.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 279a693ce4ef3a887ce8d4fa59e0f2616a14d91a Mon Sep 17 00:00:00 2001
|
||||
From 643a3d3af2a3847e730c79515bc586768053119a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 11 Nov 2011 13:14:45 +0100
|
||||
Subject: [PATCH] Allow to install RubyGems into custom location, outside of
|
||||
@ -9,13 +9,13 @@ Subject: [PATCH] Allow to install RubyGems into custom location, outside of
|
||||
tool/mkconfig.rb | 1 +
|
||||
tool/rbinstall.rb | 9 +++++++++
|
||||
version.c | 4 ++++
|
||||
4 files changed, 22 insertions(+), 0 deletions(-)
|
||||
4 files changed, 22 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index b1bc951..91c5d0d 100644
|
||||
index 748edc9..6a16745 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3056,6 +3056,13 @@ until VENDOR_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDOR_DIR}"; do
|
||||
@@ -3196,6 +3196,13 @@ until VENDORARCH_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDORARCH_D
|
||||
dir="${VENDORARCH_DIR}"
|
||||
done
|
||||
|
||||
@ -29,7 +29,7 @@ index b1bc951..91c5d0d 100644
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=""
|
||||
@@ -3149,6 +3156,7 @@ AC_SUBST(sitearch)dnl
|
||||
@@ -3289,6 +3296,7 @@ AC_SUBST(sitedir)dnl
|
||||
AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
@ -38,7 +38,7 @@ index b1bc951..91c5d0d 100644
|
||||
configure_args=$ac_configure_args
|
||||
AC_SUBST(configure_args)dnl
|
||||
diff --git a/tool/mkconfig.rb b/tool/mkconfig.rb
|
||||
index b707c4b..9fecbfb 100755
|
||||
index 79b8e44..9cef0c6 100755
|
||||
--- a/tool/mkconfig.rb
|
||||
+++ b/tool/mkconfig.rb
|
||||
@@ -84,6 +84,7 @@ File.foreach "config.status" do |line|
|
||||
@ -50,7 +50,7 @@ index b707c4b..9fecbfb 100755
|
||||
case val
|
||||
when /^\$\(ac_\w+\)$/; next
|
||||
diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
|
||||
index 6bfc73e..31dc446 100755
|
||||
index 17294a2..2757a73 100755
|
||||
--- a/tool/rbinstall.rb
|
||||
+++ b/tool/rbinstall.rb
|
||||
@@ -313,6 +313,7 @@ sitelibdir = CONFIG["sitelibdir"]
|
||||
@ -64,7 +64,7 @@ index 6bfc73e..31dc446 100755
|
||||
@@ -500,7 +501,15 @@ end
|
||||
install?(:local, :comm, :lib) do
|
||||
prepare "library scripts", rubylibdir
|
||||
noinst = %w[README* *.txt *.rdoc]
|
||||
noinst = %w[README* *.txt *.rdoc *.gemspec]
|
||||
+ noinst += %w[*ubygems.rb rubygems/ datadir.rb] if rubygemsdir
|
||||
install_recursive(File.join(srcdir, "lib"), rubylibdir, :no_install => noinst, :mode => $data_mode)
|
||||
+ if rubygemsdir
|
||||
@ -78,7 +78,7 @@ index 6bfc73e..31dc446 100755
|
||||
|
||||
install?(:local, :arch, :lib) do
|
||||
diff --git a/version.c b/version.c
|
||||
index 59d4e5e..12ba7e9 100644
|
||||
index 962f39f..979701d 100644
|
||||
--- a/version.c
|
||||
+++ b/version.c
|
||||
@@ -104,6 +104,10 @@ const char ruby_initial_load_paths[] =
|
||||
@ -93,5 +93,5 @@ index 59d4e5e..12ba7e9 100644
|
||||
#ifdef RUBY_THIN_ARCHLIB
|
||||
RUBY_THIN_ARCHLIB "\0"
|
||||
--
|
||||
1.7.7
|
||||
1.8.0
|
||||
|
||||
|
@ -1,6 +1,16 @@
|
||||
diff -up ruby-1.9.3-p0/ext/tk/extconf.rb.orig ruby-1.9.3-p0/ext/tk/extconf.rb
|
||||
--- ruby-1.9.3-p0/ext/tk/extconf.rb.orig 2011-06-29 16:11:19.000000000 +0200
|
||||
+++ ruby-1.9.3-p0/ext/tk/extconf.rb 2011-10-18 16:15:59.406299659 +0200
|
||||
From d710179fcc088a201339a28fa6a5779da8e6ab62 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 14:39:19 +0100
|
||||
Subject: [PATCH] Fix s390x build.
|
||||
|
||||
---
|
||||
ext/tk/extconf.rb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/tk/extconf.rb b/ext/tk/extconf.rb
|
||||
index 72dd6cf..5c6081e 100644
|
||||
--- a/ext/tk/extconf.rb
|
||||
+++ b/ext/tk/extconf.rb
|
||||
@@ -114,7 +114,7 @@ def is_macosx?
|
||||
end
|
||||
|
||||
@ -10,3 +20,6 @@ diff -up ruby-1.9.3-p0/ext/tk/extconf.rb.orig ruby-1.9.3-p0/ext/tk/extconf.rb
|
||||
end
|
||||
|
||||
def check_tcltk_version(version)
|
||||
--
|
||||
1.8.0
|
||||
|
||||
|
@ -1,6 +1,17 @@
|
||||
--- ruby-1.9.3-p0/lib/mkmf.rb.debug 2011-08-11 15:07:37.000000000 +0900
|
||||
+++ ruby-1.9.3-p0/lib/mkmf.rb 2012-01-29 21:34:17.000000000 +0900
|
||||
@@ -1746,7 +1746,7 @@
|
||||
From b6f6f0b8cd750e97c15f1b739b1c95d6c1989294 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 15:14:51 +0100
|
||||
Subject: [PATCH] Verbose mkmf.
|
||||
|
||||
---
|
||||
lib/mkmf.rb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/mkmf.rb b/lib/mkmf.rb
|
||||
index ded4e89..0870f22 100644
|
||||
--- a/lib/mkmf.rb
|
||||
+++ b/lib/mkmf.rb
|
||||
@@ -1746,7 +1746,7 @@ SRC
|
||||
SHELL = /bin/sh
|
||||
|
||||
# V=0 quiet, V=1 verbose. other values don't work.
|
||||
@ -9,3 +20,6 @@
|
||||
Q1 = $(V:1=)
|
||||
Q = $(Q1:0=@)
|
||||
ECHO1 = $(V:1=@#{CONFIG['NULLCMD']})
|
||||
--
|
||||
1.8.0
|
||||
|
||||
|
@ -1,6 +1,18 @@
|
||||
--- ruby-1.9.3-p0/lib/rubygems/uninstaller.rb.orig 2011-10-31 10:22:36.321579483 +0100
|
||||
+++ ruby-1.9.3-p0/lib/rubygems/uninstaller.rb 2011-10-31 10:34:25.563626119 +0100
|
||||
@@ -51,15 +51,14 @@
|
||||
From 6a07398a3aac0793d1a62f6f4778d90baf86ab7e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 14:41:06 +0100
|
||||
Subject: [PATCH] RubyGems uninstaller upstream fixes.
|
||||
|
||||
---
|
||||
lib/rubygems/uninstaller.rb | 35 +++++++++++++++++++++++------------
|
||||
test/rubygems/test_gem_uninstaller.rb | 2 +-
|
||||
2 files changed, 24 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/lib/rubygems/uninstaller.rb b/lib/rubygems/uninstaller.rb
|
||||
index cc32ea4..c0e8b4b 100644
|
||||
--- a/lib/rubygems/uninstaller.rb
|
||||
+++ b/lib/rubygems/uninstaller.rb
|
||||
@@ -51,15 +51,14 @@ class Gem::Uninstaller
|
||||
@bin_dir = options[:bin_dir]
|
||||
@format_executable = options[:format_executable]
|
||||
|
||||
@ -21,7 +33,7 @@
|
||||
end
|
||||
|
||||
##
|
||||
@@ -69,10 +68,24 @@
|
||||
@@ -69,10 +68,24 @@ class Gem::Uninstaller
|
||||
def uninstall
|
||||
list = Gem::Specification.find_all_by_name(@gem, @version)
|
||||
|
||||
@ -48,7 +60,7 @@
|
||||
remove_all list
|
||||
|
||||
elsif list.size > 1 then
|
||||
@@ -250,12 +263,10 @@
|
||||
@@ -250,12 +263,10 @@ class Gem::Uninstaller
|
||||
msg << "\t#{spec.full_name}"
|
||||
|
||||
spec.dependent_gems.each do |dep_spec, dep, satlist|
|
||||
@ -63,10 +75,11 @@
|
||||
msg << 'Continue with Uninstall?'
|
||||
return ask_yes_no(msg.join("\n"), true)
|
||||
end
|
||||
|
||||
--- ruby-1.9.3-p0/test/rubygems/test_gem_uninstaller.rb.orig 2011-11-03 08:58:31.411272176 +0100
|
||||
+++ ruby-1.9.3-p0/test/rubygems/test_gem_uninstaller.rb 2011-11-03 08:58:43.010272351 +0100
|
||||
@@ -225,7 +225,7 @@
|
||||
diff --git a/test/rubygems/test_gem_uninstaller.rb b/test/rubygems/test_gem_uninstaller.rb
|
||||
index a65b992..1cd186f 100644
|
||||
--- a/test/rubygems/test_gem_uninstaller.rb
|
||||
+++ b/test/rubygems/test_gem_uninstaller.rb
|
||||
@@ -225,7 +225,7 @@ class TestGemUninstaller < Gem::InstallerTestCase
|
||||
|
||||
uninstaller = Gem::Uninstaller.new('a')
|
||||
|
||||
@ -74,3 +87,7 @@
|
||||
+ use_ui Gem::MockGemUi.new("2\ny\n") do
|
||||
uninstaller.uninstall
|
||||
end
|
||||
|
||||
--
|
||||
1.8.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user