Upgrade to Ruby 2.0.0 (r39237).
This commit is contained in:
parent
f731780a81
commit
9c188645b4
@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
|
||||
index d6af000..1c094a3 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3221,6 +3221,10 @@ AC_SUBST(rubylibprefix)
|
||||
@@ -3188,6 +3188,10 @@ AC_SUBST(rubylibprefix)
|
||||
rubylibdir='${rubylibprefix}/${ruby_version}'
|
||||
rubyarchdir=${multiarch+'${rubyarchprefix}/${ruby_version}'}${multiarch-'${rubylibdir}/${arch}'}
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 643a3d3af2a3847e730c79515bc586768053119a Mon Sep 17 00:00:00 2001
|
||||
From b5e9dc3683cb085aa57e7b12c35a4f21b2cc1482 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 11 Nov 2011 13:14:45 +0100
|
||||
Subject: [PATCH] Allow to install RubyGems into custom location, outside of
|
||||
@ -6,16 +6,15 @@ Subject: [PATCH] Allow to install RubyGems into custom location, outside of
|
||||
|
||||
---
|
||||
configure.in | 8 ++++++++
|
||||
tool/mkconfig.rb | 1 +
|
||||
tool/rbinstall.rb | 9 +++++++++
|
||||
version.c | 4 ++++
|
||||
4 files changed, 22 insertions(+)
|
||||
3 files changed, 21 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 748edc9..6a16745 100644
|
||||
index 1627d12..e064b2b 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3256,6 +3256,13 @@ until VENDORARCH_DIR=`eval echo \\"${dir}\\"`; test "x${dir}" = "x${VENDORARCH_D
|
||||
@@ -3256,6 +3256,13 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubyarchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -29,7 +28,7 @@ index 748edc9..6a16745 100644
|
||||
if test "${LOAD_RELATIVE+set}"; then
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX='""'
|
||||
@@ -3316,6 +3323,7 @@ @@ AC_SUBST(sitedir)dnl
|
||||
@@ -3316,6 +3323,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
@ -38,7 +37,7 @@ index 748edc9..6a16745 100644
|
||||
configure_args=$ac_configure_args
|
||||
AC_SUBST(configure_args)dnl
|
||||
diff --git a/tool/rbinstall.rb b/tool/rbinstall.rb
|
||||
index 17294a2..2757a73 100755
|
||||
index 92e54c6..c72dfb6 100755
|
||||
--- a/tool/rbinstall.rb
|
||||
+++ b/tool/rbinstall.rb
|
||||
@@ -313,6 +313,7 @@ sitelibdir = CONFIG["sitelibdir"]
|
||||
@ -66,7 +65,7 @@ index 17294a2..2757a73 100755
|
||||
|
||||
install?(:local, :arch, :lib) do
|
||||
diff --git a/version.c b/version.c
|
||||
index 962f39f..979701d 100644
|
||||
index 54c4513..d76100b 100644
|
||||
--- a/version.c
|
||||
+++ b/version.c
|
||||
@@ -99,6 +99,10 @@ const char ruby_initial_load_paths[] =
|
||||
@ -80,6 +79,6 @@ index 962f39f..979701d 100644
|
||||
RUBY_LIB "\0"
|
||||
#ifdef RUBY_THINARCH
|
||||
RUBY_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
||||
---
|
||||
1.8.0
|
||||
--
|
||||
1.8.1.2
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From b6f6f0b8cd750e97c15f1b739b1c95d6c1989294 Mon Sep 17 00:00:00 2001
|
||||
From ec16398159a161fc77436b4855d489f193b2515b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Mon, 19 Nov 2012 15:14:51 +0100
|
||||
Subject: [PATCH] Verbose mkmf.
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH] Verbose mkmf.
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/mkmf.rb b/lib/mkmf.rb
|
||||
index ded4e89..0870f22 100644
|
||||
index 4b6c52e..67a15ee 100644
|
||||
--- a/lib/mkmf.rb
|
||||
+++ b/lib/mkmf.rb
|
||||
@@ -1752,7 +1752,7 @@ SRC
|
||||
@@ -1777,7 +1777,7 @@ SRC
|
||||
SHELL = /bin/sh
|
||||
|
||||
# V=0 quiet, V=1 verbose. other values don't work.
|
||||
@ -21,5 +21,5 @@ index ded4e89..0870f22 100644
|
||||
Q = $(Q1:0=@)
|
||||
ECHO1 = $(V:1=@#{CONFIG['NULLCMD']})
|
||||
--
|
||||
1.8.0
|
||||
1.8.1.2
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 1e109d1a0265dfdde2324a6a97e4225eb4343efc Mon Sep 17 00:00:00 2001
|
||||
From e943a89efd63dcfb80a0ab8d9a4db37f523f508e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
|
||||
Date: Fri, 8 Feb 2013 22:48:41 +0100
|
||||
Subject: [PATCH] Prevent duplicated paths when empty version string is
|
||||
@ -10,10 +10,10 @@ Subject: [PATCH] Prevent duplicated paths when empty version string is
|
||||
2 files changed, 13 insertions(+)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index e83cfb4..d6af000 100644
|
||||
index 5850bbf..7604bb8 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3308,6 +3308,9 @@ shvar_to_cpp RIDIR "${ridir}"
|
||||
@@ -3265,6 +3265,9 @@ shvar_to_cpp RIDIR "${ridir}"
|
||||
if test ${RUBY_LIB_VERSION_STYLE+set}; then
|
||||
AC_DEFINE_UNQUOTED(RUBY_LIB_VERSION_STYLE, $RUBY_LIB_VERSION_STYLE !<verconf>!)
|
||||
else
|
||||
@ -24,7 +24,7 @@ index e83cfb4..d6af000 100644
|
||||
fi
|
||||
AC_DEFINE_UNQUOTED(RUBY_EXEC_PREFIX, ${RUBY_EXEC_PREFIX})
|
||||
diff --git a/version.c b/version.c
|
||||
index 6ba6453..c78f609 100644
|
||||
index 282960d..54c4513 100644
|
||||
--- a/version.c
|
||||
+++ b/version.c
|
||||
@@ -39,9 +39,15 @@
|
||||
@ -43,7 +43,7 @@ index 6ba6453..c78f609 100644
|
||||
#ifndef RUBY_ARCH_LIB_FOR
|
||||
#define RUBY_ARCH_LIB_FOR(arch) RUBY_LIB "/"arch
|
||||
#endif
|
||||
@@ -79,8 +85,10 @@ const char ruby_initial_load_paths[] =
|
||||
@@ -77,8 +83,10 @@ const char ruby_initial_load_paths[] =
|
||||
RUBY_SITE_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
||||
#endif
|
||||
RUBY_SITE_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
||||
@ -54,7 +54,7 @@ index 6ba6453..c78f609 100644
|
||||
|
||||
#ifndef NO_RUBY_VENDOR_LIB
|
||||
RUBY_VENDOR_LIB2 "\0"
|
||||
@@ -88,8 +96,10 @@ const char ruby_initial_load_paths[] =
|
||||
@@ -86,8 +94,10 @@ const char ruby_initial_load_paths[] =
|
||||
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_THINARCH) "\0"
|
||||
#endif
|
||||
RUBY_VENDOR_ARCH_LIB_FOR(RUBY_SITEARCH) "\0"
|
||||
|
Loading…
Reference in New Issue
Block a user