Upgrade to Ruby 3.3.2.
Resolves: rhbz#2284020
This commit is contained in:
parent
677893973e
commit
93638d9e58
@ -11,7 +11,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index d261ea57b5..3c13076b82 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3473,6 +3473,11 @@ AS_IF([test ${multiarch+set}], [
|
||||
@@ -3478,6 +3478,11 @@ AS_IF([test ${multiarch+set}], [
|
||||
])
|
||||
|
||||
archlibdir='${libdir}/${arch}'
|
||||
|
@ -14,7 +14,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index c42436c23d..d261ea57b5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4312,7 +4312,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
@@ -4317,7 +4317,8 @@ AS_CASE(["$ruby_version_dir_name"],
|
||||
ruby_version_dir=/'${ruby_version_dir_name}'
|
||||
|
||||
if test -z "${ruby_version_dir_name}"; then
|
||||
|
@ -11,7 +11,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 3c13076b82..93af30321d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4376,6 +4376,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
@@ -4381,6 +4381,8 @@ AC_SUBST(vendorarchdir)dnl
|
||||
AC_SUBST(CONFIGURE, "`echo $0 | sed 's|.*/||'`")dnl
|
||||
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl
|
||||
|
||||
|
@ -15,7 +15,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 93af30321d..bc13397e0e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4348,6 +4348,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
@@ -4353,6 +4353,10 @@ AC_ARG_WITH(vendorarchdir,
|
||||
[vendorarchdir=$withval],
|
||||
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby'${ruby_version_dir}}${multiarch-'${vendorlibdir}/${sitearch}'}])
|
||||
|
||||
@ -26,7 +26,7 @@ index 93af30321d..bc13397e0e 100644
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4372,6 +4376,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4377,6 +4381,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
|
@ -20,7 +20,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 80b137e380..63cd3b4f8b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4262,9 +4262,6 @@ AS_CASE(["$target_os"],
|
||||
@@ -4267,9 +4267,6 @@ AS_CASE(["$target_os"],
|
||||
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
|
||||
])
|
||||
|
||||
@ -30,7 +30,7 @@ index 80b137e380..63cd3b4f8b 100644
|
||||
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
|
||||
AC_ARG_WITH(rubyarchprefix,
|
||||
AS_HELP_STRING([--with-rubyarchprefix=DIR],
|
||||
@@ -4287,57 +4284,63 @@ AC_ARG_WITH(ridir,
|
||||
@@ -4292,57 +4289,63 @@ AC_ARG_WITH(ridir,
|
||||
AC_SUBST(ridir)
|
||||
AC_SUBST(RI_BASE_NAME)
|
||||
|
||||
@ -122,7 +122,7 @@ index 80b137e380..63cd3b4f8b 100644
|
||||
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
@@ -4354,6 +4357,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
@@ -4359,6 +4362,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
AC_SUBST(arch)dnl
|
||||
AC_SUBST(sitearch)dnl
|
||||
AC_SUBST(ruby_version)dnl
|
||||
@ -262,7 +262,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index a00f2b6776..999e2d6d5d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -135,7 +135,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
@@ -136,7 +136,7 @@ RUBY_BASE_NAME=`echo ruby | sed "$program_transform_name"`
|
||||
RUBYW_BASE_NAME=`echo rubyw | sed "$program_transform_name"`
|
||||
AC_SUBST(RUBY_BASE_NAME)
|
||||
AC_SUBST(RUBYW_BASE_NAME)
|
||||
|
@ -13,7 +13,7 @@ diff --git a/hash.c b/hash.c
|
||||
index 78e9d9a2d6..f6525ba4a5 100644
|
||||
--- a/hash.c
|
||||
+++ b/hash.c
|
||||
@@ -4385,16 +4385,13 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
@@ -4382,16 +4382,13 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
if (hash_iterating_p(hash)) {
|
||||
rb_raise(rb_eRuntimeError, "compare_by_identity during iteration");
|
||||
}
|
||||
@ -33,7 +33,7 @@ index 78e9d9a2d6..f6525ba4a5 100644
|
||||
// Slow path: Need to rehash the members of `self` into a new
|
||||
// `tmp` table using the new `identhash` compare/hash functions.
|
||||
tmp = hash_alloc(0);
|
||||
@@ -4402,10 +4399,8 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
@@ -4399,10 +4396,8 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
identtable = RHASH_ST_TABLE(tmp);
|
||||
|
||||
rb_hash_foreach(hash, rb_hash_rehash_i, (VALUE)tmp);
|
||||
@ -60,7 +60,7 @@ diff --git a/hash.c b/hash.c
|
||||
index f6525ba4a5..cf83675c70 100644
|
||||
--- a/hash.c
|
||||
+++ b/hash.c
|
||||
@@ -4388,22 +4388,15 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
@@ -4385,22 +4385,15 @@ rb_hash_compare_by_id(VALUE hash)
|
||||
ar_force_convert_table(hash, __FILE__, __LINE__);
|
||||
HASH_ASSERT(RHASH_ST_TABLE_P(hash));
|
||||
|
||||
|
@ -0,0 +1,27 @@
|
||||
From d6d22e457475e3d2f8e4878bb97e2780ca2f83d6 Mon Sep 17 00:00:00 2001
|
||||
From: Sorah Fukumori <sorah@cookpad.com>
|
||||
Date: Fri, 31 May 2024 02:16:10 +0900
|
||||
Subject: [PATCH] RUBY_CHECK_HEADER didn't define HAVE_{header-file}
|
||||
|
||||
--with-gmp is not working at all because HAVE_GMP_H
|
||||
was missing since 18eaf0be90. [Bug #20515]
|
||||
|
||||
bug: https://bugs.ruby-lang.org/issues/20515
|
||||
follow-up: https://bugs.ruby-lang.org/issues/20494
|
||||
follow-up: 18eaf0be905e3e251423b42d6f4e56b7cae1bc3b
|
||||
---
|
||||
tool/m4/ruby_check_header.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tool/m4/ruby_check_header.m4 b/tool/m4/ruby_check_header.m4
|
||||
index 171455549e3362..6fec9d16c5bcf1 100644
|
||||
--- a/tool/m4/ruby_check_header.m4
|
||||
+++ b/tool/m4/ruby_check_header.m4
|
||||
@@ -3,6 +3,6 @@ AC_DEFUN([RUBY_CHECK_HEADER],
|
||||
[# RUBY_CHECK_HEADER($@)
|
||||
save_CPPFLAGS="$CPPFLAGS"
|
||||
CPPFLAGS="$CPPFLAGS m4_if([$5], [], [$INCFLAGS], [$5])"
|
||||
- AC_CHECK_HEADER([$1], [$2], [$3], [$4])
|
||||
+ AC_CHECK_HEADERS([$1], [$2], [$3], [$4])
|
||||
CPPFLAGS="$save_CPPFLAGS"
|
||||
unset save_CPPFLAGS])
|
@ -13,7 +13,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 18b4247991..5ea8ada8f7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -827,7 +827,7 @@ AS_IF([test "$GCC" = yes], [
|
||||
@@ -828,7 +828,7 @@ AS_IF([test "$GCC" = yes], [
|
||||
|
||||
# aarch64 branch protection
|
||||
AS_CASE(["$target_cpu"], [aarch64], [
|
||||
|
20
ruby.spec
20
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 3
|
||||
%global minor_version 3
|
||||
%global teeny_version 1
|
||||
%global teeny_version 2
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -10,7 +10,7 @@
|
||||
#%%global milestone rc1
|
||||
|
||||
# Keep the revision enabled for pre-releases from GIT.
|
||||
#%%global revision 5124f9ac75
|
||||
#%%global revision e5a195edf6
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -86,7 +86,7 @@
|
||||
%global prettyprint_version 0.2.0
|
||||
%global pstore_version 0.1.3
|
||||
%global readline_version 0.0.4
|
||||
%global reline_version 0.4.1
|
||||
%global reline_version 0.5.7
|
||||
%global resolv_version 0.3.0
|
||||
%global resolv_replace_version 0.1.1
|
||||
%global rinda_version 0.2.0
|
||||
@ -110,12 +110,12 @@
|
||||
%global win32ole_version 1.8.10
|
||||
%global yaml_version 0.3.0
|
||||
%global prism_version 0.19.0
|
||||
%global zlib_version 3.1.0
|
||||
%global zlib_version 3.1.1
|
||||
|
||||
# Gemified default gems.
|
||||
%global bigdecimal_version 3.1.5
|
||||
%global io_console_version 0.7.1
|
||||
%global irb_version 1.11.0
|
||||
%global irb_version 1.13.1
|
||||
%global json_version 2.7.1
|
||||
%global psych_version 5.1.2
|
||||
%global rdoc_version 6.6.3.1
|
||||
@ -171,7 +171,7 @@
|
||||
Summary: An interpreter of object-oriented scripting language
|
||||
Name: ruby
|
||||
Version: %{ruby_version}%{?development_release}
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
# Licenses, which are likely not included in binary RPMs:
|
||||
# Apache-2.0:
|
||||
# benchmark/gc/redblack.rb
|
||||
@ -281,6 +281,9 @@ Patch12: ruby-3.4.0-fix-branch-protection-compilation-for-arm.patch
|
||||
# Fix build issue on i686 due to "incompatible pointer type" error.
|
||||
# https://bugs.ruby-lang.org/issues/20447
|
||||
Patch13: ruby-3.4.0-Fix-pointer-incompatiblity.patch
|
||||
# Fix GMP support
|
||||
# https://bugs.ruby-lang.org/issues/20515
|
||||
Patch14: ruby-3.3.3-RUBY-CHECK-HEADER-didn-t-define-HAVE-header-file-.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%{?with_rubypick:Suggests: rubypick}
|
||||
@ -760,6 +763,7 @@ analysis result in RBS format, a standard type description format for Ruby
|
||||
%patch 10 -p1
|
||||
%patch 12 -p1
|
||||
%patch 13 -p1
|
||||
%patch 14 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -1722,6 +1726,10 @@ make -C %{_vpath_builddir} runruby TESTRUN_SCRIPT=" \
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jun 06 2024 Vít Ondruch <vondruch@redhat.com> - 3.3.2-9
|
||||
- Upgrade to Ruby 3.3.2.
|
||||
Resolves: rhbz#2284020
|
||||
|
||||
* Tue May 28 2024 Vít Ondruch <vondruch@redhat.com> - 3.3.1-8
|
||||
- Adjust the test to updated `checksec` output.
|
||||
Resolves: rhbz#2282953
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ruby-3.3.1.tar.xz) = c58e9be9b5ab48191fbf7d67e13f0ec42ee71ed338170e0f7b246708e9cfc617ce65098f5ce7ab32d4305e785642d3e44253462104d5b9c4abcb1a4113f48347
|
||||
SHA512 (ruby-3.3.2.tar.xz) = f2c4fb0d7c80aa46cdd80ad54ffee614e95d2fbad0554b6ce81f42fa5b891aaea63ddfd5b962e28508a4c835f9abf091a05a2e1234ef08c3e71af522a029c4e1
|
||||
|
Loading…
Reference in New Issue
Block a user