Upgrade to Ruby 2.5.0 (r59424).
This commit is contained in:
parent
b4d36d9943
commit
80cccfaaea
@ -26,7 +26,7 @@ diff --git a/common.mk b/common.mk
|
||||
index 5cfbc3d..3f0a82e 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -149,7 +149,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(INITOBJS)
|
||||
@@ -145,7 +145,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(INITOBJS)
|
||||
GOLFOBJS = goruby.$(OBJEXT) golf_prelude.$(OBJEXT)
|
||||
|
||||
DEFAULT_PRELUDES = $(GEM_PRELUDE)
|
||||
|
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
RUBY_EXEC_PREFIX=''
|
||||
@@ -4509,6 +4513,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
@@ -4486,6 +4490,7 @@ AC_SUBST(sitearchdir)dnl
|
||||
AC_SUBST(vendordir)dnl
|
||||
AC_SUBST(vendorlibdir)dnl
|
||||
AC_SUBST(vendorarchdir)dnl
|
||||
|
@ -11,7 +11,7 @@ diff --git a/common.mk b/common.mk
|
||||
index 168dc52..20c218a 100644
|
||||
--- a/common.mk
|
||||
+++ b/common.mk
|
||||
@@ -939,9 +939,9 @@ $(MINIPRELUDE_C): $(COMPILE_PRELUDE)
|
||||
@@ -935,9 +935,9 @@ $(MINIPRELUDE_C): $(COMPILE_PRELUDE)
|
||||
$(srcdir)/template/prelude.c.tmpl
|
||||
|
||||
$(PRELUDE_C): $(COMPILE_PRELUDE) \
|
||||
|
@ -120,7 +120,7 @@ index db37cd6..6e73fae 100644
|
||||
|
||||
AS_IF([test "${LOAD_RELATIVE+set}"], [
|
||||
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
|
||||
@@ -4491,6 +4494,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
@@ -4468,6 +4471,7 @@ AC_SUBST(sitearchincludedir)dnl
|
||||
AC_SUBST(arch)dnl
|
||||
AC_SUBST(sitearch)dnl
|
||||
AC_SUBST(ruby_version)dnl
|
||||
|
@ -0,0 +1,26 @@
|
||||
From 261353a42d0dc0e7bf73e5a8fb8ecffd04249d42 Mon Sep 17 00:00:00 2001
|
||||
From: Kazuki Yamaguchi <k@rhe.jp>
|
||||
Date: Tue, 27 Jun 2017 14:31:09 +0900
|
||||
Subject: [PATCH] test/test_ssl: allow 3DES cipher suites in
|
||||
test_sslctx_set_params
|
||||
|
||||
Fedora's OpenSSL seems to enable 3DES cipher suites by DEFAULT.
|
||||
|
||||
Fixes: https://github.com/ruby/openssl/issues/127
|
||||
---
|
||||
test/test_ssl.rb | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/openssl/test_ssl.rb b/test/openssl/test_ssl.rb
|
||||
index 19066566..b3efe95a 100644
|
||||
--- a/test/openssl/test_ssl.rb
|
||||
+++ b/test/openssl/test_ssl.rb
|
||||
@@ -350,7 +350,7 @@ def test_sslctx_set_params
|
||||
assert_equal OpenSSL::SSL::VERIFY_PEER, ctx.verify_mode
|
||||
ciphers_names = ctx.ciphers.collect{|v, _, _, _| v }
|
||||
assert ciphers_names.all?{|v| /A(EC)?DH/ !~ v }, "anon ciphers are disabled"
|
||||
- assert ciphers_names.all?{|v| /(RC4|MD5|EXP|DES)/ !~ v }, "weak ciphers are disabled"
|
||||
+ assert ciphers_names.all?{|v| /(RC4|MD5|EXP|DES(?!-EDE|-CBC3))/ !~ v }, "weak ciphers are disabled"
|
||||
assert_equal 0, ctx.options & OpenSSL::SSL::OP_DONT_INSERT_EMPTY_FRAGMENTS
|
||||
if defined?(OpenSSL::SSL::OP_NO_COMPRESSION) # >= 1.0.0
|
||||
assert_equal OpenSSL::SSL::OP_NO_COMPRESSION,
|
@ -10,7 +10,7 @@
|
||||
#%%global milestone rc1
|
||||
|
||||
# Keep the revision enabled for pre-releases from SVN.
|
||||
%global revision 59376
|
||||
%global revision 59424
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -1040,8 +1040,8 @@ make check TESTS="-v $DISABLE_TESTS"
|
||||
%{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec
|
||||
|
||||
%changelog
|
||||
* Tue Apr 11 2017 Vít Ondruch <vondruch@redhat.com> - 2.5.0-0.1.r59376
|
||||
- Upgrade to Ruby 2.5.0 (r59376).
|
||||
* Tue Apr 11 2017 Vít Ondruch <vondruch@redhat.com> - 2.5.0-0.1.r59424
|
||||
- Upgrade to Ruby 2.5.0 (r59424).
|
||||
|
||||
* Mon Apr 03 2017 Vít Ondruch <vondruch@redhat.com> - 2.4.1-79
|
||||
- Update to Ruby 2.4.1.
|
||||
|
Loading…
Reference in New Issue
Block a user