Disable pthread on RISC-V (riscv64)
Until we can understand the build failure related to pthread thread model it's better we disable it: BUILDSTDERR: rb_mjiminiruby: thread_pthread.c:1995: rb_sigwait_fd_put: Assertion `old == th' failed. BUILDSTDERR: make: *** [uncommon.mk:233: .ext/include/riscv64-linux/rb_mjit_min_header-2.6.3.h] Aborted (core dumped) Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
parent
d2b1e688a4
commit
60baed04d5
14
riscv-disable-pthread.patch
Normal file
14
riscv-disable-pthread.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 363afee..3276ade 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -770,6 +770,9 @@ AS_CASE(["$target_os"],
|
||||||
|
enable_pthread=yes
|
||||||
|
])
|
||||||
|
|
||||||
|
+# Disable pthread on RISC-V until compile assert is sorted out
|
||||||
|
+AS_CASE(["$target_cpu"],[riscv*],[enable_pthread=no],[])
|
||||||
|
+
|
||||||
|
dnl Checks for libraries.
|
||||||
|
AS_CASE(["$target_os"],[*bsd*|dragonfly*],[],[ac_cv_func_daemon=no])
|
||||||
|
|
12
ruby.spec
12
ruby.spec
@ -22,7 +22,7 @@
|
|||||||
|
|
||||||
|
|
||||||
%global release 121
|
%global release 121
|
||||||
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
|
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}.0.riscv64%{?dist}}
|
||||||
|
|
||||||
# The RubyGems library has to stay out of Ruby directory tree, since the
|
# The RubyGems library has to stay out of Ruby directory tree, since the
|
||||||
# RubyGems should be share by all Ruby implementations.
|
# RubyGems should be share by all Ruby implementations.
|
||||||
@ -154,6 +154,9 @@ Patch22: ruby-2.6.0-config-support-include-directive.patch
|
|||||||
# https://github.com/ruby/openssl/pull/217
|
# https://github.com/ruby/openssl/pull/217
|
||||||
Patch23: ruby-2.6.0-use-larger-keys-for-SSL-tests.patch
|
Patch23: ruby-2.6.0-use-larger-keys-for-SSL-tests.patch
|
||||||
|
|
||||||
|
# Disable pthread on Linux RISC-V (riscv64)
|
||||||
|
Patch30: riscv-disable-pthread.patch
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Suggests: rubypick
|
Suggests: rubypick
|
||||||
Recommends: ruby(rubygems) >= %{rubygems_version}
|
Recommends: ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -547,6 +550,10 @@ rm -rf ext/fiddle/libffi*
|
|||||||
%patch22 -p1
|
%patch22 -p1
|
||||||
%patch23 -p1
|
%patch23 -p1
|
||||||
|
|
||||||
|
%ifarch riscv64
|
||||||
|
%patch30 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
# Provide an example of usage of the tapset:
|
# Provide an example of usage of the tapset:
|
||||||
cp -a %{SOURCE3} .
|
cp -a %{SOURCE3} .
|
||||||
|
|
||||||
@ -1182,6 +1189,9 @@ make check TESTS="-v $DISABLE_TESTS" MSPECOPT="-fs $MSPECOPTS"
|
|||||||
%{_mandir}/man5/gemfile.5*
|
%{_mandir}/man5/gemfile.5*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 23 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> - 2.6.3-121.0.riscv64
|
||||||
|
- Disable pthread on RISC-V (riscv64)
|
||||||
|
|
||||||
* Tue Jun 25 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.3-121
|
* Tue Jun 25 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.3-121
|
||||||
- Properly support %%prerelease in %%gemspec_ macros.
|
- Properly support %%prerelease in %%gemspec_ macros.
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user