Disable pthread on RISC-V (riscv64)

Until we can understand the build failure related to pthread thread
model it's better we disable it:

BUILDSTDERR: rb_mjiminiruby: thread_pthread.c:1995: rb_sigwait_fd_put: Assertion `old == th' failed.
BUILDSTDERR: make: *** [uncommon.mk:233: .ext/include/riscv64-linux/rb_mjit_min_header-2.6.3.h] Aborted (core dumped)

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2019-07-23 17:04:04 +03:00
parent d2b1e688a4
commit 60baed04d5
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
2 changed files with 25 additions and 1 deletions

View File

@ -0,0 +1,14 @@
diff --git a/configure.ac b/configure.ac
index 363afee..3276ade 100644
--- a/configure.ac
+++ b/configure.ac
@@ -770,6 +770,9 @@ AS_CASE(["$target_os"],
enable_pthread=yes
])
+# Disable pthread on RISC-V until compile assert is sorted out
+AS_CASE(["$target_cpu"],[riscv*],[enable_pthread=no],[])
+
dnl Checks for libraries.
AS_CASE(["$target_os"],[*bsd*|dragonfly*],[],[ac_cv_func_daemon=no])

View File

@ -22,7 +22,7 @@
%global release 121
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}.0.riscv64%{?dist}}
# The RubyGems library has to stay out of Ruby directory tree, since the
# RubyGems should be share by all Ruby implementations.
@ -154,6 +154,9 @@ Patch22: ruby-2.6.0-config-support-include-directive.patch
# https://github.com/ruby/openssl/pull/217
Patch23: ruby-2.6.0-use-larger-keys-for-SSL-tests.patch
# Disable pthread on Linux RISC-V (riscv64)
Patch30: riscv-disable-pthread.patch
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Suggests: rubypick
Recommends: ruby(rubygems) >= %{rubygems_version}
@ -547,6 +550,10 @@ rm -rf ext/fiddle/libffi*
%patch22 -p1
%patch23 -p1
%ifarch riscv64
%patch30 -p1
%endif
# Provide an example of usage of the tapset:
cp -a %{SOURCE3} .
@ -1182,6 +1189,9 @@ make check TESTS="-v $DISABLE_TESTS" MSPECOPT="-fs $MSPECOPTS"
%{_mandir}/man5/gemfile.5*
%changelog
* Tue Jul 23 2019 David Abdurachmanov <david.abdurachmanov@sifive.com> - 2.6.3-121.0.riscv64
- Disable pthread on RISC-V (riscv64)
* Tue Jun 25 2019 Vít Ondruch <vondruch@redhat.com> - 2.6.3-121
- Properly support %%prerelease in %%gemspec_ macros.