Upgrade to Ruby 3.3.5.
Resolves: rhbz#2309364
This commit is contained in:
parent
b017ed037a
commit
58c3fcb847
@ -279,9 +279,9 @@ diff --git a/tool/m4/ruby_try_cflags.m4 b/tool/m4/ruby_try_cflags.m4
|
||||
index b74718fe5e1cef..b397642aad9ca2 100644
|
||||
--- a/tool/m4/ruby_try_cflags.m4
|
||||
+++ b/tool/m4/ruby_try_cflags.m4
|
||||
@@ -17,3 +17,20 @@ AC_DEFUN([RUBY_TRY_CFLAGS], [
|
||||
AC_MSG_RESULT(no)])
|
||||
])
|
||||
@@ -22,3 +22,20 @@ AC_DEFUN([RUBY_TRY_CFLAGS], [
|
||||
AC_MSG_RESULT(no)],
|
||||
[$4], [$5])
|
||||
])dnl
|
||||
+
|
||||
+AC_DEFUN([_RUBY_TRY_CFLAGS_PREPEND], [
|
||||
|
31
ruby.spec
31
ruby.spec
@ -1,6 +1,6 @@
|
||||
%global major_version 3
|
||||
%global minor_version 3
|
||||
%global teeny_version 4
|
||||
%global teeny_version 5
|
||||
%global major_minor_version %{major_version}.%{minor_version}
|
||||
|
||||
%global ruby_version %{major_minor_version}.%{teeny_version}
|
||||
@ -10,7 +10,7 @@
|
||||
#%%global milestone rc1
|
||||
|
||||
# Keep the revision enabled for pre-releases from GIT.
|
||||
#%%global revision be1089c8ec
|
||||
#%%global revision ef084cc8f4
|
||||
|
||||
%global ruby_archive %{name}-%{ruby_version}
|
||||
|
||||
@ -27,7 +27,7 @@
|
||||
%global rubygems_dir %{_datadir}/rubygems
|
||||
|
||||
# Bundled libraries versions
|
||||
%global rubygems_version 3.5.11
|
||||
%global rubygems_version 3.5.16
|
||||
%global rubygems_molinillo_version 0.8.0
|
||||
%global rubygems_net_http_version 0.4.0
|
||||
%global rubygems_net_protocol_version 0.2.2
|
||||
@ -38,7 +38,7 @@
|
||||
%global rubygems_uri_version 0.13.0
|
||||
|
||||
# Default gems.
|
||||
%global bundler_version 2.5.11
|
||||
%global bundler_version 2.5.16
|
||||
%global bundler_connection_pool_version 2.4.1
|
||||
%global bundler_fileutils_version 1.7.2
|
||||
%global bundler_net_http_persistent_version 4.0.2
|
||||
@ -105,7 +105,7 @@
|
||||
%global tmpdir_version 0.2.0
|
||||
%global tsort_version 0.2.0
|
||||
%global un_version 0.3.0
|
||||
%global uri_version 0.13.0
|
||||
%global uri_version 0.13.1
|
||||
%global weakref_version 0.1.3
|
||||
%global win32ole_version 1.8.10
|
||||
%global yaml_version 0.3.0
|
||||
@ -133,8 +133,8 @@
|
||||
%global racc_version 1.7.3
|
||||
%global rake_version 13.1.0
|
||||
%global rbs_version 3.4.0
|
||||
%global rexml_version 3.2.8
|
||||
%global rss_version 0.3.0
|
||||
%global rexml_version 3.3.6
|
||||
%global rss_version 0.3.1
|
||||
%global test_unit_version 3.6.1
|
||||
%global typeprof_version 0.21.9
|
||||
|
||||
@ -171,7 +171,7 @@
|
||||
Summary: An interpreter of object-oriented scripting language
|
||||
Name: ruby
|
||||
Version: %{ruby_version}%{?development_release}
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
# Licenses, which are likely not included in binary RPMs:
|
||||
# Apache-2.0:
|
||||
# benchmark/gc/redblack.rb
|
||||
@ -279,6 +279,15 @@ Patch9: ruby-3.3.0-Disable-syntax-suggest-test-case.patch
|
||||
# Make sure hardeding flags are correctly applied.
|
||||
# https://bugs.ruby-lang.org/issues/20520
|
||||
Patch12: ruby-3.4.0-Extract-hardening-CFLAGS-to-a-special-hardenflags-variable.patch
|
||||
# Fix build error:
|
||||
# RPM build errors:
|
||||
# error: Installed (but unpackaged) file(s) found:
|
||||
# /usr/bin/bundle.lock
|
||||
# This would break not only Ruby itself, but allso all rubygem-packages.
|
||||
# https://github.com/rubygems/rubygems/pull/7931
|
||||
Patch13: rubygems-3.5.17-Avoid-another-race-condition-of-open-mode.patch
|
||||
# https://github.com/rubygems/rubygems/pull/7939
|
||||
Patch14: rubygems-3.5.17-Remove-the-lock-file-for-binstubs.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
%{?with_rubypick:Suggests: rubypick}
|
||||
@ -757,6 +766,8 @@ analysis result in RBS format, a standard type description format for Ruby
|
||||
%patch 6 -p1
|
||||
%patch 9 -p1
|
||||
%patch 12 -p1
|
||||
%patch 13 -p1
|
||||
%patch 14 -p1
|
||||
|
||||
# Provide an example of usage of the tapset:
|
||||
cp -a %{SOURCE3} .
|
||||
@ -1733,6 +1744,10 @@ make -C %{_vpath_builddir} runruby TESTRUN_SCRIPT=" \
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 03 2024 Vít Ondruch <vondruch@redhat.com> - 3.3.5-14
|
||||
- Upgrade to Ruby 3.3.5.
|
||||
Resolves: rhbz#2309364
|
||||
|
||||
* Mon Jul 29 2024 Jun Aruga <jaruga@redhat.com> - 3.3.4-13
|
||||
- Add systemtap-sdt-devel to build Ruby with systemtap sdt header files.
|
||||
Co-authored-by: Lumír Balhar <lbalhar@redhat.com>
|
||||
|
@ -0,0 +1,45 @@
|
||||
From 2daad257bee7a500e18ebe553e79487b267fb140 Mon Sep 17 00:00:00 2001
|
||||
From: Nobuyoshi Nakada <nobu@ruby-lang.org>
|
||||
Date: Mon, 12 Aug 2024 20:18:34 +0900
|
||||
Subject: [PATCH] Avoid another race condition of open mode
|
||||
|
||||
Instead, just open in CREATE and APPEND mode.
|
||||
Also, move the workaround for old Solaris as fallback to retry.
|
||||
---
|
||||
lib/rubygems.rb | 14 +++++---------
|
||||
1 file changed, 5 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/lib/rubygems.rb b/lib/rubygems.rb
|
||||
index 2b52cde0a749..c51ba69203cb 100644
|
||||
--- a/lib/rubygems.rb
|
||||
+++ b/lib/rubygems.rb
|
||||
@@ -778,24 +778,20 @@ def self.open_file(path, flags, &block)
|
||||
File.open(path, flags, &block)
|
||||
end
|
||||
|
||||
+ MODE_TO_FLOCK = IO::RDONLY | IO::APPEND | IO::CREAT # :nodoc:
|
||||
+
|
||||
##
|
||||
# Open a file with given flags, and protect access with flock
|
||||
|
||||
def self.open_file_with_flock(path, &block)
|
||||
- flags = File.exist?(path) ? "r+" : "a+"
|
||||
-
|
||||
- File.open(path, flags) do |io|
|
||||
+ File.open(path, MODE_TO_FLOCK) do |io|
|
||||
begin
|
||||
io.flock(File::LOCK_EX)
|
||||
rescue Errno::ENOSYS, Errno::ENOTSUP
|
||||
+ rescue Errno::ENOLCK # NFS
|
||||
+ raise unless Thread.main == Thread.current
|
||||
end
|
||||
yield io
|
||||
- rescue Errno::ENOLCK # NFS
|
||||
- if Thread.main != Thread.current
|
||||
- raise
|
||||
- else
|
||||
- open_file(path, flags, &block)
|
||||
- end
|
||||
end
|
||||
end
|
||||
|
183
rubygems-3.5.17-Remove-the-lock-file-for-binstubs.patch
Normal file
183
rubygems-3.5.17-Remove-the-lock-file-for-binstubs.patch
Normal file
@ -0,0 +1,183 @@
|
||||
From ace303c2d7bc0d98407e5e8b1ca77de07aa0eb75 Mon Sep 17 00:00:00 2001
|
||||
From: Nobuyoshi Nakada <nobu@ruby-lang.org>
|
||||
Date: Tue, 13 Aug 2024 17:19:41 +0900
|
||||
Subject: [PATCH 1/3] Remove the lock file for binstubs
|
||||
|
||||
https://github.com/rubygems/rubygems/pull/7806#issuecomment-2241662488
|
||||
---
|
||||
lib/rubygems.rb | 2 +-
|
||||
lib/rubygems/installer.rb | 3 ++-
|
||||
test/rubygems/test_gem_installer.rb | 10 ++++++++++
|
||||
3 files changed, 13 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/rubygems.rb b/lib/rubygems.rb
|
||||
index bd9f240e2091..7626ccfdf0d6 100644
|
||||
--- a/lib/rubygems.rb
|
||||
+++ b/lib/rubygems.rb
|
||||
@@ -778,7 +778,7 @@ def self.open_file(path, flags, &block)
|
||||
File.open(path, flags, &block)
|
||||
end
|
||||
|
||||
- MODE_TO_FLOCK = IO::RDONLY | IO::APPEND | IO::CREAT # :nodoc:
|
||||
+ MODE_TO_FLOCK = IO::RDONLY | IO::APPEND | IO::CREAT | IO::SHARE_DELETE | IO::BINARY # :nodoc:
|
||||
|
||||
##
|
||||
# Open a file with given flags, and protect access with flock
|
||||
diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
|
||||
index d558c0be2bfa..8f95bab733f8 100644
|
||||
--- a/lib/rubygems/installer.rb
|
||||
+++ b/lib/rubygems/installer.rb
|
||||
@@ -538,7 +538,7 @@ def generate_plugins # :nodoc:
|
||||
def generate_bin_script(filename, bindir)
|
||||
bin_script_path = File.join bindir, formatted_program_filename(filename)
|
||||
|
||||
- Gem.open_file_with_flock("#{bin_script_path}.lock") do
|
||||
+ Gem.open_file_with_flock("#{bin_script_path}.lock") do |lock|
|
||||
require "fileutils"
|
||||
FileUtils.rm_f bin_script_path # prior install may have been --no-wrappers
|
||||
|
||||
@@ -546,6 +546,7 @@ def generate_bin_script(filename, bindir)
|
||||
file.write app_script_text(filename)
|
||||
file.chmod(options[:prog_mode] || 0o755)
|
||||
end
|
||||
+ File.unlink(lock.path)
|
||||
end
|
||||
|
||||
verbose bin_script_path
|
||||
diff --git a/test/rubygems/test_gem_installer.rb b/test/rubygems/test_gem_installer.rb
|
||||
index a61d1b6fff28..2f4ff7349db4 100644
|
||||
--- a/test/rubygems/test_gem_installer.rb
|
||||
+++ b/test/rubygems/test_gem_installer.rb
|
||||
@@ -1083,6 +1083,8 @@ def test_install_creates_working_binstub
|
||||
end
|
||||
|
||||
assert_match(/ran executable/, e.message)
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
def test_conflicting_binstubs
|
||||
@@ -1131,6 +1133,8 @@ def test_conflicting_binstubs
|
||||
# We expect the bin stub to activate the version that actually contains
|
||||
# the binstub.
|
||||
assert_match("I have an executable", e.message)
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
def test_install_creates_binstub_that_understand_version
|
||||
@@ -1160,6 +1164,8 @@ def test_install_creates_binstub_that_understand_version
|
||||
end
|
||||
|
||||
assert_includes(e.message, "can't find gem a (= 3.0)")
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
def test_install_creates_binstub_that_prefers_user_installed_gem_to_default
|
||||
@@ -1192,6 +1198,8 @@ def test_install_creates_binstub_that_prefers_user_installed_gem_to_default
|
||||
end
|
||||
|
||||
assert_equal(e.message, "ran executable")
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
def test_install_creates_binstub_that_dont_trust_encoding
|
||||
@@ -1222,6 +1230,8 @@ def test_install_creates_binstub_that_dont_trust_encoding
|
||||
end
|
||||
|
||||
assert_match(/ran executable/, e.message)
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
def test_install_with_no_prior_files
|
||||
|
||||
From fa0700e0f52827ae05da59a331a2917a12c09b8a Mon Sep 17 00:00:00 2001
|
||||
From: Nobuyoshi Nakada <nobu@ruby-lang.org>
|
||||
Date: Thu, 15 Aug 2024 16:20:46 +0900
|
||||
Subject: [PATCH 2/3] Workaround for TruffleRuby
|
||||
|
||||
---
|
||||
lib/rubygems.rb | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/rubygems.rb b/lib/rubygems.rb
|
||||
index 7626ccfdf0d6..9d40fcc2f77a 100644
|
||||
--- a/lib/rubygems.rb
|
||||
+++ b/lib/rubygems.rb
|
||||
@@ -778,7 +778,9 @@ def self.open_file(path, flags, &block)
|
||||
File.open(path, flags, &block)
|
||||
end
|
||||
|
||||
- MODE_TO_FLOCK = IO::RDONLY | IO::APPEND | IO::CREAT | IO::SHARE_DELETE | IO::BINARY # :nodoc:
|
||||
+ mode = IO::RDONLY | IO::APPEND | IO::CREAT | IO::BINARY
|
||||
+ mode |= IO::SHARE_DELETE if IO.const_defined?(:SHARE_DELETE)
|
||||
+ MODE_TO_FLOCK = mode # :nodoc:
|
||||
|
||||
##
|
||||
# Open a file with given flags, and protect access with flock
|
||||
|
||||
From 6548e7aa17186687d0a8b99571885f148363016d Mon Sep 17 00:00:00 2001
|
||||
From: Nobuyoshi Nakada <nobu@ruby-lang.org>
|
||||
Date: Fri, 16 Aug 2024 20:19:22 +0900
|
||||
Subject: [PATCH 3/3] Ensure that the lock file will be removed
|
||||
|
||||
---
|
||||
lib/rubygems/installer.rb | 3 ++-
|
||||
test/rubygems/test_gem_installer.rb | 27 +++++++++++++++++++++++++++
|
||||
2 files changed, 29 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/rubygems/installer.rb b/lib/rubygems/installer.rb
|
||||
index 8f95bab733f8..1085f73fca53 100644
|
||||
--- a/lib/rubygems/installer.rb
|
||||
+++ b/lib/rubygems/installer.rb
|
||||
@@ -546,7 +546,8 @@ def generate_bin_script(filename, bindir)
|
||||
file.write app_script_text(filename)
|
||||
file.chmod(options[:prog_mode] || 0o755)
|
||||
end
|
||||
- File.unlink(lock.path)
|
||||
+ ensure
|
||||
+ FileUtils.rm_f lock.path
|
||||
end
|
||||
|
||||
verbose bin_script_path
|
||||
diff --git a/test/rubygems/test_gem_installer.rb b/test/rubygems/test_gem_installer.rb
|
||||
index 2f4ff7349db4..ad5b1a244e80 100644
|
||||
--- a/test/rubygems/test_gem_installer.rb
|
||||
+++ b/test/rubygems/test_gem_installer.rb
|
||||
@@ -1234,6 +1234,33 @@ def test_install_creates_binstub_that_dont_trust_encoding
|
||||
assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
end
|
||||
|
||||
+ def test_install_does_not_leave_lockfile_for_binstub
|
||||
+ installer = util_setup_installer
|
||||
+
|
||||
+ installer.wrappers = true
|
||||
+
|
||||
+ File.class_eval do
|
||||
+ alias_method :original_chmod, :chmod
|
||||
+ define_method(:chmod) do |mode|
|
||||
+ original_chmod(mode)
|
||||
+ raise Gem::Ext::BuildError if path.end_with?("/executable")
|
||||
+ end
|
||||
+ end
|
||||
+
|
||||
+ assert_raise(Gem::Ext::BuildError) do
|
||||
+ installer.install
|
||||
+ end
|
||||
+
|
||||
+ assert_path_not_exist(File.join(installer.bin_dir, "executable.lock"))
|
||||
+ # assert_path_not_exist(File.join(installer.bin_dir, "executable"))
|
||||
+ ensure
|
||||
+ File.class_eval do
|
||||
+ remove_method :chmod
|
||||
+ alias_method :chmod, :original_chmod
|
||||
+ remove_method :original_chmod
|
||||
+ end
|
||||
+ end
|
||||
+
|
||||
def test_install_with_no_prior_files
|
||||
installer = util_setup_installer
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (ruby-3.3.4.tar.xz) = b26461a13ff82a08a282f10108028bb2a2e4a28da6182a291062fc54089c6655d79c22cc69d59156f9b11cb10a17fe8c69d489343fbae123a45f03361b95c9eb
|
||||
SHA512 (ruby-3.3.5.tar.xz) = dd5c6a7f74854e143e0ca46b9d7c0d1983fc4886f5f733cd108345dbf4b21f61ad978ad6806e05a57b7af28fd9216dd38d7145808188bbb3695a7f3a4eda3883
|
||||
|
Loading…
Reference in New Issue
Block a user