The exec_prefix seems to be correct now.
This commit is contained in:
parent
e1890f92f2
commit
486dd7a45b
@ -1,43 +0,0 @@
|
|||||||
* Unmerged path ChangeLog
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index be7d4fe..2d511e5 100644
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -2574,14 +2574,9 @@ AS_CASE(["$target_os"],
|
|
||||||
|
|
||||||
AC_SUBST(setup)
|
|
||||||
|
|
||||||
-test x"$prefix" = xNONE && prefix=$ac_default_prefix
|
|
||||||
-test x"${exec_prefix}" = xNONE && exec_prefix="$prefix"
|
|
||||||
-pat=`echo "${exec_prefix}" | tr -c '\012' .`'\(.*\)'
|
|
||||||
-for var in bindir libdir; do
|
|
||||||
- eval val='"$'$var'"'
|
|
||||||
- AS_CASE(["$val"], ["${exec_prefix}"*], [val='${exec_prefix}'"`expr \"$val\" : \"$pat\"`"])
|
|
||||||
- eval $var='"$val"'
|
|
||||||
-done
|
|
||||||
+if test "$prefix" = NONE; then
|
|
||||||
+ prefix=$ac_default_prefix
|
|
||||||
+fi
|
|
||||||
|
|
||||||
BTESTRUBY='$(MINIRUBY)'
|
|
||||||
if test x"$cross_compiling" = xyes; then
|
|
||||||
@@ -3211,9 +3216,6 @@ AS_CASE(["$target_os"],
|
|
||||||
|
|
||||||
shvar_to_cpp() {
|
|
||||||
var="$1" val="$2"
|
|
||||||
- exec_prefix_pat="`echo \"${exec_prefix}\" | sed 's/\\./\\\\./g'`"
|
|
||||||
- arch_pat="`echo \"${arch}\" | sed 's/\\./\\\\./g'`"
|
|
||||||
- sitearch_pat="`echo \"${sitearch}\" | sed 's/\\./\\\\./g'`"
|
|
||||||
val="`echo '\"'\"${val}\"'\"' |
|
|
||||||
sed \
|
|
||||||
-e 's/\${\([[A-Z][A-Z_]]*\)}/\"\1\"/g' \
|
|
||||||
@@ -3236,9 +3238,6 @@ shvar_to_cpp() {
|
|
||||||
-e 's/\${rubyarchprefix}/\"RUBY_ARCH_PREFIX_FOR(arch)\"/g' \
|
|
||||||
-e 's/\${rubysitearchprefix}/\"RUBY_SITEARCH_PREFIX_FOR(arch)\"/g' \
|
|
||||||
-e 's/\${exec_prefix}/\"RUBY_EXEC_PREFIX\"/g' \
|
|
||||||
- -e \"s|${exec_prefix_pat}/|\"'\"RUBY_EXEC_PREFIX\"/|g' \
|
|
||||||
- -e \"s|${arch_pat}|\"'\"arch\"|g' \
|
|
||||||
- -e \"s|${sitearch_pat}|\"'\"sitearch\"|g' \
|
|
||||||
-e 's|^\\\"NONE/|RUBY_EXEC_PREFIX\\\"/|' \
|
|
||||||
-e 's|^\\\"NONE\\\"|\\\"'\"${prefix}\"'\\\"|' \
|
|
||||||
-e 's/^\\\"\\\"\(.\)/\1/;s/\(.\)\\\"\\\"$/\1/'
|
|
@ -135,10 +135,6 @@ Patch13: rubygems-2.0.0-Do-not-modify-global-Specification.dirs-during-insta.pat
|
|||||||
# This prevents issues, when ruby configuration specifies --with-ruby-version=''.
|
# This prevents issues, when ruby configuration specifies --with-ruby-version=''.
|
||||||
# https://github.com/rubygems/rubygems/pull/455
|
# https://github.com/rubygems/rubygems/pull/455
|
||||||
Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
|
Patch14: rubygems-2.0.0-Fixes-for-empty-ruby-version.patch
|
||||||
# Fixes issues with wrong value of Rubygem's shebang introduced in r39267.
|
|
||||||
# https://bugs.ruby-lang.org/issues/7915
|
|
||||||
# TODO:
|
|
||||||
Patch15: ruby-2.0.0-revert-unexpand-exec-prefix.patch
|
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: ruby(rubygems) >= %{rubygems_version}
|
Requires: ruby(rubygems) >= %{rubygems_version}
|
||||||
@ -402,7 +398,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
|
|||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
%patch13 -p1
|
%patch13 -p1
|
||||||
%patch14 -p1
|
%patch14 -p1
|
||||||
%patch15 -p1
|
|
||||||
|
|
||||||
# Provide an example of usage of the tapset:
|
# Provide an example of usage of the tapset:
|
||||||
cp -a %{SOURCE3} .
|
cp -a %{SOURCE3} .
|
||||||
|
Loading…
Reference in New Issue
Block a user