Upgrade to Ruby 2.2.0 (r48476).

This commit is contained in:
Vít Ondruch 2014-11-18 17:14:45 +01:00
parent 8c0bc69d65
commit 2cd1c80dbf
2 changed files with 13 additions and 11 deletions

View File

@ -26,15 +26,15 @@ diff --git a/common.mk b/common.mk
index 5cfbc3d..3f0a82e 100644
--- a/common.mk
+++ b/common.mk
@@ -113,7 +113,7 @@ ALLOBJS = $(NORMALMAINOBJ) $(MINIOBJS) $(COMMONOBJS) $(DMYEXT)
@@ -115,7 +115,7 @@
GOLFOBJS = goruby.$(OBJEXT) golf_prelude.$(OBJEXT)
DEFAULT_PRELUDES = $(GEM_PRELUDE)
-PRELUDE_SCRIPTS = $(srcdir)/prelude.rb $(srcdir)/enc/prelude.rb $(DEFAULT_PRELUDES)
+PRELUDE_SCRIPTS = $(srcdir)/prelude.rb $(srcdir)/enc/prelude.rb $(DEFAULT_PRELUDES) $(OPTIONAL_PRELUDES)
GEM_PRELUDE = $(srcdir)/gem_prelude.rb
PRELUDES = prelude.c miniprelude.c
GOLFPRELUDES = golf_prelude.c
GEM_PRELUDE = $(srcdir)/gem_prelude.rb
PRELUDES = {$(srcdir)}prelude.c {$(srcdir)}miniprelude.c
GOLFPRELUDES = {$(srcdir)}golf_prelude.c
diff --git a/configure.in b/configure.in
index 0e371e2..d4f1dcb 100644
--- a/configure.in

View File

@ -10,7 +10,7 @@
#%%global milestone preview2
# Keep the revision enabled for pre-releases from SVN.
%global revision 48365
%global revision 48476
%global ruby_archive %{name}-%{ruby_version}
@ -24,7 +24,7 @@
%global release 24
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
%global rubygems_version 2.4.2
%global rubygems_version 2.4.4
# The RubyGems library has to stay out of Ruby directory three, since the
# RubyGems should be share by all Ruby implementations.
@ -37,12 +37,12 @@
%global bigdecimal_version 1.2.5
%global io_console_version 0.4.2
%global json_version 1.8.1
%global minitest_version 5.4.2
%global minitest_version 5.4.3
%global power_assert_version 0.2.0
%global psych_version 2.0.6
%global rake_version 10.3.2
%global rdoc_version 4.2.0.alpha
%global test_unit_version 3.0.5
%global test_unit_version 3.0.6
# Might not be needed in the future, if we are lucky enough.
# https://bugzilla.redhat.com/show_bug.cgi?id=888262
@ -455,7 +455,9 @@ for cert in \
Class3PublicPrimaryCertificationAuthority.pem \
DigiCertHighAssuranceEVRootCA.pem \
EntrustnetSecureServerCertificationAuthority.pem \
GeoTrustGlobalCA.pem
GeoTrustGlobalCA.pem \
AddTrustExternalCARoot.pem \
AddTrustExternalCARoot-2048.pem
do
rm %{buildroot}%{rubygems_dir}/rubygems/ssl_certs/$cert
done
@ -870,8 +872,8 @@ make check TESTS="-v $DISABLE_TESTS"
%{ruby_libdir}/tkextlib
%changelog
* Mon Nov 10 2014 Vít Ondruch <vondruch@redhat.com> - 2.2.0-0.24.r48365
- Upgrade to Ruby 2.2.0 (r48365).
* Mon Nov 10 2014 Vít Ondruch <vondruch@redhat.com> - 2.2.0-0.24.r48476
- Upgrade to Ruby 2.2.0 (r48476).
- Explicitly list RubyGems directories to avoid accidentaly packaged content.
- Split test-unit and power_assert gems into separate sub-packages.