Update to Ruby 2.2.5.

This commit is contained in:
Vít Ondruch 2016-05-02 15:00:24 +02:00
parent a0377b1ffd
commit 22ddfc8f11
10 changed files with 129 additions and 11 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/ruby-2.2.2.tar.xz
/ruby-2.2.3.tar.xz
/ruby-2.2.4.tar.xz
/ruby-2.2.5.tar.xz

View File

@ -39,7 +39,7 @@ diff --git a/configure.in b/configure.in
index 0e371e2..d4f1dcb 100644
--- a/configure.in
+++ b/configure.in
@@ -4169,6 +4169,13 @@ AC_SUBST(rubyarchhdrdir)dnl
@@ -4209,6 +4209,13 @@ AC_SUBST(rubyarchhdrdir)dnl
AC_SUBST(sitearchhdrdir)dnl
AC_SUBST(vendorarchhdrdir)dnl

View File

@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
index 37d9a62..553d4d0 100644
--- a/configure.in
+++ b/configure.in
@@ -3385,6 +3385,11 @@ if test ${multiarch+set}; then
@@ -3425,6 +3425,11 @@ if test ${multiarch+set}; then
fi
archlibdir='${libdir}/${arch}'

View File

@ -14,7 +14,7 @@ diff --git a/configure.in b/configure.in
index 17ed3ed..5843651 100644
--- a/configure.in
+++ b/configure.in
@@ -3975,8 +3975,6 @@ AS_CASE(["$target_os"],
@@ -4015,8 +4015,6 @@ AS_CASE(["$target_os"],
rubyw_install_name='$(RUBYW_INSTALL_NAME)'
])
@ -23,7 +23,7 @@ index 17ed3ed..5843651 100644
rubyarchprefix=${multiarch+'${archlibdir}/${RUBY_BASE_NAME}'}${multiarch-'${rubylibprefix}/${arch}'}
AC_ARG_WITH(rubyarchprefix,
@@ -4006,6 +4004,7 @@ AC_ARG_WITH(ruby-version,
@@ -4046,6 +4044,7 @@ AC_ARG_WITH(ruby-version,
[ruby_version=full])
unset RUBY_LIB_VERSION
unset RUBY_LIB_VERSION_STYLE
@ -31,7 +31,7 @@ index 17ed3ed..5843651 100644
AS_CASE(["$ruby_version"],
[full], [RUBY_LIB_VERSION_STYLE='3 /* full */'],
[minor], [RUBY_LIB_VERSION_STYLE='2 /* minor */'])
@@ -4022,30 +4021,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
@@ -4062,30 +4061,34 @@ if test ${RUBY_LIB_VERSION_STYLE+set}; then
ruby_version="`$CPP -I. -I"${srcdir}" -I"${srcdir}/include" conftest.c | sed '/^ruby_version=/!d;s/ //g'`"
eval $ruby_version
elif test -z "${ruby_version}"; then

View File

@ -11,7 +11,7 @@ diff --git a/configure.in b/configure.in
index 553d4d0..03a4152 100644
--- a/configure.in
+++ b/configure.in
@@ -4087,6 +4087,8 @@ AC_SUBST(vendorarchdir)dnl
@@ -4127,6 +4127,8 @@ AC_SUBST(vendorarchdir)dnl
AC_SUBST(configure_args, "`echo "${ac_configure_args}" | sed 's/\\$/$$/g'`")dnl

View File

@ -15,7 +15,7 @@ diff --git a/configure.in b/configure.in
index 03a4152..0e371e2 100644
--- a/configure.in
+++ b/configure.in
@@ -4061,6 +4061,10 @@ AC_ARG_WITH(vendorarchdir,
@@ -4101,6 +4101,10 @@ AC_ARG_WITH(vendorarchdir,
[vendorarchdir=$withval],
[vendorarchdir=${multiarch+'${rubysitearchprefix}/vendor_ruby/${ruby_version}'}${multiarch-'${vendorlibdir}/${sitearch}'}])
@ -26,7 +26,7 @@ index 03a4152..0e371e2 100644
if test "${LOAD_RELATIVE+set}"; then
AC_DEFINE_UNQUOTED(LOAD_RELATIVE, $LOAD_RELATIVE)
RUBY_EXEC_PREFIX=''
@@ -4084,6 +4088,7 @@ AC_SUBST(sitearchdir)dnl
@@ -4124,6 +4128,7 @@ AC_SUBST(sitearchdir)dnl
AC_SUBST(vendordir)dnl
AC_SUBST(vendorlibdir)dnl
AC_SUBST(vendorarchdir)dnl

View File

@ -0,0 +1,40 @@
From cf23ad429da3213fd3b1261c546dfa08e7dba2bf Mon Sep 17 00:00:00 2001
From: usa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
Date: Wed, 27 Apr 2016 13:17:50 +0000
Subject: [PATCH] * compile.c (new_label_body): missed backporting r54548 in
r54698. this fixes randomly test failure introduced by r54698. cf. [Bug
#12082]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@54799 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
---
ChangeLog | 6 ++++++
compile.c | 2 ++
2 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/ChangeLog b/ChangeLog
index 2cfdb2c2..fe09b1e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+Wed Apr 27 22:16:04 2016 NAKAMURA Usaku <usa@ruby-lang.org>
+
+ * compile.c (new_label_body): missed backporting r54548 in r54698.
+ this fixes randomly test failure introduced by r54698.
+ cf. [Bug #12082]
+
Fri Apr 29 20:11:38 2016 Tanaka Akira <akr@fsij.org>
* test/ruby/test_time_tz.rb: Tests depends on Europe/Moscow removed
diff --git a/compile.c b/compile.c
index 001152a..cc8e748 100644
--- a/compile.c
+++ b/compile.c
@@ -929,6 +929,8 @@ new_label_body(rb_iseq_t *iseq, long line)
labelobj->label_no = iseq->compile_data->label_no++;
labelobj->sc_state = 0;
labelobj->sp = -1;
+ labelobj->set = 0;
+ labelobj->rescued = LABEL_RESCUE_NONE;
return labelobj;
}

View File

@ -0,0 +1,63 @@
From d16ff5c412b90b2766be97a5d3d689c5a18528d3 Mon Sep 17 00:00:00 2001
From: usa <usa@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
Date: Fri, 29 Apr 2016 11:12:17 +0000
Subject: [PATCH] merge revision(s) 54706:
* test/ruby/test_time_tz.rb: Tests depends on Europe/Moscow removed
to avoid test failures due to the tzdata change.
https://github.com/eggert/tz/commit/8ee11a301cf173afb0c76e0315b9f9ec8ebb9d95
Found by naruse.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@54815 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
---
ChangeLog | 7 +++++++
test/ruby/test_time_tz.rb | 13 -------------
2 files changed, 7 insertions(+), 13 deletions(-)
diff --git a/ChangeLog b/ChangeLog
index fe09b1e..1351c74 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+Fri Apr 29 20:11:38 2016 Tanaka Akira <akr@fsij.org>
+
+ * test/ruby/test_time_tz.rb: Tests depends on Europe/Moscow removed
+ to avoid test failures due to the tzdata change.
+ https://github.com/eggert/tz/commit/8ee11a301cf173afb0c76e0315b9f9ec8ebb9d95
+ Found by naruse.
+
Tue Apr 26 13:38:31 2016 NAKAMURA Usaku <usa@ruby-lang.org>
* README.EXT{,.ja}: `nul` should be uppercase.
diff --git a/test/ruby/test_time_tz.rb b/test/ruby/test_time_tz.rb
index fb1ab9b..96a03b7 100644
--- a/test/ruby/test_time_tz.rb
+++ b/test/ruby/test_time_tz.rb
@@ -169,13 +169,6 @@ def test_europe_lisbon
}
end if has_lisbon_tz
- def test_europe_moscow
- with_tz(tz="Europe/Moscow") {
- assert_time_constructor(tz, "1992-03-29 00:00:00 +0400", :local, [1992,3,28,23,0,0])
- assert_time_constructor(tz, "1992-03-29 00:59:59 +0400", :local, [1992,3,28,23,59,59])
- }
- end
-
def test_pacific_kiritimati
with_tz(tz="Pacific/Kiritimati") {
assert_time_constructor(tz, "1994-12-31 23:59:59 -1000", :local, [1994,12,31,23,59,59])
@@ -355,12 +348,6 @@ def self.gen_zdump_test(data)
Europe/London Sun Aug 10 01:00:00 1947 UTC = Sun Aug 10 02:00:00 1947 BST isdst=1 gmtoff=3600
Europe/London Sun Nov 2 01:59:59 1947 UTC = Sun Nov 2 02:59:59 1947 BST isdst=1 gmtoff=3600
Europe/London Sun Nov 2 02:00:00 1947 UTC = Sun Nov 2 02:00:00 1947 GMT isdst=0 gmtoff=0
-Europe/Moscow Sat Jan 18 23:59:59 1992 UTC = Sun Jan 19 01:59:59 1992 MSK isdst=0 gmtoff=7200
-Europe/Moscow Sun Jan 19 00:00:00 1992 UTC = Sun Jan 19 03:00:00 1992 MSK isdst=0 gmtoff=10800
-Europe/Moscow Sat Mar 28 19:59:59 1992 UTC = Sat Mar 28 22:59:59 1992 MSK isdst=0 gmtoff=10800
-Europe/Moscow Sat Mar 28 20:00:00 1992 UTC = Sun Mar 29 00:00:00 1992 MSD isdst=1 gmtoff=14400
-Europe/Moscow Sat Sep 26 18:59:59 1992 UTC = Sat Sep 26 22:59:59 1992 MSD isdst=1 gmtoff=14400
-Europe/Moscow Sat Sep 26 19:00:00 1992 UTC = Sat Sep 26 22:00:00 1992 MSK isdst=0 gmtoff=10800
Pacific/Kiritimati Sun Jan 1 09:59:59 1995 UTC = Sat Dec 31 23:59:59 1994 LINT isdst=0 gmtoff=-36000
Pacific/Kiritimati Sun Jan 1 10:00:00 1995 UTC = Mon Jan 2 00:00:00 1995 LINT isdst=0 gmtoff=50400
End

View File

@ -1,6 +1,6 @@
%global major_version 2
%global minor_version 2
%global teeny_version 4
%global teeny_version 5
%global major_minor_version %{major_version}.%{minor_version}
%global ruby_version %{major_minor_version}.%{teeny_version}
@ -21,7 +21,7 @@
%endif
%global release 47
%global release 48
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
%global rubygems_version 2.4.5.1
@ -115,6 +115,13 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
# Use miniruby to regenerate prelude.c.
# https://bugs.ruby-lang.org/issues/10554
Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
# Ignore Europe/Moscow TZ test, which fails due to change in tzdata.
# https://github.com/ruby/ruby/commit/d16ff5c412b90b2766be97a5d3d689c5a18528d3
Patch8: ruby-2.2.6-Tests-depends-on-Europe-Moscow-removed.patch
# Fixes random TestRubyOptimization#test_tailcall_inhibited_by_rescue test
# suite failures.
# https://github.com/ruby/ruby/commit/cf23ad429da3213fd3b1261c546dfa08e7dba2bf
Patch9: ruby-2.2.6-Fix-random-test-failure-introduced-by-r54698.patch
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: ruby(rubygems) >= %{rubygems_version}
@ -416,6 +423,8 @@ rm -rf ext/fiddle/libffi*
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
# Provide an example of usage of the tapset:
cp -a %{SOURCE3} .
@ -750,7 +759,9 @@ make check TESTS="-v $DISABLE_TESTS"
%{ruby_libarchdir}/enc/utf_16le.so
%{ruby_libarchdir}/enc/utf_32be.so
%{ruby_libarchdir}/enc/utf_32le.so
%{ruby_libarchdir}/enc/windows_1250.so
%{ruby_libarchdir}/enc/windows_1251.so
%{ruby_libarchdir}/enc/windows_1252.so
%{ruby_libarchdir}/enc/windows_31j.so
%{ruby_libarchdir}/etc.so
%{ruby_libarchdir}/fcntl.so
@ -890,6 +901,9 @@ make check TESTS="-v $DISABLE_TESTS"
%{ruby_libdir}/tkextlib
%changelog
* Mon May 02 2016 Vít Ondruch <vondruch@redhat.com> - 2.2.5-48
- Update to Ruby 2.2.5.
* Mon Dec 21 2015 Vít Ondruch <vondruch@redhat.com> - 2.2.4-47
- Update to Ruby 2.2.4.

View File

@ -1 +1 @@
350bfd495e1974cf752de9f4566c7911 ruby-2.2.4.tar.xz
4b9506c37e908b5b17215b66b2760438 ruby-2.2.5.tar.xz