Update to 2.1.6

This commit is contained in:
Josef Stribny 2015-04-14 13:11:53 +02:00
parent 84b8f16b83
commit 0e163c24d9
3 changed files with 7 additions and 49 deletions

View File

@ -1,41 +0,0 @@
diff -up ruby-2.1.5/configure.in.nosse2 ruby-2.1.5/configure.in
--- ruby-2.1.5/configure.in.nosse2 2014-12-26 16:31:57.696889054 -0700
+++ ruby-2.1.5/configure.in 2014-12-26 16:32:25.187718930 -0700
@@ -860,22 +860,6 @@ if test "$GCC" = yes; then
for oflag in -fno-fast-math; do
RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
done
- AS_CASE(["$target"],
- [*-darwin*], [
- # doesn't seem necessary on Mac OS X
- ],
- [[i[4-6]86*|i386*mingw*]], [
- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
- ])
- AS_CASE(["$XCFLAGS"],
- [[*-msse2*]], [
- RUBY_TRY_CFLAGS(-mstackrealign, [
- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
- ])
- ])
- ]
- )
fi
AC_ARG_WITH(opt-dir,
diff -up ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 ruby-2.1.5/test/ruby/test_sprintf.rb
--- ruby-2.1.5/test/ruby/test_sprintf.rb.nosse2 2014-09-03 09:25:51.000000000 -0600
+++ ruby-2.1.5/test/ruby/test_sprintf.rb 2014-12-26 16:31:57.699889035 -0700
@@ -194,8 +194,9 @@ class TestSprintf < Test::Unit::TestCase
sprintf("%20.0f", 36893488147419107329.0))
assert_equal(" Inf", sprintf("% 0e", 1.0/0.0), "moved from btest/knownbug")
assert_equal(" -0.", sprintf("%#10.0f", -0.5), "[ruby-dev:42552]")
- assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
- assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
+ # out of spec
+ #assert_equal("0x1p+2", sprintf('%.0a', Float('0x1.fp+1')), "[ruby-dev:42551]")
+ #assert_equal("-0x1.0p+2", sprintf('%.1a', Float('-0x1.ffp+1')), "[ruby-dev:42551]")
end
def test_float_hex

View File

@ -1,6 +1,6 @@
%global major_version 2
%global minor_version 1
%global teeny_version 5
%global teeny_version 6
%global major_minor_version %{major_version}.%{minor_version}
%global ruby_version %{major_minor_version}.%{teeny_version}
@ -21,7 +21,7 @@
%endif
%global release 26
%global release 27
%{!?release_string:%global release_string %{?development_release:0.}%{release}%{?development_release:.%{development_release}}%{?dist}}
%global rubygems_version 2.2.2
@ -35,7 +35,7 @@
%global irb_version %{ruby_version}
%global bigdecimal_version 1.2.4
%global io_console_version 0.4.2
%global io_console_version 0.4.3
%global json_version 1.8.1
%global minitest_version 4.7.5
%global psych_version 2.0.5
@ -109,9 +109,6 @@ Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
# Test are broken due to SSLv3 disabled in Fedora.
# https://bugs.ruby-lang.org/issues/10046
Patch7: ruby-2.2.0-Don-t-use-obsolete-SSLv3-for-tests.patch
# Disable sse2, already applied upstream
# https://bugzilla.redhat.com/show_bug.cgi?id=1101811
Patch8: ruby-nosse2.patch
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: ruby(rubygems) >= %{rubygems_version}
@ -373,7 +370,6 @@ Tcl/Tk interface for the object-oriented scripting language Ruby.
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
# Provide an example of usage of the tapset:
cp -a %{SOURCE3} .
@ -874,6 +870,9 @@ make check TESTS="-v $DISABLE_TESTS"
%{ruby_libdir}/tkextlib
%changelog
* Tue Apr 14 2015 Josef Stribny <jstribny@redhat.com> - 2.1.6-27
- Update to 2.1.6
* Fri Dec 26 2014 Orion Poplwski <orion@cora.nwra.com> - 2.1.5-26
- Disbable sse2 on i668 (bug #1101811)

View File

@ -1 +1 @@
a7c3e5fec47eff23091b566e9e1dac1b ruby-2.1.5.tar.bz2
e1a8e6c6bfbb09bb7f8d6be8f508e4a1 ruby-2.1.6.tar.bz2