rpy/rpy-1.0.3-turn-off-debug.patch
José Abílio Oliveira Matos 75810a5472 - Update to 1.0.3
- Backport two patches from upstream (turn off debug and use the lapack
    version that R was compiled with)
2008-05-21 15:24:25 +00:00

43 lines
1.2 KiB
Diff

Revision: 517
http://rpy.svn.sourceforge.net/rpy/?rev=517&view=rev
Author: warnes
Date: 2008-05-14 10:10:57 -0700 (Wed, 14 May 2008)
Log Message:
-----------
Turn off debug build flag for default installs, add todo about Rlapack/lapack
Modified Paths:
--------------
trunk/rpy/setup.py
Modified: trunk/rpy/setup.py
===================================================================
--- trunk/rpy/setup.py 2008-05-14 17:05:47 UTC (rev 516)
+++ trunk/rpy/setup.py 2008-05-14 17:10:57 UTC (rev 517)
@@ -30,13 +30,14 @@
See the files INSTALL.UNIX and INSTALL.WINDOWS for more details.
"""
-DEBUG=True
+DEBUG=False
import os, os.path, sys, shutil, re
from distutils.core import setup, Extension
from distutils.sysconfig import *
from distutils.errors import *
import rpy_tools
+
if sys.platform=="win32":
import rpy_wintools
@@ -85,7 +86,7 @@
get_config_vars()['OPT'] = '-g -Wall'
else:
# to avoid strict prototypes errors from R includes
- get_config_vars()['OPT'] = '-DNDEBUG -g -O3 -Wall'
+ get_config_vars()['OPT'] = '-DNDEBUG -O3 -Wall'
# get the Python version
if sys.version[:3] >= '2.2':