Fix rpy to find R headers in new home /usr/include/R.

This commit is contained in:
Tom Callaway 2008-01-08 00:47:30 +00:00
parent 18429a2965
commit 116cd24742
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,11 @@
diff -up rpy-1.0-RC3/setup.py.BAD rpy-1.0-RC3/setup.py
--- rpy-1.0-RC3/setup.py.BAD 2008-01-07 19:43:13.000000000 -0500
+++ rpy-1.0-RC3/setup.py 2008-01-07 19:45:18.000000000 -0500
@@ -131,6 +131,7 @@ for RHOME in RHOMES:
else: # unix-like systems, this is known to work for Linux and Solaris
include_dirs = [ os.path.join(RHOME.strip(), 'include'),
'src' ]
+ include_dirs.append("/usr/include/R/")
libraries=['R','Rlapack']
library_dirs = r_libs
runtime_libs = r_libs

View File

@ -7,12 +7,13 @@
Name: rpy
Summary: Python interface to the R language
Version: 1.0
Release: 0.6%{?pred}%{?dist}
Release: 0.7%{?pred}%{?dist}
Url: http://rpy.sourceforge.net
Source: http://dl.sf.net/%{name}/%{name}-%{version}%{?pre}.tar.gz
License: GPLv2+
Group: Development/Libraries
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch0: rpy-1.0-RC3-FHSinclude.patch
BuildRequires: R-devel = 2.6.1, numpy, python-devel, texinfo, tetex
@ -30,6 +31,8 @@ converted to Python exceptions.
%prep
%setup -n %{name}-%{version}%{?pre}
# Rawhide now puts the R headers in /usr/include/R
%patch0 -p1
%build
env CFLAGS="$RPM_OPT_FLAGS" python setup.py build
@ -68,6 +71,9 @@ fi
%changelog
* Mon Jan 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0-0.7.RC3
- find the moved R headers in their new home (/usr/include/R)
* Mon Jan 7 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 1.0-0.6.RC3
- BuildRequires: R-devel rather than just R