45 lines
1.5 KiB
Diff
45 lines
1.5 KiB
Diff
From 1e38abe3e6697efcf55663060533e286e1e77ae4 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <1e38abe3e6697efcf55663060533e286e1e77ae4.1488964568.git.pmatilai@redhat.com>
|
|
In-Reply-To: <189b4f88c8e100155ec23a1e0b214bdc8473532a.1488964568.git.pmatilai@redhat.com>
|
|
References: <189b4f88c8e100155ec23a1e0b214bdc8473532a.1488964568.git.pmatilai@redhat.com>
|
|
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
Date: Wed, 10 Aug 2016 13:58:30 +0200
|
|
Subject: [PATCH 08/11] configure.ac: use LIBDW always conditionally
|
|
|
|
References: https://bugzilla.redhat.com/show_bug.cgi?id=1365278
|
|
Reported-and-tested-by: Neal Gompa <ngompa13@gmail.com>
|
|
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
---
|
|
configure.ac | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 08eceeb..5dd2bb6 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -368,7 +368,8 @@ AM_CONDITIONAL(WITH_ARCHIVE,[test "$with_archive" = yes])
|
|
|
|
#=================
|
|
# Check for elfutils libdw library with dwelf_elf_gnu_build_id.
|
|
-AS_IF([test "$WITH_LIBELF" = yes],[
|
|
+WITH_LIBDW_LIB=
|
|
+AS_IF([test "$WITH_LIBELF" != yes],[
|
|
AC_CHECK_HEADERS([elfutils/libdwelf.h],[
|
|
AC_CHECK_LIB(dw, dwelf_elf_gnu_build_id, [
|
|
AC_DEFINE(HAVE_LIBDW, 1,
|
|
@@ -377,9 +378,9 @@ AS_IF([test "$WITH_LIBELF" = yes],[
|
|
WITH_LIBDW=yes
|
|
])
|
|
])
|
|
- AC_SUBST(WITH_LIBDW_LIB)
|
|
- AM_CONDITIONAL(LIBDW,[test "$WITH_LIBDW" = yes])
|
|
])
|
|
+AC_SUBST(WITH_LIBDW_LIB)
|
|
+AM_CONDITIONAL(LIBDW,[test "$WITH_LIBDW" = yes])
|
|
|
|
#=================
|
|
# Process --with/without-external-db
|
|
--
|
|
2.9.3
|
|
|