rpm/rpm-4.7.2-chmod-selinux.patch

13 lines
513 B
Diff

diff -up rpm-4.7.2/configure.ac.chmod-test rpm-4.7.2/configure.ac
--- rpm-4.7.2/configure.ac.chmod-test 2009-11-25 09:19:30.000000000 +0200
+++ rpm-4.7.2/configure.ac 2009-12-04 11:23:39.000000000 +0200
@@ -61,7 +61,7 @@ AC_MSG_CHECKING(POSIX chmod)
touch foo.chmodtest
chmod 744 foo.chmodtest
chmod +X foo.chmodtest 2>/dev/null
-a=`ls -l foo.chmodtest | awk '{print $1}'`
+a=`ls -l foo.chmodtest | awk '{print substr($1,1,10)}'`
rm -f foo.chmodtest
if test "$a" = "-rwxr-xr-x"; then
AC_MSG_RESULT(yes)