Make sure that test results are not ignored

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
Igor Gnatenko 2017-07-24 08:42:04 +02:00
parent 54b0c6f766
commit e3181b4ffb
5 changed files with 35 additions and 6 deletions

View File

@ -22,7 +22,7 @@ Signed-off-by: Mark Wielaard <mark@klomp.org>
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/scripts/find-debuginfo.sh b/scripts/find-debuginfo.sh
index 5ec52d3..b83e4c6 100644
index 5ec52d3bc..b83e4c6db 100644
--- a/scripts/find-debuginfo.sh
+++ b/scripts/find-debuginfo.sh
@@ -247,12 +247,16 @@ add_minidebug()

View File

@ -18,7 +18,7 @@ in both python2 and python3.
1 file changed, 1 insertion(+)
diff --git a/python/rpmsystem-py.h b/python/rpmsystem-py.h
index 50e8770..c8423e3 100644
index 50e8770e8..c8423e3dc 100644
--- a/python/rpmsystem-py.h
+++ b/python/rpmsystem-py.h
@@ -5,6 +5,7 @@

View File

@ -9,7 +9,7 @@ Subject: [PATCH] Fix error handling in rpmio Python binding test case
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/rpmpython.at b/tests/rpmpython.at
index 949673b..eac31b2 100644
index 949673bd8..eac31b20b 100644
--- a/tests/rpmpython.at
+++ b/tests/rpmpython.at
@@ -53,7 +53,7 @@ for iot in [ 'fpio', 'fdio', 'ufdio', 'gzdio' ]:

View File

@ -0,0 +1,23 @@
From ee2eec7c7922f8927b4850b385da26384ad05755 Mon Sep 17 00:00:00 2001
From: Jun Aruga <jaruga@redhat.com>
Date: Mon, 3 Jul 2017 17:07:56 +0200
Subject: [PATCH] Return error exit status when make check is failed.
(cherry picked from commit 45d9f54e9669ed44cc632247483f49a42725849b)
---
tests/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 83586ec67..4ccc1a092 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -125,7 +125,7 @@ check_DATA += testing$(bindir)/rpmbuild
if HAVE_FAKECHROOT
check-local: $(check_DATA)
- $(SHELL) '$(TESTSUITE)' $(TESTSUITEFLAGS) ||:
+ $(SHELL) '$(TESTSUITE)' $(TESTSUITEFLAGS)
else
check-local:
echo "you need to have fakechroot installed"

View File

@ -29,7 +29,7 @@
Summary: The RPM package management system
Name: rpm
Version: %{rpmver}
Release: %{?snapver:0.%{snapver}.}35%{?dist}
Release: %{?snapver:0.%{snapver}.}36%{?dist}
Group: System Environment/Base
Url: http://www.rpm.org/
Source0: http://ftp.rpm.org/releases/%{srcdir}/%{name}-%{srcver}.tar.bz2
@ -149,8 +149,11 @@ Patch332: 0056-find-debuginfo.sh-Add-keep-section-and-remove-sectio.patch
Patch333: 0057-find-debuginfo.sh-Remove-non-allocated-NOBITS-sectio.patch
# Fix rpmfd_write on big endian arches.
patch334: 0058-Define-PY_SSIZE_T_CLEAN.patch
patch335: 0059-Fix-error-handling-in-rpmio-Python-binding-test-case.patch
Patch334: 0058-Define-PY_SSIZE_T_CLEAN.patch
Patch335: 0059-Fix-error-handling-in-rpmio-Python-binding-test-case.patch
# Finally make sure that test results are not ignored ;)
Patch340: 0060-Return-error-exit-status-when-make-check-is-failed.patch
# These are not yet upstream
Patch902: rpm-4.7.1-geode-i686.patch
@ -648,6 +651,9 @@ exit 0
%doc doc/librpm/html/*
%changelog
* Mon Jul 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.13.0.1-36
- Make sure that test results are not ignored
* Sun Jul 23 2017 Mark Wielaard <mjw@fedoraproject.org> - 4.13.0.1-35
- Fix rpmfd_write on big endian arches.