Fix libbzip2 detection

This commit is contained in:
Florian Festi 2023-05-15 18:28:41 +02:00
parent e66b981d90
commit b1dddb5038
2 changed files with 32 additions and 1 deletions

View File

@ -0,0 +1,27 @@
From d18d6ce41df4a5887df47a69052a401808aef19f Mon Sep 17 00:00:00 2001
From: Florian Festi <ffesti@redhat.com>
Date: Mon, 8 May 2023 17:50:21 +0200
Subject: [PATCH] Fix bzip2 detection
HAVE_BZLIB_H was not set due to a typo leading to the bz2 support not
being compiled in although the library was detected correctly.
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9718505bf..4a5332f4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -272,7 +272,7 @@ id0name(UID_0_USER /etc/passwd)
id0name(GID_0_GROUP /etc/group)
# map module/package findings to config.h
-if (${Bzip2_FOUND})
+if (${BZIP2_FOUND})
set(HAVE_BZLIB_H 1)
endif()
if (${LIBLZMA_FOUND})
--
2.40.1

View File

@ -32,7 +32,7 @@
%global rpmver 4.18.90
#global snapver rc1
%global baserelease 2
%global baserelease 3
%global sover 10
%global oldsover 9
@ -151,6 +151,7 @@ rpm-4.18.90-weak-user-group.patch
# ...
0001-Remove-second-share-dir-from-infodir-and-mandir.patch
0001-Add-pgpVerifySignature2-and-pgpPrtParams2.patch
0001-Fix-bzip2-detection.patch
# These are not yet upstream
rpm-4.7.1-geode-i686.patch
@ -646,6 +647,9 @@ fi
%doc %{_defaultdocdir}/rpm/API/
%changelog
* Mo May 15 2023 Florian Festi <ffesti@redhat.com> - 4.18.90-3
- Fix libbzip2 detection
* Thu May 11 2023 Florian Festi <ffesti@redhat.com> - 4.18.90-2
- Add compat links for building dnf and friends