Drop patches already in 4.18.1 tarball

These were forgotten in commit 7bfe20af40
This commit is contained in:
Michal Domonkos 2023-04-24 10:07:45 +02:00
parent 8a4b8c5cfe
commit a0551c6d3b
4 changed files with 0 additions and 185 deletions

View File

@ -1,28 +0,0 @@
From 3103d307063c71ff7791c2a59aacd41cfa05285c Mon Sep 17 00:00:00 2001
Message-Id: <3103d307063c71ff7791c2a59aacd41cfa05285c.1676544357.git.pmatilai@redhat.com>
From: Panu Matilainen <pmatilai@redhat.com>
Date: Thu, 16 Feb 2023 12:18:02 +0200
Subject: [PATCH 1/2] Exclude kernel modules from ELF dependency generation
The kernel modules are technically ELF DSO's but we only care about
library level dependencies which the kernel modules will never have, so
processing them is just waste of time.
This "regressed" when we dropped the "exeonly" flag from ELF in
commit 8901a6be1652519c4875436e29e0a663be0790b7.
---
fileattrs/elf.attr | 1 +
1 file changed, 1 insertion(+)
diff --git a/fileattrs/elf.attr b/fileattrs/elf.attr
index 58322d3cd..21bc471b0 100644
--- a/fileattrs/elf.attr
+++ b/fileattrs/elf.attr
@@ -1,3 +1,4 @@
%__elf_provides %{_rpmconfigdir}/elfdeps --provides
%__elf_requires %{_rpmconfigdir}/elfdeps --requires
%__elf_magic ^(setuid,? )?(setgid,? )?(sticky )?ELF (32|64)-bit.*$
+%__elf_exclude_path ^/lib/modules/.*\.ko?(\.[[:alnum:]]*)$
--
2.39.1

View File

@ -1,31 +0,0 @@
From a3d11f7a53811e42cbe36a91a1583a723c2fe108 Mon Sep 17 00:00:00 2001
Message-Id: <a3d11f7a53811e42cbe36a91a1583a723c2fe108.1670413818.git.pmatilai@redhat.com>
From: Panu Matilainen <pmatilai@redhat.com>
Date: Mon, 6 Jun 2022 12:04:15 +0300
Subject: [PATCH] Fix potential uninitialized variable use in
rpmtsImportPubkey()
Commit d703160334ff545ce8bf7475da5689422f43dacc introduced a new step
to key import which can fail before keyring is initialized.
Always initialize your variables, never need "fixes" like this.
---
lib/rpmts.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/rpmts.c b/lib/rpmts.c
index 0b6b7ac6b..b1c80b9c8 100644
--- a/lib/rpmts.c
+++ b/lib/rpmts.c
@@ -609,7 +609,7 @@ rpmRC rpmtsImportPubkey(const rpmts ts, const unsigned char * pkt, size_t pktlen
rpmPubkey *subkeys = NULL;
int subkeysCount = 0;
rpmVSFlags oflags = rpmtsVSFlags(ts);
- rpmKeyring keyring;
+ rpmKeyring keyring = NULL;
rpmtxn txn = rpmtxnBegin(ts, RPMTXN_WRITE);
int krc, i;
--
2.38.1

View File

@ -1,82 +0,0 @@
From de0b9d142ad8bada4d49afeee95616fee265d44f Mon Sep 17 00:00:00 2001
Message-Id: <de0b9d142ad8bada4d49afeee95616fee265d44f.1673264828.git.pmatilai@redhat.com>
From: Panu Matilainen <pmatilai@redhat.com>
Date: Mon, 9 Jan 2023 12:56:34 +0200
Subject: [PATCH] Generate Python egg-info from automake builds
To compensate for the loss of egg-info from the python distutils build,
create one ourselves.
This is effectively a backport of e31fb5b75898bfa09180dba02475c6d01764d94f
which dismissed the need for an automake version, but unfortunately Python
3.12 and automake-based rpm versions do co-exist in the same time-space
continuum and we'll have to deal with this in rpm 4.18 as well.
As to why not just use distutils from python-setuptools: that variant
turns the egg-info into a directory, which in rpm is a one-way street.
And we don't need that multi megabyte Python library to fill in these
couple of values, really.
---
configure.ac | 1 +
python/Makefile.am | 9 ++++++++-
python/rpm.egg-info.in | 10 ++++++++++
3 files changed, 19 insertions(+), 1 deletion(-)
create mode 100644 python/rpm.egg-info.in
diff --git a/configure.ac b/configure.ac
index fbbfead89..5f5842590 100644
--- a/configure.ac
+++ b/configure.ac
@@ -964,5 +964,6 @@ AC_CONFIG_FILES([Makefile
tests/Makefile
plugins/Makefile
python/setup.py
+ python/rpm.egg-info
])
AC_OUTPUT
diff --git a/python/Makefile.am b/python/Makefile.am
index ec3608134..04168406d 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -3,14 +3,21 @@
include $(top_srcdir)/rpm.am
AM_CFLAGS = @RPMCFLAGS@
-EXTRA_DIST = rpm/__init__.py rpm/transaction.py
+CLEANFILES =
+EXTRA_DIST = rpm/__init__.py rpm/transaction.py rpm.egg-info.in
AM_CPPFLAGS = -I$(top_srcdir)/include/
AM_CPPFLAGS += -I$(top_srcdir)/python
AM_CPPFLAGS += @PYTHON_CFLAGS@
+egginfo = $(PACKAGE_NAME)-$(PACKAGE_VERSION)-py$(PYTHON_VERSION).egg-info
+$(egginfo):
+ cat rpm.egg-info > $(egginfo)
+CLEANFILES += $(egginfo)
+
pkgpyexec_LTLIBRARIES = _rpm.la
pkgpyexec_DATA = rpm/__init__.py rpm/transaction.py
+pyexec_DATA = $(egginfo)
_rpm_la_LDFLAGS = -module -avoid-version -shared
_rpm_la_LIBADD = \
diff --git a/python/rpm.egg-info.in b/python/rpm.egg-info.in
new file mode 100644
index 000000000..838ce5854
--- /dev/null
+++ b/python/rpm.egg-info.in
@@ -0,0 +1,10 @@
+Metadata-Version: 1.0
+Name: @PACKAGE_NAME@
+Version: @PACKAGE_VERSION@
+Summary: Python bindings for rpm
+Home-page: @PACKAGE_URL@
+Author: Rpm community
+Author-email: rpm-maint@lists.rpm.org
+License: GNU General Public License v2
+Description: Python bindings for rpm
+Platform: UNKNOWN
--
2.39.0

View File

@ -1,44 +0,0 @@
From 31356bf81c247871d6e4461565f4b33c1e6a145a Mon Sep 17 00:00:00 2001
Message-Id: <31356bf81c247871d6e4461565f4b33c1e6a145a.1676544357.git.pmatilai@redhat.com>
In-Reply-To: <3103d307063c71ff7791c2a59aacd41cfa05285c.1676544357.git.pmatilai@redhat.com>
References: <3103d307063c71ff7791c2a59aacd41cfa05285c.1676544357.git.pmatilai@redhat.com>
From: Panu Matilainen <pmatilai@redhat.com>
Date: Thu, 16 Feb 2023 12:25:24 +0200
Subject: [PATCH 2/2] Disable debuginfod server lookups in build and dependency
generator scripts
With recent elfutils (0.182 or so) various seemingly innocuous tools
such as `readelf` like to do network lookups for ELF symbol information.
There's no circumstance where we'd want that to happen during rpmbuild,
so disable these lookups during all spec build scriptlets and also
dependency generator children.
---
build/rpmfc.c | 1 +
macros.in | 1 +
2 files changed, 2 insertions(+)
diff --git a/build/rpmfc.c b/build/rpmfc.c
index 06205469c..a69e81f44 100644
--- a/build/rpmfc.c
+++ b/build/rpmfc.c
@@ -316,6 +316,7 @@ static int getOutputFrom(ARGV_t argv,
rpmlog(RPMLOG_DEBUG, "\texecv(%s) pid %d\n",
argv[0], (unsigned)getpid());
+ unsetenv("DEBUGINFOD_URLS");
if (buildRoot)
setenv("RPM_BUILD_ROOT", buildRoot, 1);
diff --git a/macros.in b/macros.in
index 7398a0496..307086a2b 100644
--- a/macros.in
@@ -724,6 +724,7 @@ package or when debugging this package.\
LANG=C\
export LANG\
unset CDPATH DISPLAY ||:\
+ unset DEBUGINFOD_URLS ||:\
%{?buildroot:RPM_BUILD_ROOT=\"%{u2p:%{buildroot}}\"\
export RPM_BUILD_ROOT}\
%{?_javaclasspath:CLASSPATH=\"%{_javaclasspath}\"\
+++ b/macros.in
--