- update to 4.11.3
This commit is contained in:
parent
af499afec3
commit
69d1f81c9b
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/rpm-4.11.1-rc2.tar.bz2
|
||||
/rpm-4.11.1.tar.bz2
|
||||
/rpm-4.11.2.tar.bz2
|
||||
/rpm-4.11.3.tar.bz2
|
||||
|
@ -1,61 +0,0 @@
|
||||
--- rpm-4.11.0.1/python/setup.py.in.setuppy-fixes 2012-11-07 13:55:24.000000000 +0100
|
||||
+++ rpm-4.11.0.1/python/setup.py.in 2013-04-03 14:16:48.149931703 +0200
|
||||
@@ -1,13 +1,19 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
from distutils.core import setup, Extension
|
||||
+import os
|
||||
import subprocess
|
||||
from glob import glob
|
||||
|
||||
def pkgconfig(what):
|
||||
out = []
|
||||
cmd = 'pkg-config %s %s' % (what, '@PACKAGE_NAME@')
|
||||
- pcout = subprocess.check_output(cmd.split()).decode()
|
||||
+ env = dict(os.environ, **{'PKG_CONFIG_PATH': '..'})
|
||||
+ proc = subprocess.Popen(cmd.split(),
|
||||
+ stdout=subprocess.PIPE,
|
||||
+ stderr=subprocess.PIPE,
|
||||
+ env=env)
|
||||
+ pcout = proc.communicate()[0].decode()
|
||||
for token in pcout.split():
|
||||
out.append(token[2:])
|
||||
return out
|
||||
@@ -18,7 +24,8 @@
|
||||
srcs.extend(glob('%s*.c' % n))
|
||||
return srcs
|
||||
|
||||
-cflags = ['-std=c99']
|
||||
+cflags = ['-std=c99', '-I../include']
|
||||
+additional_link_args = ['-Wl,-L../rpmio/.libs', '-Wl,-L../lib/.libs', '-Wl,-L../build/.libs', '-Wl,-L../sign/.libs']
|
||||
|
||||
rpmmod = Extension('rpm._rpm',
|
||||
sources = mksources([
|
||||
@@ -28,21 +35,24 @@
|
||||
]),
|
||||
include_dirs = pkgconfig('--cflags'),
|
||||
libraries = pkgconfig('--libs'),
|
||||
- extra_compile_args = cflags
|
||||
+ extra_compile_args = cflags,
|
||||
+ extra_link_args = additional_link_args
|
||||
)
|
||||
|
||||
rpmbuild_mod = Extension('rpm._rpmb',
|
||||
sources = mksources(['rpmbmodule', 'spec']),
|
||||
include_dirs = pkgconfig('--cflags'),
|
||||
libraries = pkgconfig('--libs') + ['rpmbuild'],
|
||||
- extra_compile_args = cflags
|
||||
+ extra_compile_args = cflags,
|
||||
+ extra_link_args = additional_link_args
|
||||
)
|
||||
|
||||
rpmsign_mod = Extension('rpm._rpms',
|
||||
sources = mksources(['rpmbmodule']),
|
||||
include_dirs = pkgconfig('--cflags'),
|
||||
libraries = pkgconfig('--libs') + ['rpmsign'],
|
||||
- extra_compile_args = cflags
|
||||
+ extra_compile_args = cflags,
|
||||
+ extra_link_args = additional_link_args
|
||||
)
|
||||
|
||||
setup(name='@PACKAGE_NAME@-python',
|
10
rpm.spec
10
rpm.spec
@ -11,7 +11,7 @@
|
||||
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%define rpmver 4.11.2
|
||||
%define rpmver 4.11.3
|
||||
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||
|
||||
%define bdbname libdb
|
||||
@ -21,7 +21,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.11.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -65,8 +65,6 @@ Patch305: rpm-4.10.0-dwz-debuginfo.patch
|
||||
Patch306: rpm-4.10.0-minidebuginfo.patch
|
||||
# Fix CRC32 after dwz (#971119)
|
||||
Patch307: rpm-4.11.1-sepdebugcrcfix.patch
|
||||
# To be upstreamed in slightly different form
|
||||
Patch308: rpm-4.11.0.1-setuppy-fixes.patch
|
||||
# Temporary Patch to provide support for updates
|
||||
Patch400: rpm-4.10.90-rpmlib-filesystem-check.patch
|
||||
|
||||
@ -264,7 +262,6 @@ packages on a system.
|
||||
%patch305 -p1 -b .dwz-debuginfo
|
||||
%patch306 -p1 -b .minidebuginfo
|
||||
%patch307 -p1 -b .sepdebugcrcfix
|
||||
%patch308 -p1 -b .setuppy-fixes
|
||||
|
||||
%patch400 -p1 -b .rpmlib-filesystem-check
|
||||
|
||||
@ -515,6 +512,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Fri Sep 05 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.3-1
|
||||
- update to 4.11.3 (http://rpm.org/wiki/Releases/4.11.3)
|
||||
|
||||
* Tue Feb 18 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-2
|
||||
- reduce the double separator spec parse error into a warning (#1065563)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user