Fix debugedit for ppc relocations (#199473)
This commit is contained in:
parent
f713820f42
commit
63e6a29407
11
rpm-4.4.2-debugedit-ppc-reloc.patch
Normal file
11
rpm-4.4.2-debugedit-ppc-reloc.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- tools/debugedit.c 20 May 2004 21:30:00 -0000 2.8
|
||||||
|
+++ tools/debugedit.c 19 Jul 2006 19:17:49 -0000
|
||||||
|
@@ -1034,7 +1034,7 @@ edit_dwarf2 (DSO *dso)
|
||||||
|
break;
|
||||||
|
case EM_PPC:
|
||||||
|
case EM_PPC64:
|
||||||
|
- if (rtype != R_PPC_ADDR32 || rtype != R_PPC_UADDR32)
|
||||||
|
+ if (rtype != R_PPC_ADDR32 && rtype != R_PPC_UADDR32)
|
||||||
|
goto fail;
|
||||||
|
break;
|
||||||
|
case EM_S390:
|
7
rpm.spec
7
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
|||||||
%define version 4.4.2
|
%define version 4.4.2
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 29
|
Release: 30
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||||
Source1: mono-find-provides
|
Source1: mono-find-provides
|
||||||
@ -56,6 +56,7 @@ Patch27: rpm-4.4.2-noselinux-verify.patch
|
|||||||
Patch28: rpm-4.4.2-python-aslist.patch
|
Patch28: rpm-4.4.2-python-aslist.patch
|
||||||
Patch29: rpm-4.4.2-rpmio-ipv6.patch
|
Patch29: rpm-4.4.2-rpmio-ipv6.patch
|
||||||
Patch30: rpm-4.4.2-gnuhash.patch
|
Patch30: rpm-4.4.2-gnuhash.patch
|
||||||
|
Patch31: rpm-4.4.2-debugedit-ppc-reloc.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Conflicts: patch < 2.5
|
Conflicts: patch < 2.5
|
||||||
%ifos linux
|
%ifos linux
|
||||||
@ -199,6 +200,7 @@ shell-like rules.
|
|||||||
%patch28 -p1 -b .aslist
|
%patch28 -p1 -b .aslist
|
||||||
%patch29 -p1 -b .ipv6
|
%patch29 -p1 -b .ipv6
|
||||||
%patch30 -p1 -b .gnuhash
|
%patch30 -p1 -b .gnuhash
|
||||||
|
%patch31 -p0 -b .dbgppc
|
||||||
|
|
||||||
# rebuild configure for ipv6
|
# rebuild configure for ipv6
|
||||||
autoconf
|
autoconf
|
||||||
@ -595,6 +597,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 19 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-30
|
||||||
|
- Fix debugedit for ppc relocations (#199473)
|
||||||
|
|
||||||
* Fri Jul 14 2006 David Cantrell <dcantrell@redhat.com> - 4.4.2-29
|
* Fri Jul 14 2006 David Cantrell <dcantrell@redhat.com> - 4.4.2-29
|
||||||
- Fixed null pointer problem in rpmfcELF() DT_GNU_HASH handling
|
- Fixed null pointer problem in rpmfcELF() DT_GNU_HASH handling
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user