- Fix Python import directive for more strict Python3 search rules

- Resolves: #1236493
This commit is contained in:
Florian Festi 2015-06-29 12:18:50 +02:00
parent 8e0e97732b
commit 3b6a3d6051
2 changed files with 34 additions and 1 deletions

View File

@ -0,0 +1,29 @@
From 97989236c0f39ccbc7f2c1d52cc30f167fd827fe Mon Sep 17 00:00:00 2001
From: Florian Festi <ffesti@redhat.com>
Date: Mon, 26 Jan 2015 14:22:34 +0100
Subject: [PATCH] Fix Python import directive for more strict Python3 search
rules
Fixes http://rpm.org/ticket/885
---
python/rpm/transaction.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/python/rpm/transaction.py b/python/rpm/transaction.py
index db7ca67..91a6cc1 100644
--- a/python/rpm/transaction.py
+++ b/python/rpm/transaction.py
@@ -37,8 +37,8 @@ class TransactionSet(TransactionSetCore):
return self._wrapSetGet('_probFilter', ignoreSet)
def parseSpec(self, specfile):
- import _rpmb
- return _rpmb.spec(specfile)
+ import rpm._rpmb
+ return rpm._rpmb.spec(specfile)
def getKeys(self):
keys = []
--
2.1.0

View File

@ -27,7 +27,7 @@
Summary: The RPM package management system
Name: rpm
Version: %{rpmver}
Release: %{?snapver:0.%{snapver}.}11%{?dist}
Release: %{?snapver:0.%{snapver}.}12%{?dist}
Group: System Environment/Base
Url: http://www.rpm.org/
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
@ -64,6 +64,7 @@ Patch104: rpm-4.12.0-golang-debuginfo.patch
Patch105: rpm-4.12.0-whatrecommends.patch
Patch108: rpm-4.12.0-gpg-passphrase1.patch
Patch109: rpm-4.12.0-gpg-passphrase2.patch
Patch110: rpm-4.12.0-Fix-Python3-import.patch
# These are not yet upstream
Patch302: rpm-4.7.1-geode-i686.patch
@ -548,6 +549,9 @@ exit 0
%doc doc/librpm/html/*
%changelog
* Mon Jun 29 2015 Florian Festi <ffesti@rpm.org> - 4.12.0.1-12
- Fix Python import directive for more strict Python3 search rules (#1236493)
* Fri Jun 19 2015 Lubos Kardos <lkardos@redhat.com> 4.12.0.1-11
- Allow gpg to get passphrase by itself (#1228234)