fd8bf6984f
- Fix to sentinel systemd service and configuration (thanks Remi) - Refresh patch management
40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
From 9083bd267135c4d3404c2f1f4a90e900cc13c097 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
|
Date: Thu, 11 Sep 2014 13:40:54 +0200
|
|
Subject: [PATCH 2/5] redis 2.8.11: deps library fPIC performance tuning
|
|
|
|
---
|
|
deps/Makefile | 2 +-
|
|
deps/linenoise/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/deps/Makefile b/deps/Makefile
|
|
index e183ede..9dcb6b1 100644
|
|
--- a/deps/Makefile
|
|
+++ b/deps/Makefile
|
|
@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
|
|
LUA_CFLAGS= -D__C99FEATURES__=1
|
|
endif
|
|
|
|
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
|
|
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS) -fPIC
|
|
LUA_LDFLAGS+= $(LDFLAGS)
|
|
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
|
# challenging to cross-compile lua (and redis). These defines make it easier
|
|
diff --git a/deps/linenoise/Makefile b/deps/linenoise/Makefile
|
|
index 1dd894b..712f2a6 100644
|
|
--- a/deps/linenoise/Makefile
|
|
+++ b/deps/linenoise/Makefile
|
|
@@ -2,7 +2,7 @@ STD=
|
|
WARN= -Wall
|
|
OPT= -Os
|
|
|
|
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
|
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
|
|
R_LDFLAGS= $(LDFLAGS)
|
|
DEBUG= -g
|
|
|
|
--
|
|
1.9.3
|
|
|